Invisible and unselectable flow region in image

Bug #485269 reported by Markus Poessel on 2009-11-19
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

I created a PDF with XFig and imported it into Inkscape 0.46 (running on a Mac under OS X 10.5.6, Xquartz 2.1.5 - (xorg-server 1.3.0-apple22) (2.1.5)).

When I uploaded to Wikimedia commons, I noticed a black rectangle; see various versions on http://commons.wikimedia.org/wiki/File:Sed_klasse1.svg

I tried various proposed fixes I found on Google: selecting and converting to text; selecting and converting to path.

It took a helpful commons user to find out that the file contains an empty, invisible, unselectable flow region that caused the problem. He or she removed the region using a text editor.

jazzynico (jazzynico) wrote :

Duplicate of Bug #167335 (flowed text (flowRoot) must be moved to inkscape namespace )?

tags: added: svg

Could be a duplicate - I was thrown off by the fact that in my case, I imported the image, whereas the other bug involved an original Inkscape drawing. But the apparently empty flowRoot regions look the same. Thanks!

~suv (suv-lp) wrote :

The 'un-selectability' of empty 'Flowed Text' objects might have a common cause with bug #349602 “Textbox is unselectable after text is overflowed by empty lines.”

They can be created accidentally in Inkscape with the text tool: draw a rectangle (maybe thinking you're still using the select tool), don't enter any text, click somewhere else on the canvas and the textbox disappears but leaves a unvisible svg:FlowRoot element behind (watch it happening with the XML editor open) - see question "Black blocks appear on the image when I open an SVG file with Firefox." <https://answers.launchpad.net/inkscape/+question/77542>

tags: added: text

OK, that could be it. I'm rather new to Inkscape, and could well have created empty text boxes in the way you describe. Thanks for the info!

~suv (suv-lp) wrote :

Another workaround to find empty 'Flowed text' objects:
1) 'Edit > Deselect'
2) activate the text tool
3) use <TAB> to cycle through all text objects in the drawing and watch the status line for the message "Type or edit flowed text (0 characters); Enter to start new paragraph"
4) use <DEL> or <Backspace> to delete the selected empty 'Flowed Text' object
5) continue with <TAB> until the first text object is selected again

Both issue as reported and workaround reproduced with Inkscape 0.46+devel r22575 on OS X 10.5.8.

Confirming this as bug because empty flowed text boxes should not be left behind invisible and barely selectable regardless of whether the flowed text object (svg:flowRoot containing svg:flowRegion and svg:flowPara) is part of the current SVG specification or is (not) recognized by other SVG viewers.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed

Thank you for the additional workaround!

~suv (suv-lp) wrote :

Alternative steps to select all 'Flowed Text' objects (empty or not):

1) open 'Edit > Find…'
2) enter 'flowRoot' into the 'ID:' field
3) search

The resulting selection contains all 'Flowed text' objects which then can be deleted or converted to regular text (shift-click those you want to keep as 'Flowed Text' to remove them from the selection).

Gari (garikolc) wrote :

I think this bug is more than a problem with the flow text.

I made a project with Inkscape and when I tried to print it I saw the black boxes. Triying to remove them I took the texts and made the "suv (suv-lp)" protocol but nothing changed.

I have isolated a sample copying it and there is no word "flow" on the svg file and everytime I try to print it on a pdf, the black boxes appears again.

~suv (suv-lp) wrote :

@Gari - this report _is_ about _flowed_ text indeed, and not about printing issues with regular text which uses gradients with transparency as fill style (the PostScript file format often used in print workflows does not support transparency).

Please file a separate report, after having made sure that the unexpected print output persists even if the text uses a plain solid black fill color (or maybe gradients with solid color stops only (e.g. black to a lighter grey)), and with a standard font instead of 'KacstOne'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers