"Color Markers to Match Stroke" doesn't work for "InfiniteStartLine" marker

Bug #479644 reported by John M. Długosz on 2009-11-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

After running "Color Markers to Match Stroke", the "..." marker is still black. The def is duplicated, but the style is not applied to the duplicate. Adding the stroke and fill to the existing style contents (it was just "visible") worked.

I suppose the script barfed when it didn't see the same element structure as most of the "markers" use.

su_v (suv-lp) on 2009-11-10
tags: added: extensions-plugins markers
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.46+devel r22566 on OS X 10.5.8

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2009-11-10
Changed in inkscape:
importance: Undecided → Low
su_v (suv-lp) wrote :

related: Bug #165865 “markers must take object's stroke color (SVG 1.2 feature)”:
<https://bugs.launchpad.net/inkscape/+bug/165865>

su_v (suv-lp) wrote :
stinkinrich88 (stinkinrich88) wrote :

still a problem with Inkscape 0.48.0 r9654 on Ubuntu 10.11

jazzynico (jazzynico) on 2011-08-29
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fix committed, trunk revision 10593.
Also fixes the same kind of issue with InfiniteEndLine and Scissor markers.

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Backported to the 0.48.x branch, revision 9826.

tags: removed: backport-proposed
Changed in inkscape:
milestone: 0.49 → 0.48.3
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers