Arc end cap not perpendicular

Bug #477969 reported by Kjohrf on 2009-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

I draw a 90 degree arc with a wide stroke. from 270 to 0 degrees.

The end caps are not perpendicular to the axes.

See attached file for sample. Not the end cap versus the horizontal and vertical guidelines.

Kjohrf (kjohrf) wrote :
su_v (suv-lp) wrote :

To me this looks like a duplicate of
Bug #167356 “Angle / rendering of arc (circle) isn't exact”
which in turn is linked as duplicate to
Bug #168218 “circles and arcs are incorrectly drawn (bezier appoximation)”
which is marked 'Fix released' in rev. 20771

Is this a regression - or is 167356 not a duplicate of 168218?

tags: added: shape-editing
Kjohrf (kjohrf) wrote :

Thought that first one was different since it had the comment about "beziers vs. circles" but I'm probabyl wrong.

FYI this is 0.47pre4 on WinXP.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.46+devel r22566 on OS X 10.5.8

su_v (suv-lp) wrote :
tags: added: renderer svg
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

@Johan - patched pass reference SVG file for testsuite

su_v (suv-lp) wrote :

Fixed with new cairo-renderer in trunk (merged in r10326).

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
importance: Undecided → Medium
su_v (suv-lp) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers