Tiled Clones / Trace: Apply to Size skews resulting clone grid

Bug #469885 reported by Kjohrf on 2009-11-02
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

I have been learning how to use the Trace tab of the Create Tiled Clones dialog,
and think I have come across a bug that is not reported.

I make a small cirlce (.025").

I make a rectangle 1" x 1" and put it at the bottom in a new, lower layer.
I make the rectangle have a gradient fill from corner to corner, black to green.

I select the small circle and go to Create Tiled Clones. I press Reset to clear all setting.
Then on the Trace tab I select Pick: Color, Invert (just to make it more obvious what it
is doing), Apply: Color and Size. 20 x 20, and Use saved size and position of the tile.

The resulting grid of tiled clones skews up as it goes to the right, instead of being
a rectangular grid.

If I de-select Apply: Size, it works correctly, but I don't get the size variation that I
wanted. The Apply: Size selection seems to be broken.

See both examples in the attached file.

Kjohrf (kjohrf) wrote :
su_v (suv-lp) on 2009-11-02
tags: added: transformations
su_v (suv-lp) wrote :

Bug: The 'translate' attribute of the group 'Layer 1' causes the miscalculation of the coordinates of the clones.
Workaround: moving the original ellipse to or creating a new original ellipse on a (new) layer without 'translate' attribute.

workaround A
1) select original ellipse
2) apply 'Edit > Clones > Create Tilde Clones… > Remove'
3) keep original ellipse selected
4) use 'Layer > Move Selection to Layer Below' (image)
5) apply 'Edit > Clones > Create Tiled Clones… > Trace'

workaround B
1) select original ellipse
2) apply 'Edit > Clones > Create Tilde Clones… > Remove'
3) use 'Layer > Add Layer…' above current layer
4) create new original ellipse on the new layer
5) apply 'Edit > Clones > Create Tiled Clones… > Trace'

most likely duplicate of bug #168651 "Tiled Clones" inside transformed groups broken

Changed in inkscape:
status: New → Confirmed
Kjohrf (kjohrf) wrote :

Thanks for checking and for the workarounds.

I saw that other bug but couldn't decipher it well. :)

Kjohrf (kjohrf) wrote :

Note: I just started a new document to try Trace more. I got even a different skewing
pattern. I have only the original Layer ("Layer 1"). As soon as I use "Apply: Size"
there are problems.

su_v (suv-lp) wrote :

… attach the file and steps to reproduce if you think it's unrelated to the 'tiled clones inside transformed groups broken'.

Kjohrf (kjohrf) wrote :

It's so random. Sometimes it works. Sometimes it doesn't. But these seems reproceable to me on 0.47pre4 (Win XP still, if that matters).

Open the attached file.
On Create Tiled Clones:
  Pick: Opacity Apply: Color, Size, Opacity 20x20 Used saved size
Works fine.
Remove clones
  Now change Pick to Color. The clones are now partly highly then the rectangle.

su_v (suv-lp) wrote :

It's the same issue:

| <g
| inkscape:label="Layer 1"
| inkscape:groupmode="layer"
| id="layer1"
| transform="translate(0,-62.362)">

"Layer 1" has a translate() attribute. Remove it and the tiles (with Pick: Color) are correctly positioned.

Linking this report as duplicate to bug #168651 "Tiled Clones" inside transformed groups broken. Feel free to add a comment and revert the duplicate status if you don't agree.

Kjohrf (kjohrf) wrote :

Thanks. Don't understand what the translate attributes are (from a user perspective), but glad
you've got a handle on it.

su_v (suv-lp) wrote :

Maybe you find more information (as a starting point) here: <http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Transforms.html#Transforms-Xml>. But I guess from a users perspective attributes like 'translate()' and 'matrix()' are Inkscape internals that can stay hidden in the XML editor (as long as there's no bug ;-).

su_v (suv-lp) on 2015-02-19
tags: added: clones groups
Changed in inkscape:
importance: Undecided → Medium
status: Confirmed → Triaged
su_v (suv-lp) wrote :

Unlinked as duplicate from bug #168651 because the initial patch available there (fixes displaced clones using 'Rotation' mode) does not address the issue with displaced clones in 'Trace' mode.

Mc (mc...) on 2015-02-21
Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Triaged → In Progress
Mc (mc...) wrote :

patch committed in rev 13934

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2015-02-21
Changed in inkscape:
milestone: none → 0.92
tags: added: backport-proposed
ScislaC (scislac) wrote :

trunk r13934 backported in 0.91.x r13760

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers