SVG with media output fails with special characters

Bug #456248 reported by jazzynico on 2009-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

This extension is affected by the same problem as Bug #386069 (Embed extension fails, see comment 37), that is special characters such as à, é, etc. are not properly decoded when used in the path or name of the linked images or the svg file.
I could easily fix the URL check (already fixed in Bug #386069), but there are other issues regarding how the filenames are encoded in the zip file.
Probably too late for 0.47...

jazzynico (jazzynico) on 2010-01-29
Changed in inkscape:
milestone: 0.47.1 → 0.48
status: New → In Progress
Changed in inkscape (Ubuntu):
status: New → Confirmed
jazzynico (jazzynico) wrote :

Still in progress.
And I still have problems with zip encoding:
* Works well on Windows if I use cp437 (bug unusable on Linux).
* Works well on Linux if I use latin-1 (bug unusable on Windows).
* Doesn't work at all with utf-8.

Does anyone have a clue?

jazzynico (jazzynico) wrote :

Not surprisingly I have the same kind of issue if I compress a file on Ubuntu (tar.gz or .zip) and try to open it on Windows, and vice versa (only 7zip format seems to work well).
Switching to lzma could be a solution, but it is not supported in the current Python version as a default module and I'm reluctant to add another external one.

I think that I will commit my current dev version, which uses cp437 on Windows and latin-1 on Linux and OSX. As long as you don't share the compressed file between these operating systems, it should work as expected.
Of course, if you don't use special characters in your path, there's no problem at all!

jazzynico (jazzynico) wrote :

New version committed in bzr rev. 9134.
I'm going to open a new report for the cross-platform issue.

Changed in inkscape:
status: In Progress → Fix Committed
Alex Valavanis (valavanisalex) wrote :

Adding upstream patch which fixes this bug

Jon A. Cruz (jon-joncruz) wrote :

using cp437 really sounds like a work-around and not a full solution. We should look into that aspect.

jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
Alex Valavanis (valavanisalex) wrote :

This bug will be fixed in Ubuntu with the release of inkscape_0.48.0-1ubuntu1, which will appear in Maverick shortly. Please see bug #628048 for details.

Changed in inkscape (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.0-1ubuntu1

---------------
inkscape (0.48.0-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
    LP: #463602, LP: #591986)
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
    - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  * debian/dirs:
    - Add usr/share/pixmaps. Allow inkscape.xpm installation
  * drop 50-poppler-API.dpatch (now upstream)
  * drop 51-paste-in-unwritable-directory.dpatch (now upstream)

inkscape (0.48.0-1) experimental; urgency=low

  * [cae07a3] New Upstream version 0.48.0
  * [309c498] add patch to fix crash in node tool
  * The highlights of this release are:
      - multipath editing
      - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
      - new Airbrush tool
      - LaTeX export with PDF/PS/EPS
      - JessyInk extension to create presentations
      - numerous bugfixes
  * [56702cf] don't build-depend on libssl-dev (closes: #573338)
  * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
    many thanks to him (closes: #576357)
  * [747d3d1] add README.source adopted from nagios to make lintian a
    bit happier
  * [4df0df7] Remove all patches since they are applied upstream
 -- Alex Valavanis <email address hidden> Sun, 12 Sep 2010 19:44:58 +0100

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released

You have a choice today!
We are an experienced company, who will give you a big chance!
How many days and hours should you spend at the university?
Yes
it is too long!
We offer you the way much better!
100% verified Degree: Bachelors, Masters and Doctorate (PHD).
Our professionals will answer to any your questions and suggest you the best choice!
Make it now! Make your life easier!
You should wait only 2-4 weeks.

We will help you!

+ 1 - 646 - 537 - 1732
Please leave us your:
1) Your Name
2) Your Country
3) Phone No. with countrycode if outside USA
Do Not Reply to this Email.
We do not reply to text inquiries, and our server will reject all response traffic.
We apologize for any inconvenience this may have caused you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers