Inkscape: A Vector Drawing Tool

Opening document properties closes Inkscape

Reported by EricG on 2009-10-19
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

0.47pre4-1.exe; Vista Business 32 bits

When I try to open the document properties window, Inkscape simply closes. I have to open Inkscape as administrator, open the document, and then everything is normal, even if I re-open the document later in the session as a simple user.

~suv (suv-lp) on 2009-10-19
tags: added: crash win32
EricG (eegaba) wrote :

Note: the above manipulation has to be done, in a same Win session, for each SVG file as the bug affects them independently.

~suv (suv-lp) wrote :

Does it happen with new documents as well (default template)? Any relation to linked color profiles / Color management?

EricG (eegaba) wrote :

Update after further tests:
- the bug affects new blank documents as well;
- documents without fixed color profile created with 0.46 are affected even during a same Win session, even if they are “saved as...”: re-opening these SVGs logged as simple user and trying to open the doc's properties closes Inkscape;
- the same documents with a fixed color profile (sRGB) work fine, even from a Win session to an other.

May it have also some relation with Vista's UAC as many software work fine when logged as admin but don't when logged as simple user, without any warning from Vista ?

theAdib (theadib) wrote :

Eric, could you please attach your preferences.xml file. Before and after opening as administrator.
Do you see any error message if you start inkscape from command prompt (and let it crash)?

The preferences you will find on C:\Documents and Settings\YOURUSERNAME\Application Data\inkscape\preferences.xml

Adib.

EricG (eegaba) wrote :

The first attached xml is from the simple user's folder.

EricG (eegaba) wrote :

This second is from the admin's folder.

EricG (eegaba) wrote :

The third too after having opened and closed a SVG without color profile as admin. The xml from the user's folder didn't change, of course. Any need from the “extension-errors.log” file as I can see many dependencies are missing ?

Opening Inkscape through the command lines as user doesn't display any error message but the bug still occurs.

uwesch (uwesch) wrote :

I had the same problem till i renamed my preferences.xml

My attachment is my "old" original xml file.

jazzynico (jazzynico) wrote :

Faulty preferences.xml tested on Ubuntu 9.10, Inkscape revision 22575. No crash. No error.

Changed in inkscape:
importance: Undecided → High
~suv (suv-lp) wrote :

crash not reproduced with Inkscape 0.46+devel on OS X 10.5.8: all above attached preferences files that cause Inkscape to crash on win32 tested on osx: no crash when opening document properties, no related console messages.

possibly related:
Bug #482148 “when go to menu/file/document propreties inkscape 0.47pre4-1 go in crash”. Inkscape is reported to crash on OS X when opening document properties with this last console message (no emergency save triggered):

lcms: Error #12288; Read error. Got 0 bytes, block should be of 128 bytes

jazzynico (jazzynico) wrote :

Confirmed (with uwesch's and EricG's preferences files) on Vista, Inkscape revision 22575.

Console message:
lcms: Error #12288; Corrupted profile: 'C:\Windows\system32\spool\DRIVERS\COLOR\D50.camp'

Changed in inkscape:
status: New → Confirmed
tags: added: color
jazzynico (jazzynico) wrote :

Another workaround, if you don't want to reset the preferences file:
1. Open Inkscape preferences.
2. In the color management section, uncheck Retrieve profile from display.

Or replace from_display="1" with from_display="0" in the displayprofile group in the xml file.

~suv (suv-lp) wrote :

@JazzyNico - could you test if this crash still is reproducible with a current 0.47+devel build?

jazzynico (jazzynico) wrote :

@suv - I don't have access to Vista now. I'll test tomorrow.
I've tried to reproduce this bug on XP, but it seems to affect Vista (and maybe 7) only.

jazzynico (jazzynico) wrote :

Tested on Vista. Inkscape no longer crash, but I still have the error messages.

Gemmu (gemmu) wrote :

Tested on Windows 7 Pro. Inkscape crashes when selecting "Document Properties", unless "Retrieve profile from display" is unchecked. This occurs on new blank and other documents.

Le Novere (lenov) wrote :

I reproduce the bug with Inkscape 0.48 on Kubuntu 10.10 64bits. The crash does not append if Inkscape is launched in sudo mode. Modifying the color profile loading does not change anything.

~suv (suv-lp) wrote :

@Le Novere - using Inkscape 0.48 on Kubuntu 10.10, you are most likely experiencing bug #658055 (which is unrelated to color profiles but triggered by changes in Gtk+ >= 2.22).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers