Changing the bounding box type in preferences does not update the preview

Bug #448872 reported by Bertrand Petit on 2009-10-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Vinipsmaker

Bug Description

In 0.47pre3 when changing the "Bounding box to use" preference from "visual bounding box" to "geometric bounding box" (or the reverse) while an object is selected the displayed bounding box is not updated. One has to deselect the object and select it again to be able to observe the correct bounding box.

Related branches

~suv (suv-lp) on 2009-10-12
tags: added: snapping ui
removed: boundingbox preference
~suv (suv-lp) wrote :

I am not sure if this is a bug or an RFE? I can confirm the behavior but have not seen it previously as bug. AFAIK these selection modii represent generic different drawing concepts that include or influence the way you structure and build your design They are not like grid, guides or snap that you toggle on and off while constructing complex objects. I could be wrong though. Can you explain in more detail where and how this affects your work-flow?

~suv (suv-lp) on 2009-10-15
tags: added: ui-selection-group-layer
Bertrand Petit (bp-lp) wrote :

The bug (yes I still think this is a bug) does not affect my workflow. I think that when a setting that affects the way things a drawn on display is changed or togled then the display shall be refreshed to reflect the change of setting that was just made. This behavior I describe is the same as is already implemented for the "view > display mode" sub-menu: when a different display mode is selected the on-screen rendering is immediately updated.

By the way it seems that the bouding box type preference has disapeared from 0.47pre4. Is this a bug or intended?

~suv (suv-lp) wrote :

> it seems that the bouding box type preference has disapeared from 0.47pre4.
Certainly not so ;-). It is on the first tab - see 'Preferences > Tools : Bounding box to use'.

~suv (suv-lp) wrote :

> One has to deselect the object and select it again to be able
> to observe the correct bounding box.

I had a closer look and this isn't quite true: you can keep the current selection and still trigger a redraw of the new bbox setting if you
a) use <F1> or click once on the select tool button in the vertical
   toolbox on the left.
or
b) just continue to work with your selection set - the next drag/rotate
   action will immediately update the display of the new bbox setting.

(tested with Inkscape 0.46+devel r22528 on OS X 10.5.8)

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 10.10, Inkscape trunk revision 10130.
Inkscape could be improved to immediately reflect changes in the preferences, but since there are workarounds, the issue can be considered as low importance.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
~suv (suv-lp) on 2011-05-25
tags: added: selection
removed: snapping ui-selection-group-layer
~suv (suv-lp) on 2013-03-07
tags: added: easy-fix
insaner (insaner) wrote :

is this related to bug #960986 ?

insaner (insaner) wrote :
~suv (suv-lp) wrote :

> is this related to bug #960986 ?

No.

> and/or bug #955141

No.

Both of those are regressions in trunk due to bbox caching - this one is an old missing feature.

~suv (suv-lp) on 2013-04-25
Changed in inkscape:
status: Confirmed → In Progress
assignee: nobody → Vinipsmaker (vinipsmaker)
~suv (suv-lp) wrote :

Proposed fix tested successfully on OS X 10.7.5 with Inkscape 0.48+devel r12312.

jazzynico (jazzynico) wrote :

Also tested successfully on Debian Wheezy, Inkscape trunk revision 12328.

jazzynico (jazzynico) wrote :

Branch merged revision 12329.
Thanks for the patch!

Changed in inkscape:
milestone: none → 0.49
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers