Could not find the icon 'object-visible'

Bug #446842 reported by Alvin Penner on 2009-10-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

running Windows XP, Inkscape 0.47pre3 (Sep 28 2009), I get the messages:

D:\Program Files\Inkscape>inkscapec
(inkscape.exe:3380): Gtk-WARNING **: Could not find the icon 'object-visible'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases

Alvin Penner (apenner) wrote :

this does not happen on Windows XP, Inkscape 0.47pre1 (Jul 3 2009)

su_v (suv-lp) on 2009-10-09
tags: added: ui ui-dialogs-toolbars
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape revision 22384 (and lots of older revs), but not with 0.46.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

same warning with Inkscape 0.46+devel on OS X if no 'hicolor' theme is installed.

Chris Morgan (chris.morgan) wrote :

Here is a patch for it. It will work fine on Win32, but it needs testing on Linux (don't want to go overriding the real hicolor theme index, not sure if it would do it, not sure about the distribution techniques). I think it should work for OS X.

This just creates share/icons/hicolor with an empty file in it index.theme. This stops the warning. (I think the object-visible bit is a red herring, I checked very thoroughly in the mappings files and the SVG icons file, it's all there, and it works too.) It also adds the said index.theme file to the Makefile.

~suv was the one that suggested trying it.

Chris Morgan (chris.morgan) wrote :

Looking through the valid icon paths again, I think share/inkscape/icons/hicolor could be a better location as it should never clash with anything on Linux, but there is no share/inkscape at the moment.

Alvin Penner (apenner) wrote :

just writing to confirm that, on Windows XP, the warning messages do go away if I manually create a directory \Inkscape\share\icons\hicolor\ and manually create an empty file called index.theme.

thanks for the tip...

bbyak (buliabyak) wrote :

I tested this on Ubuntu 9.10 and found that the patch has no effect whatsoever - make or make install do not create or modify any files. So I committed the patch, since the bug is really annoying on WIndows. The fix is hacky but seems harmless; if anyone can suggest anything better you're welcome.

Changed in inkscape:
status: Confirmed → Fix Released
jazzynico (jazzynico) on 2010-02-05
Changed in inkscape:
milestone: none → 0.48
Alvin Penner (apenner) wrote :

- running Windows XP, Inkscape 0.47+devel (Feb 9 2010), rev 9073, this bug has reappeared.
- code from http://old.nabble.com/windows-devel-builds-ts27344390.html
It appears that the directory \Inkscape\share\icons\hicolor\ has not been created.

Changed in inkscape:
status: Fix Released → New
Alvin Penner (apenner) wrote :

just writing to confirm that this bug still exists on Windows XP, (Feb 18 2010) bzr rev 9097

jazzynico (jazzynico) wrote :

Confirmed on XP, rev 9073 (can't test with more recent revs now).

Changed in inkscape:
milestone: 0.48 → none
status: New → Confirmed
jazzynico (jazzynico) wrote :

Fix committed in rev. 9128.
The additional folder and empty file just needed to be created in the source share/icons folder in order to be installed.

Changed in inkscape:
milestone: none → 0.48
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

Not yet fixed for osx packaging: AFAIU the new directory and the empty 'index.theme' file can't be used in the osx packaging process unless they are installed with 'make install' (as opposed to just exist in 'src/share/icons').

Changed in inkscape:
status: Fix Committed → In Progress
Alex Valavanis (valavanisalex) wrote :

Shifted the milestone as 0.48 has been released

Changed in inkscape:
milestone: 0.48 → 0.48.3
su_v (suv-lp) wrote :

Patch for 'src/packaging/macosx/osx-app.sh' to include a copy of the default hicolor icon theme index file in the application bundle.

Ted Gould (ted) on 2012-02-15
Changed in inkscape:
milestone: 0.48.3 → 0.48.4
su_v (suv-lp) on 2012-07-10
tags: added: osx packaging win32
removed: ui ui-dialogs-toolbars
su_v (suv-lp) wrote :

Fix for OS X package committed in r11762.
Backported to lp:inkscape/0.48.x in r9915.

Changed in inkscape:
status: In Progress → Fix Committed
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers