Tutorial changes for 0.91

Bug #440194 reported by jazzynico on 2009-10-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
Inkscape-docs
Medium
jazzynico

Bug Description

Tutorial strings that need to be fixed for 0.48 (see Bug #381274)

Tracing
----------
Very old tutorial (single pass only). Needs a big update.

Tips
-----
Clipping or masking a bitmap

"By default, an imported bitmap (e.g. a photo) is an <image> element which is not editable by the Node tool. To work around this, convert the image into a rectangle with pattern fill by Object to Pattern (Alt+I). This will give you a rectangle filled with your bitmap. Now this object can be converted to path, node-edited, intersected with other shapes etc. In Inkscape Preferences (Misc tab), you can set the option of always importing bitmaps as pattern-filled rectangles. "

Release Notes 0.46: Other changes and improvements

"The option Import bitmap as <image> is removed; it was added several versions ago to allow optionally importing images as rectangles with image pattern, to make clipping the images easier. Now that you can easily use clipping paths, as well as convert any image to rectangle with pattern with Alt+I, this option is not really necessary and removed to reduce confusion. Bitmaps are always imported into SVG as an <image> element. "

--
Hidden features and the XML editor

"The XML editor allows you to change almost all aspects of the document without using an external text editor. Also, Inkscape usually supports more SVG features than are accessible from the GUI. For example, we now support displaying masks and clipping paths, even though there's no GUI for creating or modifying them. The XML editor is one way to get access to these features (if you know SVG). "

Release Notes 0.44: Clipping and masking

"Inkscape now provides some UI for using clipping paths and masks. […]"

Release Notes 0.47: Node tool

"The Node tool can now edit clipping paths and masks of objects on canvas, without releasing them. If the selected object has a clipping path and mask, the corresponding buttons on the controls bar of the tool will be enabled; pressing these buttons will display the editable paths or handles of the clippath or mask. A clipping path is stroked green, a mask is stroked blue (the same colors as those used for them in Outline mode). "

jazzynico (jazzynico) on 2009-11-28
Changed in inkscape:
milestone: 0.47.1 → 0.48
jazzynico (jazzynico) wrote :

Comments from Bug #504967:

 in "Clipping or Masking a Bitmap", in lines:
"...In Inkscape Preferences (Misc tab), you can set the option of always importing bitmaps as pattern-filled rectangles."
there is not such option nor in 0.46 or 0.47 version (I don't know from which version it's gone).

 in "Transparency, gradients, and PostScript export",
"... make sure it's in the “pick visible color without alpha” mode; click on that same object. ..."
As far as I remember there was no any text button in control bar for Dropper in 0.46, but that's not matter now. in 0.47 there's two text trigger buttons ("Pick" and "Assign"). in order to reach the objective, user should release the "Pick" button (disable it). the text between the quotations ("pick visible color without alpha") doesn't seems to be match according to the tooltip.

AliQ. (ghanavatian-ali) wrote :

about out-dated stuff, I'm talking about the "Tips and Tricks" especially, I don't remember anything elsewhere at the moment:

 in "Clipping or Masking a Bitmap", in lines:
"...In Inkscape Preferences (Misc tab), you can set the option of always importing bitmaps as pattern-filled rectangles."
there is not such option nor in 0.46 or 0.47 version (I don't know from which version it's gone).

 in "Transparency, gradients, and PostScript export",
"... make sure it's in the “pick visible color without alpha” mode; click on that same object. ..."
As far as I remember there was no any text button in control bar for Dropper in 0.46, but that's not matter now. in 0.47 there's two text trigger buttons ("Pick" and "Assign"). in order to reach the objective, user should release the "Pick" button (disable it). the text between the quotations ("pick visible color without alpha") doesn't seems to be match according to the tooltip.

And there was something wrong in the "Entering Unicode values" which seems to be fixed in this 0.47 version.

jazzynico (jazzynico) wrote :

Hidden features and the XML editor - Fixed by helix84 in SVN rev22649.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
status: Confirmed → In Progress
Masato HASHIMOTO (hashimo) wrote :

Tips
-----------
* Radial placement with Tile Clones
"... going to the Shift tab and __setting Per row/Shift Y and Per column/Shift X both to -100%. __"

-> To check "Exclude tile" in Shift tab does same behavior.

--
* Drop shadows

-> Obsoleted. 'Filter' > 'Shadows and Glows' > 'Drop shadow' is provided.

--

Interpolate
-----------
* Einleitung
"... Effects > Generate From Path > Interpolate from the menu."

-> "Extension > Generate From Path > Interpolate from the menu."

jazzynico (jazzynico) wrote :

Nothing really moved in 0.48. Targeting it to 0.49.

Changed in inkscape:
milestone: 0.48 → 0.49
jazzynico (jazzynico) on 2010-08-24
summary: - Tutorial changes for 0.48
+ Tutorial changes for 0.49
jazzynico (jazzynico) on 2011-02-07
Changed in inkscape-docs:
assignee: nobody → JazzyNico (jazzynico)
importance: Undecided → Medium
status: New → In Progress
Changed in inkscape:
status: In Progress → Triaged
jazzynico (jazzynico) on 2013-12-26
summary: - Tutorial changes for 0.49
+ Tutorial changes for 0.91
Martin Owens (doctormo) wrote :

Ryan from the tutorials blog said at LibrePlanet 2014 that he wants to help with the inkscape tutorials for the next release. http://inkscapetutorials.wordpress.com/ I'm going to subscribe him to this bug report.

~suv (suv-lp) wrote :

Tips and Tricks (trunk):
Uses the old label for the menu item formerly called 'Vaccum Defs' -> in trunk now called 'Clean up Document'.

~suv (suv-lp) wrote :

Tips and tricks (trunk):
Uses old label for menu item formerly called 'File > Export Bitmap' -> in trunk now called 'File > Export PNG Image'.

Ryan Lerch (ryanlerch) wrote :

Just started a wikipage to try to track who is reviewing what, and to collate notes -- http://wiki.inkscape.org/wiki/index.php/0.91-tutorial-review

Masato HASHIMOTO (hashimo) wrote :

Tracing Pixel Art is forgotten.
It's available on Help > Tutorial of trunk, but its content seems to not match the current UI.

jazzynico (jazzynico) on 2015-01-16
Changed in inkscape-docs:
status: In Progress → Fix Released
Changed in inkscape:
status: Triaged → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers