PDF Save As dialog 'convert text to paths' option is confusing

Bug #437567 reported by Adrian Johnson on 2009-09-27
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Kence

Bug Description

Several times on IRC I've seen questions asked about the 'convert text to paths' option. It seems to generation a lot of confusion. There is also a lack of knowledge about if/when fonts are embedded in PDF.

I suggest making this option a combo box or radio buttons with two options "Embed fonts" and "Convert text to paths".

It would also be useful to have a help button in this dialog to bring up more information on these options. For example it could explain that the "Embed fonts" option allows text to be selectable and when there is a lot of text it produces smaller faster printing files.

Also the resolution option is incorrectly labeled with "dpi". It should be pixels per inch. See:
http://en.wikipedia.org/wiki/Dots_per_inch#DPI_measurement_in_printing

This causes confusion when users think that when printing on a 1200dpi laser they should enter 1200 in this field.

Pablo Trabajos (pajarico) wrote :

I'm setting this as confirmed. Personally, I agree with you on both points. Thanks for your report.

tags: added: pdf ui
Changed in inkscape:
status: New → Confirmed
importance: Undecided → Low
su_v (suv-lp) wrote :

Raising Importance to 'Medium' because PDF is one of the most used export formats.

Changed in inkscape:
importance: Low → Medium
tags: added: exporting
su_v (suv-lp) wrote :

This RFE depends on bug #388257.

Benjamin Humphrey (humphreybc) wrote :

Affects the entire Ubuntu Manual Project.

Kence (cpeel) wrote :

This patch implements the radio buttons for embed fonts/convert to paths as suggested. There are several other improvements that could/should be made to the dialog but I'll stop with just this to 1) not railroad the defect and 2) see how challenging it's going to be to get a patch accepted (as it's my first for Inkscape).

su_v (suv-lp) wrote :

Thank you for contributing to Inkscape! Unfortunately your patch fails with the current trunk version:

$ patch -d ./src -p0 --dry-run < ../_patch/todo/437567-pdf_export_radiobuttons.diff
patching file extension/param/parameter.cpp
Hunk #1 succeeded at 198 with fuzz 1.
patching file extension/internal/cairo-renderer-pdf-out.cpp
Hunk #1 succeeded at 144 (offset 4 lines).
Hunk #2 FAILED at 222.
1 out of 2 hunks FAILED -- saving rejects to file extension/internal/cairo-renderer-pdf-out.cpp.rej

Please note that Inkscape has moved from SVN at sourceforge to BZR at launchpad:
<http://www.inkscape.org/bzr.php?lang=en>

pdf_export_radiobuttons.diff:
--- extension/param/parameter.cpp (revision 22703)

Current trunk (lp:inkscape) is at r9341.

su_v (suv-lp) wrote :

see also recent commits:

9201 Added wrappers for the "optiongroup" type that correspond to existing "float", "enum" etc. wrappers.
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9201>

9202 Changed the embed/link dialog to use radio buttons instead of a checkbox to make the link/embed effect clearer.
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9202>

Kence (cpeel) wrote :

Thanks ~suv - I'll poke at that later today/tomorrow. Can we please get http://inkscape.org/doc/devdocs.php?lang=en updated to replace "Working with SVN" with a link to "Working with Bazaar"?

Kence (cpeel) wrote :

Here's a respun patch against the bzr trunk.

Kence (cpeel) wrote :

After thinking about it some, I realized that the new LaTeX option is mutually exclusive of the embed/path options and being text output related, also belongs in the radio list. This patch creates the following radio options:

Text output options:
o Embed fonts
o Convert text to paths
o Omit text in PDF and create LaTeX file

Johan Engelen (johanengelen) wrote :

Thanks for your patch. Could you make it consistent for PS and EPS export?
Thanks!

Kence (cpeel) wrote :

This patch uses the aforementioned radio boxes for PDF, PS, and EPS save dialogs -- lots of duplicate code in there!

I see that CairoPsOutput::textToPath() and CairoEpsOutput::textToPath() both reference the textToPath extension parameter but it's unclear to me if it's the same extension dialog that I made the changes in (and thus needs to be updated to use get_param_optiongroup() ) or if it's referring to a separate extension dialog being loaded elsewhere that will retain the checkbox (and thus should continue to use get_param_bool() ). After much searching in the code and the UI I couldn't ascertain the answer although I have a feeling it's a separate dialog -- assuming that code is being used at all.

su_v (suv-lp) on 2010-04-21
Changed in inkscape:
status: Confirmed → In Progress
ScislaC (scislac) wrote :

Johan: it looks like you were checking out this patch as it was being worked on and it appears they made the modification you requested shortly after you asked for it. Would you be willing to take another look?

Sparhawk (sparhawkthesecond) wrote :

It's not fixed in Inkscape 0.48.4 r9939. I actually came here confused as to what 'convert text to paths' meant. So if this is unselected, are the fonts embedded?

su_v (suv-lp) wrote :

On 2014-02-24 06:40 +0100, Sparhawk wrote:
> I actually came here confused as to what 'convert text to paths'
> meant. So if this is unselected, are the fonts embedded?

Yes, if 'Convert texts to paths' is unchecked (default setting), the text stays text in the PDF, and the fonts used by the text objects are embedded (as subsets, i.e. only the used glyphs of the font are embedded).

jazzynico (jazzynico) wrote :

Patch updated to apply to the recent trunk revisions (r13444).

Changed in inkscape:
milestone: none → 0.91
su_v (suv-lp) on 2014-11-06
Changed in inkscape:
milestone: 0.91 → 0.92
jazzynico (jazzynico) wrote :

Patch tested successfully on Crunchbang Waldorf, trunk rev. 13879, and committed rev. 13880.
Thanks Casey!

Changed in inkscape:
assignee: nobody → Kence (cpeel)
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Follow-up report (regression introduced with r13880):
- Bug #1417990 “trunk: crash on export to PDF via command line”
  https://bugs.launchpad.net/inkscape/+bug/1417990

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers