<symbol> not rendered correctly in exported PDF

Bug #436962 reported by theAdib on 2009-09-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
theAdib
inkscape (Ubuntu)
Low
Unassigned

Bug Description

attached svg is not rendered correctly in pdf.
This is a follow up from https://bugs.launchpad.net/inkscape/+bug/248721
and addresses the not mentioned issues.
Issues here:
1. too many red dots : rendering the svg:symbol where it should not render
2. no symbol in red dot : this is because not inheriting the fill-rule from group to inner element/group

theAdib (theadib) wrote :
Changed in inkscape:
importance: Undecided → Medium
assignee: nobody → theAdib (theadib)
status: New → Won't Fix
status: Won't Fix → Triaged
status: Triaged → In Progress
theAdib (theadib) wrote :
theAdib (theadib) wrote :
su_v (suv-lp) wrote :

Patch tested with Inkscape 0.46+devel r22293 on OS X 10.5.8
PDF export settings: default (new preferences.xml)

can not confirm fix for PDF export of symbols: I still get
- 4 instead of 2 red circles in PDF
- no symbol rendered inside the red circles

tags: added: pdf
su_v (suv-lp) wrote :

I forgot to check the make console output: found some error messages when compiling with your patch applied.

su_v (suv-lp) wrote :
Changed in inkscape (Ubuntu):
status: New → Confirmed
theAdib (theadib) wrote :

~suv I will reattach the patch now against recent svn 22524. This patch replaces that from #2. Adib.

theAdib (theadib) wrote :

to simplify I attach as well the my recent version. src/extension/internal/cairo-renderer.cpp
FYI there might be something else not good in your build because the compiler only outputs warnings whereas the linker misses symbols.?field.comment=to simplify I attach as well the my recent version. src/extension/internal/cairo-renderer.cpp
FYI there might be something else not good in your build because the compiler only outputs warnings whereas the linker misses symbols.

theAdib.

su_v (suv-lp) wrote :

> only outputs warnings whereas the linker misses symbols
Strange - why would 'make' even have built 'filedialogimpl-win32.o' when I build on osx? I guess (but will look into it) that file doesn't exist but the makefile has a reference to it anyway - same goes for 'ige-mac-menu.o' (AFAIK only used if native inkscape is compiled with quartz/aqua libs instead of X11) and the other win32 related files...

su_v (suv-lp) wrote :

patch tested and partial fix confirmed with Inkscape 0.46+devel r22528+patch on OS X 10.5.8

> Issues here:
> 1. too many red dots
confirmed fixed (see attached PDF file)

> 2. no symbol in red dot
still open

su_v (suv-lp) on 2009-11-20
tags: added: exporting
su_v (suv-lp) on 2010-04-09
summary: - pdf not rendered correctly
+ <symbol> not rendered correctly in exported PDF
Alex Valavanis (valavanisalex) wrote :

I still see 4 red circles with no symbols, using inkscape_0.48.0-1ubuntu1 on Maverick Meerkat.

@theAdlib - Are you still working on a fix for this?

Changed in inkscape (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Alex Valavanis (valavanisalex) wrote :

Sorry - "@theAdib"

su_v (suv-lp) wrote :

Possibly related reports about instantiated <symbol>s with viewbox attributes incorrectly exported to PDF (confirmed with current trunk and cairo 1.10.2):

Bug #485846 “imported svg not exportable to eps”
Bug #705345 “Cairo rendering broken for "use" elements with scaling or a viewBox”

su_v (suv-lp) wrote :

Tested with r10197 (with patch for bug #705345) on Mac OS X 10.5.8 (i386), cairo 1.10.2:

The symbol definitions themselves are no longer exported (compared to PDF exported with r10196 with 4 red circles there are only two red circles in r10197).

The remaining issue - both red circles are still rendered filled (instead of showing a white fill in the cut-out area) - seems unrelated to the <symbol> problem because the cairo-based export apparently ignores the fill rule which is set on a parent group instead of the red path itself (which isn't an instantiated symbol (<use> element) btw).

theAdib (theadib) wrote :

I investigated further and I hope I found a good patch for this.
Please test on many samples it might have a large side effects.
patch is committed in revision 10200.

theAdib.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2011-06-10
Changed in inkscape:
milestone: none → 0.49
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers