crash after 'undo/redo' a (combined) filter effect

Bug #431271 reported by su_v on 2009-09-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
jazzynico

Bug Description

Inkscape 0.46+devel r22240 on OS X 10.5.8 (happens with or without patch of bug #430804)

1) create rectangle, select it & open filter editor
2) apply image filter, leave filter editor open
3) apply 'Filters > Blurs > Blur content'
4) Undo, Redo
5) Inkscape crashes

After the first crash, Inkscape no longer displays any image used in a new image filter without resetting 'preferences.xml'.

console messages:
terminate called after throwing an instance of 'std::logic_error'
  what(): basic_string::_S_construct NULL not valid

crash report attached

Related branches

su_v (suv-lp) wrote :
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape rev. 22242 and two random predefined filters.

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
su_v (suv-lp) wrote :

> After the first crash, Inkscape no longer displays any image used in a new image filter without resetting 'preferences.xml'.

This is bug #382313 “Image Filter broken for external images” and possibly triggered by the random size of the rectangle in my tests.

kanya (kanya) wrote :

I tried it with svn trunk (22373), still the same. No need for an external image. I can even reproduce it in a simpler way (or another similar bug) apply any filter to anything, then open filter editor, then undo. If there were more filters undo all. Undoing the last filter crashes inkscape. Need gdb output?

tags: added: undo
su_v (suv-lp) wrote :

@kanja: I know it's not about one of the filters used being the 'Image' filter, that's why I added the comment (I did not mean that the bug itself is a duplicate of the image filter bug)

> I can even reproduce it in a simpler way (or another similar bug)
bug number?

> apply any filter to anything, then open filter editor, then undo.
> If there were more filters undo all.
> Undoing the last filter crashes inkscape

cannot reproduce this crash with Inkscape r22389:
Undoing the last (or only) applied filter with the filter editor dialog opened doesn't crash Inkscape.

Chris Mohler (cr33dog) wrote :

I'm seeing a similar issue. To reproduce:

Write a simple extension that sets the current layer's style to "display:none". (see attached)
Run the extension
Undo

Result:
ERROR:document-undo.cpp:173:void sp_document_maybe_done(SPDocument*, const gchar*, unsigned int, Glib::ustring): assertion failed: (doc->priv->sensitive)

Happens on 0.46 and current SVN.

Chris Mohler (cr33dog) wrote :

D'oh - I commented the wrong bug. I should have been on Bug #249035...

Pablo Trabajos (pajarico) wrote :

Chris: to avoid confusion I had deleted your attachments.

su_v (suv-lp) wrote :

Backtrace from current trunk (r10191) on OS X 10.5.8 (i386)

jazzynico (jazzynico) wrote :

Still present in revision 11575.

Quicker steps:
1) In a new document, open filter editor
2) Create a new filter (New button)
3) Add a primitive
4) Undo, Redo
5) Inkscape crashes

su_v (suv-lp) on 2012-08-01
tags: removed: ui-dialogs-toolbars
jazzynico (jazzynico) wrote :

Patch attached (tested on Windows XP, Inkscape revision 11575).

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :
tags: added: ui
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Tested successfully on Ubuntu 11.04, and committed revision 11581.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Backported to the branch, revision 9924.

Changed in inkscape:
milestone: 0.49 → 0.48.4
tags: removed: backport-proposed
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers