Portions of path not drawn on screen or exported

Bug #428415 reported by Lawrence on 2009-09-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

Using Inkscape 0.47pre2 r22153, built Aug 24 2009 on Windows Vista, with all recent updates, 2 GB memory.
The bug is the whole path is not drawn on the screen. With some circumstances the whole path will not be drawn in the exported png.
The problem item in the svg is a single path with 3068 nodes. To reproduce the bug zoom in and / or zoom out multiple times. Sometimes it seems to show more often when the path is not directly centered on the screen.
Muliple files are attached: original svg, screen prints and exported png.
spiral.svg is the svg. The path is a spiral which has been modified by applying a pattern on path. I was doodling around trying to get a quick spiral rope drawing.
spiral_screen_print_good.png shows how the spiral path looks when the whole spiral shows on the screen.
spiral_good.png shows a good exported png.
spiral_screen_print_bad*.png show screen prints when the whole spiral is not shown on screen.
In general the exported png has all of the spiral but on occasion a bad exported png happens: spiral_bad1.png Notice the missing piece on the right hand side just below the middle.
When the filter Filter->ABCs->Specular light is used on the path the problem shows up more often on the screen and much more often in the exported png.
Attached files which start with "spec*" have the Specular Light filter turned on.
I have tried copying and pasting the path into a separate svg and the problem is reproducable but does not happen as often.

I have reproduced similar problems in Inkscape 0.46+devel r21627, built Jun 19 2009.

Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :

Is there anyway to attach more than one file at a time?

Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Lawrence (annon0m0s) wrote :
Pablo Trabajos (pajarico) wrote :

Confirmed on Win XP SP3 using 0.47pre2, Sep 2 version.

Changed in inkscape:
status: New → Confirmed
Pablo Trabajos (pajarico) wrote :

1- Filters don't seem to have any effect in my test
2- In outline mode the figure is always complete
3- I can't reproduce it on display but not on export

Pablo Trabajos (pajarico) wrote :

It should be "I CAN reproduce it on display but not on export".

su_v (suv-lp) wrote :

reproduced with Inkscape 0.46+devel r22401 on OS X 10.5.8

workaround: select the large spiral > Path > Break apart > Group. Now screen redrawing, zooming, moving and rotating the grouped paths happens a lot faster and without rendering errors (no missing pieces).

This seems to be a issue with single paths with many nodes. Many paths with an equal total number of nodes in a group are rendered correctly and without performance lag.

tags: added: performance svg
tags: added: renderer
Lawrence (annon0m0s) wrote :

hi,
This problem still happens in Inkscape 0.47pre4 , built Oct 12 2009 Windows Vista.

Kelley (kelleybythesea) wrote :

Similar problem can be demonstrated with five node path; version Inkscape 0.47 r22583, built Nov 21 2009. Attached zip of svg and png file shows a "lazy S" whose PNG output is truncated at the second node.

su_v (suv-lp) wrote :

@Kelley - your issue looks closer to the one reported in bug #189214 “curve is exported badly (but displayed correctly)” <https://bugs.launchpad.net/inkscape/+bug/189214> and the workaround posted there lets me export your example without missing any segments of the dashed path: adding a node to one of the missing segments of the path. (tested with Inkscape 0.47 on OS X 10.5.8)

Kelley (kelleybythesea) wrote :

~suv - Thanks for the suggested workaround. There perhaps seems to be something else afoot here. When just the five node path is selected and exported at the same 300 dpi, the png (path5575.png attached) exports as expected (i.e., not truncated). The previous export showing the flaw used the page size (1500 px x 1011 px). Platform is XP.

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.1.
Not reproduced with trunk revision 10466 (new Cairo renderer).

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
su_v (suv-lp) on 2012-04-19
tags: removed: svg
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers