Inkscape does not run on Mac OSX 10.6

Bug #421305 reported by Earl Stutes on 2009-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

After installing Mac OSX 10.6 inkscape will launch, but immediately crashes. Here is the crash report

Process: inkscape-bin [11404]
Path: /Applications/Inkscape.app/Contents/Resources/bin/inkscape-bin
Identifier: inkscape-bin
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: Inkscape [11402]

Date/Time: 2009-08-29 17:24:49.637 -0700
OS Version: Mac OS X 10.6 (10A432)
Report Version: 6

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
  Library not loaded: /usr/lib/libxml2.2.dylib
  Referenced from: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
  Reason: Incompatible library version: DictionaryServices requires version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

su_v (suv-lp) on 2009-08-30
tags: added: build crash osx
su_v (suv-lp) wrote :

@Earl - The 'Incompatible library version' is a known issue and being worked on (see bug #392693 and its other duplicates). As I don't have 10.6 installed yet - can I ask you to test the latest prerelease build 'Inkscape-0.47-pre1-2.LEOPARD.dmg' from <http://sourceforge.net/projects/inkscape/files/inkscape/0.47pre1/>? So far there have been no crash reports for that build running on SL.

The reason I ask you to do a test run: yesterday I read in two comments on InkscapeForum.com that the python extensions fail on SL with the infamous message "The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or ...".
source: <http://www.inkscapeforum.com/viewtopic.php?f=29&t=3588>

If this is really the case it needs to be fixed before 0.47 is released IMHO. Therefor I am looking for information that (hopefully _not_) confirms this extension failure on a default SL install. If any of the effects in the 'Extensions' menu fail with the above quoted message - could you open a separate bug report please?

Thank you in advance for your time and effort,
~suv

Downloaded and ran 0.47-pre 1-2. It seems to take a long time to get
started, but it is up and running. I have not run any extensive tests
on it yet. But I see a usuable app.

On the subject of python, I have a phython solitaire app that also
does not run on 10.6(H3Team solitare)

Thanks

=eas=
On Aug 31, 2009, at 9:20 AM, ~suv wrote:

> *** This bug is a duplicate of bug 392693 ***
> https://bugs.launchpad.net/bugs/392693
>
> @Earl - The 'Incompatible library version' is a known issue and being
> worked on (see bug #392693 and its other duplicates). As I don't have
> 10.6 installed yet - can I ask you to test the latest prerelease build
> 'Inkscape-0.47-pre1-2.LEOPARD.dmg' from
> <http://sourceforge.net/projects/inkscape/files/inkscape/0.47pre1/>?
> So
> far there have been no crash reports for that build running on SL.
>
> The reason I ask you to do a test run: yesterday I read in two
> comments on InkscapeForum.com that the python extensions fail on SL
> with the infamous message "The fantastic lxml wrapper for libxml2 is
> required by inkex.py and therefore this extension. Please download
> and install the latest version from http://cheeseshop.python.org/pypi/lxml/
> , or ...".
> source: <http://www.inkscapeforum.com/viewtopic.php?f=29&t=3588>
>
> If this is really the case it needs to be fixed before 0.47 is
> released
> IMHO. Therefor I am looking for information that (hopefully _not_)
> confirms this extension failure on a default SL install. If any of the
> effects in the 'Extensions' menu fail with the above quoted message -
> could you open a separate bug report please?
>
> Thank you in advance for your time and effort,
> ~suv
>
> --
> Inkscape does not run on Mac OSX 10.6
> https://bugs.launchpad.net/bugs/421305
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> After installing Mac OSX 10.6 inkscape will launch, but immediately
> crashes. Here is the crash report
>
> Process: inkscape-bin [11404]
> Path: /Applications/Inkscape.app/Contents/Resources/bin/
> inkscape-bin
> Identifier: inkscape-bin
> Version: ??? (???)
> Code Type: X86 (Native)
> Parent Process: Inkscape [11402]
>
> Date/Time: 2009-08-29 17:24:49.637 -0700
> OS Version: Mac OS X 10.6 (10A432)
> Report Version: 6
>
> Exception Type: EXC_BREAKPOINT (SIGTRAP)
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread: 0
>
> Dyld Error Message:
> Library not loaded: /usr/lib/libxml2.2.dylib
> Referenced from: /System/Library/Frameworks/CoreServices.framework/
> Versions/A/Frameworks/DictionaryServices.framework/Versions/A/
> DictionaryServices
> Reason: Incompatible library version: DictionaryServices requires
> version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

su_v (suv-lp) wrote :

> Downloaded and ran 0.47-pre 1-2. It seems to take a long time to get
> started, but it is up and running. I have not run any extensive tests
> on it yet. But I see a usuable app.

Thank you for confirming that! The long start time might be due to
building the (X11) fontcache.

> On the subject of python, I have a phython solitaire app that also
> does not run on 10.6(H3Team solitare)

1) Could you make a quick extension test and just run 'Extensions >
Render > Gear...' which should insert one gear into the drawing and give
you immediate feedback if python extensions are basically functional?

2) Could you open terminal.app and type:

 which python
 python --version

and paste the output here?

thanks again, ~suv

birdsaregood (ariel36) wrote :

~suv, I just want to let you know I tried 0.47 pre 2 on Snow Leopard (a different computer). It opened fine, but I did get the python error when trying to do the grayscale effect (only one i tested). I need to do the terminal.app thing you said I guess for more info, and I could also try grabbing the files from my existing copy of 0.47 pre 1 on Tiger and see how it goes.

Earl Stutes (estutes) wrote :

On Aug 31, 2009, at 12:22 PM, ~suv wrote:

> *** This bug is a duplicate of bug 392693 ***
> https://bugs.launchpad.net/bugs/392693
>
>> Downloaded and ran 0.47-pre 1-2. It seems to take a long time to get
>> started, but it is up and running. I have not run any extensive
>> tests
>> on it yet. But I see a usuable app.
>
> Thank you for confirming that! The long start time might be due to
> building the (X11) fontcache.
>
>> On the subject of python, I have a phython solitaire app that also
>> does not run on 10.6(H3Team solitare)
>
> 1) Could you make a quick extension test and just run 'Extensions >
> Render > Gear...' which should insert one gear into the drawing and
> give
> you immediate feedback if python extensions are basically functional?

  Error message: "The fantastic lxml wrapper for libxml2 is required
by inkex.py and therefore this extention. Please download and install
the latest version from http://cheeseshop.python.org/pypi/lxml/, or
install it through your package manager by a command like: sudo apt-
get install python-lxml"
>
> 2) Could you open terminal.app and type:
>
> which python
> python --version
>
> and paste the output here?

neptune:~ eas$ which python
/usr/bin/python
neptune:~ eas$ python --version
Python 2.6.1
neptune:~ eas$

>
> thanks again, ~suv
>
> --
> Inkscape does not run on Mac OSX 10.6
> https://bugs.launchpad.net/bugs/421305
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> After installing Mac OSX 10.6 inkscape will launch, but immediately
> crashes. Here is the crash report
>
> Process: inkscape-bin [11404]
> Path: /Applications/Inkscape.app/Contents/Resources/bin/
> inkscape-bin
> Identifier: inkscape-bin
> Version: ??? (???)
> Code Type: X86 (Native)
> Parent Process: Inkscape [11402]
>
> Date/Time: 2009-08-29 17:24:49.637 -0700
> OS Version: Mac OS X 10.6 (10A432)
> Report Version: 6
>
> Exception Type: EXC_BREAKPOINT (SIGTRAP)
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread: 0
>
> Dyld Error Message:
> Library not loaded: /usr/lib/libxml2.2.dylib
> Referenced from: /System/Library/Frameworks/CoreServices.framework/
> Versions/A/Frameworks/DictionaryServices.framework/Versions/A/
> DictionaryServices
> Reason: Incompatible library version: DictionaryServices requires
> version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

su_v (suv-lp) wrote :

@Earl - could you please file a separate bug report about failing python extensions on SL? This needs to be looked at before Inkscape 0.47 on OS X is released. At least so that it's clear whether the issue is with Apple's Python install or Inkscape's launcher script - maybe it just needs to be adapted to different Python paths on SL.

su_v (suv-lp) wrote :

... and could you please add the output of following shell commands:

ARCH=`arch`
PYTHON_VERS=`python -V 2>&1 | cut -c 8-10`
echo PYTHONPATH="Content/Resources/python/site-packages/$ARCH/$PYTHON_VERS"

to the new bug report (since you have access to SL :)

My guess is that Inkscape needs to provide packages for the new 'x86_64' architecture: quoting e.g. from
Issue 6802: build fails on Snow Leopard - Python tracker <http://bugs.python.org/issue6802>:

"The default value for the -arch flag changed in SL. It used to be the same as the output of the arch command (i386 on intel systems) and now is x86-64."

Earl Stutes (estutes) wrote :

I am sorry, I do not understand your request.
Here is the output of the 3 commands
neptune:Library eas$ echo $ARCH
i386
neptune:Library eas$ echo $PYTHON_VERS
2.6
neptune:Library eas$ echo $PYTHONPATH
Content/Resources/python/site-packages/i386/2.6

Are you asking me to add that data to the bug report?

=eas=

On Aug 31, 2009, at 2:05 PM, ~suv wrote:

> *** This bug is a duplicate of bug 392693 ***
> https://bugs.launchpad.net/bugs/392693
>
> ... and could you please add the output of following shell commands:
>
> ARCH=`arch`
> PYTHON_VERS=`python -V 2>&1 | cut -c 8-10`
> echo PYTHONPATH="Content/Resources/python/site-packages/$ARCH/
> $PYTHON_VERS"
>
> to the new bug report (since you have access to SL :)
>
> My guess is that Inkscape needs to provide packages for the new
> 'x86_64' architecture: quoting e.g. from
> Issue 6802: build fails on Snow Leopard - Python tracker <http://bugs.python.org/issue6802
> >:
>
> "The default value for the -arch flag changed in SL. It used to be the
> same as the output of the arch command (i386 on intel systems) and now
> is x86-64."
>
>
> ** Bug watch added: Python Roundup #6802
> http://bugs.python.org/issue6802
>
> --
> Inkscape does not run on Mac OSX 10.6
> https://bugs.launchpad.net/bugs/421305
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> After installing Mac OSX 10.6 inkscape will launch, but immediately
> crashes. Here is the crash report
>
> Process: inkscape-bin [11404]
> Path: /Applications/Inkscape.app/Contents/Resources/bin/
> inkscape-bin
> Identifier: inkscape-bin
> Version: ??? (???)
> Code Type: X86 (Native)
> Parent Process: Inkscape [11402]
>
> Date/Time: 2009-08-29 17:24:49.637 -0700
> OS Version: Mac OS X 10.6 (10A432)
> Report Version: 6
>
> Exception Type: EXC_BREAKPOINT (SIGTRAP)
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread: 0
>
> Dyld Error Message:
> Library not loaded: /usr/lib/libxml2.2.dylib
> Referenced from: /System/Library/Frameworks/CoreServices.framework/
> Versions/A/Frameworks/DictionaryServices.framework/Versions/A/
> DictionaryServices
> Reason: Incompatible library version: DictionaryServices requires
> version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

su_v (suv-lp) wrote :

@Earl - sorry for being unclear: I was hoping you could file a separate bug about the Python extensions not running on Snow Leopard, because you have access to SL whereas I don't know if any of the developers currently working on the OS X port already have.

And in case you do so, it would be helpful to include the (in total) five command lines and their output to that new bug report.

Otherwise someone else will - sooner or later ;-)

Thank you for taking the time to report back! ~suv

Michael Wybrow (mjwybrow) wrote :

I have access to a Snow Leopard machine now, so can look at this python Snow Leopard problem a little further.

Earl Stutes (estutes) wrote :

okay, I can do that. I will try to get to that later this evening.

=eas=
On Aug 31, 2009, at 4:58 PM, ~suv wrote:

> *** This bug is a duplicate of bug 392693 ***
> https://bugs.launchpad.net/bugs/392693
>
> @Earl - sorry for being unclear: I was hoping you could file a
> separate
> bug about the Python extensions not running on Snow Leopard, because
> you
> have access to SL whereas I don't know if any of the developers
> currently working on the OS X port already have.
>
> And in case you do so, it would be helpful to include the (in total)
> five command lines and their output to that new bug report.
>
> Otherwise someone else will - sooner or later ;-)
>
> Thank you for taking the time to report back! ~suv
>
> --
> Inkscape does not run on Mac OSX 10.6
> https://bugs.launchpad.net/bugs/421305
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> After installing Mac OSX 10.6 inkscape will launch, but immediately
> crashes. Here is the crash report
>
> Process: inkscape-bin [11404]
> Path: /Applications/Inkscape.app/Contents/Resources/bin/
> inkscape-bin
> Identifier: inkscape-bin
> Version: ??? (???)
> Code Type: X86 (Native)
> Parent Process: Inkscape [11402]
>
> Date/Time: 2009-08-29 17:24:49.637 -0700
> OS Version: Mac OS X 10.6 (10A432)
> Report Version: 6
>
> Exception Type: EXC_BREAKPOINT (SIGTRAP)
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread: 0
>
> Dyld Error Message:
> Library not loaded: /usr/lib/libxml2.2.dylib
> Referenced from: /System/Library/Frameworks/CoreServices.framework/
> Versions/A/Frameworks/DictionaryServices.framework/Versions/A/
> DictionaryServices
> Reason: Incompatible library version: DictionaryServices requires
> version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

birdsaregood (ariel36) wrote :

Just to confirm: Trying Inkscape pre2 on this clean install of snow leopard, it works but the extensions don't work, even when swapping the python files from my old copy of Inkscape. No macpython copy is currently installed. I would provide data from the terminal, but I see you already have a couple people doing that. If I knew the URL of the new bug, I would be happy to confirm there that it effects me though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.