wrong lossy format warning message

Bug #418085 reported by Thomas Holder on 2009-08-24
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Thomas Holder

Bug Description

the warning message about data loss always claims the format to be org.inkscape.output.svg.inkscape

Commit 22033 introduces this constant.

svn diff -r 22032:22033 src/ui/view/edit-widget.cpp
Index: src/ui/view/edit-widget.cpp
===================================================================
--- src/ui/view/edit-widget.cpp (revision 22032)
+++ src/ui/view/edit-widget.cpp (revision 22033)
@@ -1247,7 +1247,7 @@
                 _("<span weight=\"bold\" size=\"larger\">The file \"%s\" was saved with a format (%s) that may cause data loss!</span>\n\n"
                   "Do you want to save this file as an Inkscape SVG?"),
                 SP_DOCUMENT_NAME(doc),
- Inkscape::Extension::db.get(sp_document_repr_root(doc)->attribute("inkscape:output_extension"))->get_name());
+ SP_MODULE_KEY_OUTPUT_SVG_INKSCAPE);

         Gtk::MessageDialog dlg (*this,
                        markup,

tags: added: saving svg
theAdib (theadib) wrote :

Maximilian, this was your commit could you please investigate?
This is the only change in this file on that particular revision. Might be an "accident"?
Adib.

Changed in inkscape:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Maximilian Albert (cilix)
Thomas Holder (speleo3) wrote :

fixed by removing the format indication. Since the "inkscape:output_extension" attribute was removed (revision 8454 by cilix42), the information is not available any more.

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

inkscape trunk: r10099

Changed in inkscape:
milestone: none → 0.49
assignee: Maximilian Albert (cilix) → Thomas Holder (speleo3)
su_v (suv-lp) on 2011-06-10
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

~suv - Unfortunately this one really needs a string change and thus break the . release rule.

tags: removed: backport-proposed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers