copy an object from inkscape to system clipboard doesn't keep transparency

Bug #404826 reported by Popolon on 2009-07-26
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

1-draw a vector shape

2-ctrl+c it

3-paste in another application

* I tested in mypaint (pure bitmap software, using git version) => paste object into current layer but with white filled frame (use : layers => paste from clipboard - ctrl+v)
* copy from gimp and paste to mypaint keep transparency, then I suppose this is a specific inkscape bug

I tested in gimp => no result (but this is another problem, gimp seem to be able to export to system clipboard but unable to import from system clipboard)
I tested also in openoffice draw, it paste svg source text (this is a openoffice draw missing feature)

other related problem, that could be a clue, copy a vector shape from openoffice draw paste a white filled bitmap with the shape into inkscape. from ood to mypaint same problem

This could be a system clipboard problem ?

I use Ubuntu Jaunty amd64 with gnome desktop.

tags: added: clipboard
removed: copy-paste
Pablo Trabajos (pajarico) wrote :

Here is what I found:
inkscape->gimp: pastes ok but as a path. I guess it's because gimp takes the EMF (vectorial) data instead of the bitmap data. You can see this with the clipboard viewer (screenshots attached). Inkscape stores clipboards copies in a wide range of formats, so gimp should be trained to take the bitmap instead of the vector. When trying to create a new bitmap from clipboard gimp says there is no raster data in it.

Question to the developers: why there are so many formats grayed-out in the drop-down menu of my attached screenshots?

gimp->inkscape: pastes ok both layers or selections (when there is one). Paths are also ok.

>* copy from gimp and paste to mypaint keep transparency, then I suppose this is a specific inkscape bug
I think it's in gimp. When pasting between raster applications the only available data is in bitmap. Is gimp the one confused when vector and bitmap are offered to it (as Inkscape does). Could you tip gimp devs about this?

Regards.

Pablo Trabajos (pajarico) wrote :
Pablo Trabajos (pajarico) wrote :
Bundini (jacobstr) wrote :

This is extremely crappy, folks.

Interop between vector applications, and bitmap applications is essential. For anybody using Illustrator and Photoshop this is taken for granted. I can guarantee that every graphic designer that even attempts to whet his appetite with these fabulous OS alternatives is going to cringe the moment they're affected by this.

Seems like a nitpick, but it's really a jarring speedbump in the user experience. Sure, there's a workaround (import/export) but thats exactly what makes this jarring. It's unreasonable when you've got a nice source graphic (say with some stock vectors of floral decorations) and you just want to pick and choose a couple of grouped objects to copy and paste into that site design you're working on in GIMP.

It's awesome that you got the copy and paste Interop going, but the lack of transparency means that it's useless. Honestly.

Bundini: First of all, that is not the proper way to comment a bug. If you want to discuss if it's crappy or not, please use a forum. A bug tracker isn't a place for oppinions, it's a place to add information about the bug in order to fix it.

About the bug itself, I think it's invalid. It's not inkscape's problem at all. The data copied are vectors, and they're copied properly.
The problem is in GIMP (and I wouldn't say it's a problem, but a feature not implemented).
When you copy from illustrator to photoshop, for instance, Photoshop has a feature that detects if you're pasting vectors or bitmaps and offers choices. You can import them as vectorial objects or rasterized them to pixels.
I can't see much trouble in using alt+b then right click and "edit externally". I wouldn't catalog that as a jarring speedbump in the user experience.
I think this bug should be closed as invalid, or at least turning into a feature, something like "copy to clipboard as bitmap". The problem seems to be in the target applications that cannot manage the copied SVG data well, not in inkscape.

Pablo Trabajos (pajarico) wrote :

I agree. Based on my research it is GIMP the one which has to implement a way to import a vector or a bitmap based on user choice (like Photoshop does with Illustrator). Maybe it already does and it's just a matter of configuration. Inkscape accepts everything from GIMP perfectly.

And "crappy" is not a good way to explain things. Noticing GIMP developers about the lack of this feature would be more productive.

Regards.

su_v (suv-lp) wrote :

doesn't keep transparency:
> 1-draw a vector shape
> 2-ctrl+c it
> 3-paste in another application

Reproduced with Inkscape 0.48+devel r9834 and GIMP 2.6.10 on OS X 10.5.8

1) Also or even happens when creating a bitmap copy first in Inkscape (which keeps the transparent background and any transparency/reduced opacity used for the fill/stroke of the vector objects), then copying the bitmap in Inkscape to the clipboard and pasting it into GIMP (as new layer): the pasted image has an added white background with all object transparencies flattened.

2) Extracting the bitmap copy in Inkscape to disk and opening the extracted PNG in GIMP preserves the transparency correctly.

3) Copying said PNG in GIMP and pasting it back into Inkscape also preserves the transparencies correctly.

Changed in inkscape:
status: New → Confirmed
John Anton (jja6) wrote :

IMHO this is an Inkscape problem. Shouldn't I be able to create a logo and paste it into an MS Office application? Without transparency it seems that I can't do that unless the backgrounds match.

su_v (suv-lp) wrote :

Technical note: it seems that in Inkscape the output extension "Cairo PNG" is called when creating the bitmap version (for the system clipboard) of the vector objects copied to the clipboard.

"Cairo PNG" however was used for testing Cairo-based export in Inkscape (i.e. it does not use Inkscape's renderer like 'Export bitmap'), and AFAIU was not intended to replace or be equal in quality to 'File > Export Bitmap'. This internal output extension ("Cairo PNG") does not fully support all SVG features used in Inkscape and always adds a white background. (see also bug #669267).

Changed in inkscape:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers