Inkscape: A Vector Drawing Tool

Wacom Bamboo Tablet on Windows, pen tool works on toolbars but not on the document

Reported by Rileywoo on 2009-07-23
242
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
Inkscape Devlibs
Medium
Unassigned

Bug Description

Wacom tablets (Bamboo and Intuos3) do not work on document when the "Use pressure-sensitive tablet" option is set. Problem seen on Microsoft Windows XP 32-bit and Microsoft Windows Vista 32 bit.

This can temporarily be fixed by opening the "Input Devices..." dialog and setting the first entry for "WACOM Tablet Eraser" to "screen" instead of disabled, but the problem recurs once Inkscape restarts.

ScislaC (scislac) wrote :

What version of Inkscape are you trying with? Please try with a pre-release of 0.47 and report back.

The only other thing I can throw out there is that I have a friend who had tablet issues on Vista that were due to Vista's native pen/tablet support (which was fixed by disabling via the Control panel).

Rileywoo (elwoodsusanm) wrote :

I tried with 0.46 and it was just the same. I don't have a problem with other programmes such as Adobe Elements and Coreldraw14.

ScislaC (scislac) wrote :

Have you configured it via the Input Devices entry in the File menu? Also, please do try this against 0.47 pre-release as opposed to 0.46 as we want to do our best to get any issues taken care of before the final release.

Rileywoo (elwoodsusanm) wrote :

I have followed your instructions. The eraser end of the Wacom pen will now work for both erasing AND drawing!! The stylus end won't do anything and in the settings I cannot alter the pen pressure.

Dub Dublin (dub-dublin) wrote :

Bug confirmed in the following environment:

Inkscape version: 0.47pre1 (built July3, 2009 - prebuilt binary as installed by the exe)
Windows XP SP3
Wacom Bamboo Tablet

Pen does not work in drawing/canvas area, but does work in toolbars and menus.

Breaking News: The bug appears to be in the Input Devices Dialog, or at least the broken (for Bamboo, anyway) defaults that it uses. I *can* get it to work if I do the following, quite non-intuitive sequence:
1. Open File/Input Devices
2. Select "Wacom Tablet Eraser" from "Device" pulldown
3. Now choose "Screen" from "Mode" pulldown
4. Choose "Wacom Tablet Pressure Stylus" from "Device" pulldown
5. Now press "Save" button

The pen stylus works after this, but pressure sensitivity is uneven. Eraser doesn't appear to work at all, but I'm not really sure how it's supposed to work - can anybody tell me?

Luca Bruno (lucab) on 2009-07-26
summary: - Wacom Bamboo Tablet will allow the pen tool to work on toolbars but not
- on the document? Im have Vista 32 bit
+ Wacom Bamboo Tablet on Windows, pen tool works on toolbars but not on
+ the document
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.47
status: New → Confirmed
Airwave (airwaveindehouse) wrote :

hi, i have the same problem.

Win XP SP 3 and Inskape 0.47 Pre1 and Hyper Pen USB Aiptek

in 0.46 it was going great this hyper pen,

But in 0.47 Pre isnt work on the dokument, i cant take a line (left klick) i see the cursor and i can move it but no klick.

on toolbars is going great and select a tool too...

i hope this would be fixed please

tags: added: tablet

 I have the same problem but I use the sistem WindowsXP. I tried to configurate my tablet in the 0.47 version but the program didn´t recognise it.
 Can someone help??

ScislaC (scislac) wrote :

Can someone please try the development version of GIMP which utilizes the most recent version of GTK? If the tablet works, chances are that us updating the libraries will make your tablet work in Inkscape too. Also, make sure that in GIMP you go into the preferences and ensure that your tablet is properly configured in the input devices. Here is the download link: http://bit.ly/1aeMIH

cleary (bernard-gray) wrote :

I can confirm Rileywoo's report on no pressure, and not being able to adjust the pressure dropdown in the input devices dialog -

Wacom Bamboo Fun
Vista32, latest wacom driver (april 2009)
inkscape 0.47 pre2 built by ChrisMorgan
Calligraphy tool selected, with pressure sensitivity enabled

I'm not a regular tablet user either, so I don't know what the expected behaviour is with the eraser - it doesn't erase, it works like the pen end with no pressure sensitivity.

@ ScislaC - I tried the gimp version as suggested, the pressure sensitivity is working with it, however the eraser draws by default (doesn't erase) - still don't know if this is expected behaviour or not. Still cannot adjust the pressure dropdown in the gimp input devices dialog either (which looks suspiciously similar to the inkscape one)

ScislaC (scislac) wrote :

Please try out the following build, which has newer gtk libs and hopefully will fix some of these issues: http://inkscape.chrismorgan.info/win32-builds/Inkscape-0.47pre2-2.exe

Jon A. Cruz (jon-joncruz) wrote :

An interesting behavior was noticed on OS X running in X11. With a tablet and extended events enabled, the trackpad stopped working in the drawing area. The main visible difference was that it was getting coordinates way to large. I believe this windows problem reported here has no coordinates/activity showing up at all. This may or may not be related.

Agung Prabowo (prabowo96) wrote :

Yesterday I removed my 0.46 version and install the 0.47 pre 4 on Windows XP 32 bit. The Wacom problem which is "... pen tool works on toolbars but not on the document ..." was still exists. Solution from #5 is work but this is annoying since we always do and do again whenever we begin to start Inkscape. My permanen solution is download the Gtk dlls mentioned in the forum: http://www.inkscapeforum.com/viewtopic.php?t=1091&f=21#p15554

Hope all these *.dlls will be shipped with the final version of 0.47.

ScislaC (scislac) on 2009-11-24
Changed in inkscape:
milestone: 0.47 → none
Crus-T (onfaitarde) wrote :

This bug is still present in Inkscape 0.47-3 (Windows XP SP3 32-bit and wacom bamboo fun tablet)
The solution cited by Agung Prabowo is still working

RodPierce (rod-lookfresh) wrote :

Have this bug with my Wacom Intuos3 under XP.

Can use pen on menus etc, but not on drawing.

Was fine in 0.46.

RodPierce (rod-lookfresh) wrote :

Update: by playing with the "Input Devices..." dialog I was able to get my Wacom working with 0.47

I've run into this same problem with my Wacom Intuos3 tablet and Inkscape 0.47

When first starting Inkscape, the tablet is able to click on toolbars, but not on the document

If I fiddle with the "Input Devices..." dialog, I can get it to work perfectly. However these settings are not retained between restarts of Inkscape, and the dialog in general seems flaky in that settings don't always seem to "stick" when I hit save, even within one session of inkscape.

If I deselect the "Use pressure-sensitive tablet (requires restart)" checkbox under Inkscape Settings, the tablet consistently works in the toolbars and document, but without pressure sensitivity.

I will attempt to use the DLLs mentioned in #12 to see if this fixes the flaky behavior of the "Input Devices..." dialog.

Using the DLLs from #12 did not change behavior.

However, I have minimized the number of steps to get the correct behavior.

1. Start up Inkscape
2. Selected the Calligraphy tool by using my tablet. This shows that selecting the toolbar works, but when I try to draw on the document, nothing happens.
2. Open the dialog through File -> Input Devices...
3. From the dropdown list of devices select "WACOM Tablet Eraser"
4. Select "screen" on the right-handside dropdown menu (the one that currently says "disabled")
5. Hit "close"
6. Attempt to draw with the tablet on the document. Drawing occurs and the sensitivity to pressure and angle is as expected.

Note: Steps 2 through 5 were performed with the mouse.

Ways to get incorrect behavior after program is in correct state (as described above):
A. Restart Inkscape. This causes the previous behavior to occur, that is, the tablet cannot draw on the document.
B. Open the "Input Devices..." dialog, select "WACOM Tablet Eraser" and set the right-hand side dropdown menu to say "disabled", then hit "close"

Clicking save on each individual device listed in the dialog has no affect on the behavior after restart. Is this dialog from GTK+? Is there a debug build with lots of verbose logging I could run this test case through that would be helpful?

description: updated
tags: added: input-devices-dialog settings

From the GTK docs [http://www.gtk.org/api/2.6/gdk/gdk-Input-Devices.html] (Sentence emphasized with **):

Various aspects of each device may be configured. The easiest way of creating a GUI to allow the user to configure such a device is to use the GtkInputDialog widget in GTK+. **However, even when using this widget, application writers will need to directly query and set the configuration parameters in order to save the state between invocations of the application.** The configuration of devices is queried using gdk_devices_list(). Each device must be activated using gdk_device_set_mode(), which also controls whether the device's range is mapped to the entire screen or to a single window. The mapping of the valuators of the device onto the predefined valuator types is set using gdk_device_set_axis_use(). And the source type for each device can be set with gdk_device_set_source().

Could this be the problem?

~suv (suv-lp) on 2009-11-27
tags: removed: input-devices-dialog settings
tags: added: ui-dialogs-toolbars
artberry (inkscape-artberry) wrote :

This bug also seems to be affecting me. However I have a older Wacom Pen partner CT-0405-R. I have therefore filed it as a separate bug although I suspect it's probably the same issue. I'm using Window XP Professional SP3. The problem is affecting the new 0.47 version.

That said I also had problems with 0.46 however in that case it will recognise the tablet if I hold the pen over the pad whilst starting the program.

At this point I have un-installed the new 0.47 version and reverted back to 0.46 since at least that version is usable.

Carl Peterson (carlopeterson) wrote :

This problem affects me as well. I have a Graphire 3 or 4 (CTE-430), running Windows 7 with Inkscape 0.47 stable. I am running the latest Wacom drivers for XP/Vista. I was able to work around this problem by changing the input device settings. I noticed that the trackpad on my laptop also did not click in the drawing area while the tablet was plugged in but functioned fine when I unplugged the tablet. It did work in the menu and toolbar areas.

Celt (celts-mail) wrote :

This bug is still present in Inkscape 0.47-3 r22583 Nov 21 2009, on XP Pro32, SP3.

Furthermore, it trashes the general preferences.xml file and Inkscape runs on defaults (ie no autosave). Even deleting the preferences file does not fix it.

This bug has been around for a very very long time. PLEASE can it be fixed?

CyberRasta (svetlin300w) wrote :

I have the same problem.

After I set the input devcies and restart inkscape an error message says: preferences.xml is not a valid xml and runs on the defaults.

Nils Jeppe (nils) wrote :

Bug confirmed, CTF-420 tablet, Windows XP 32bit, Inkscape 0.47. It basically breaks Inkscape for me. :'(

Vital Expressions (marie-troy) wrote :

Ok weird first time I start the program it seemed to work, except the cursor was about 1/4th of an inch above and 1/4th of an inch over from where it was displaying it was.

That problem disappeared when I changed the window/screen configuration that everyone was saying.

Then it was totally crazy it would only align it self to the center of the screen. So I could only draw along the Y axis up and down and the x axis was all over the place.

I cannot change the pressure in the tablet menu.

I think I figured out what it is doing though. If I flip it upside down the x doesn't move and y is erratic

Now I have turned off the pressure control, and the axis line up fine and the original issue of it being off 1/4 of an inch is gone.

I don't think I am going to mess with it anymore, but if yours is messed up see if the pressure appears to be controlling the location?

Vital Expressions (marie-troy) wrote :

That sounds confusing. What I mean is that it appeared the pressure of the pen tip was controlling the x axis and the eraser end was controlling the y axis, not the movement on the tablet but the pressure. When I pushed down with the pen x would go down when I pushed down with the eraser the y would move to the right.

0815 (emailbox0815) wrote :

I have exactly the same problem

Inkscape: 0.47 r22583, built Nov 21 2009

device: wacom cinque 12 wx

only when I disable pressure sensivity it paints on the document

AndyDap (gate2a) wrote :

I have had the same problem. I did the various repairs suggested and sometimes it worked, sometimes it didn't. However, I have now found out how to make the problem go away, at least for me. Haven't ploughed through all the responses so someone else may have mentioned this, so I apologise now.

If I start Inkscape using my mouse, then try to use the app with my pen and tablet, I get no devices loaded/recognised, etc.

If I start Inkscape using my pen and the tablet and NOT the mouse, everything works fine.

Krzysztof Kosinski (tweenk) wrote :

Please try this nightly build and tell me whether it works, e.g. whether the tablet settings are saved.
http://inkscape.modevia.com/win32/inkscapeR9180-1003121306.7z

There are actually 2 bugs: the first is that default tablet settings are not always correct, and the second one is that the tablet settings are not saved sometimes. The above nightly build should have the second bug fixed (which is also described here)
https://bugs.launchpad.net/inkscape/+bug/334800

I don't know whether fixing the first problem (wrong defaults) for all people is possible.

DragonGirl269 (dragongirl269) wrote :

System: Windows XP

Service Pack: 3

Inkscape Version: 0.47

Input Device: Wacom Bamboo Pen

Input Device Settings:
•Device- WACOM Tablet Pressure Stylus
•Mode- Screen
•X Axis- 2
•Y Axis- 1
•Pressure- none
•X Tilt- none
•Y Tilt- none
•Wheel- none

Problem:
The stylus won't work on the canvas area. I've had this same problem with GIMP and Corel Painter but I was able to fix it
with the settings on there. However, I've messed with the input device settings on Inkscape as much as I could and I still
can't get it to work right. It wont let me set the axises to none which seems like what might be the problem. It also won't
let me set any of the other options to anything but none. The only thing it will let me do is switch the numbers of the
X and Y axis. For example, when I click on 1 for the X axis the Y axis switches to 2 and the same for when I switch Y back
to 1 X goes back to 2, but other than that it won't let me change a single setting on there for screen mode. I did randomly
get it to work on the settings i listed above, but it was detecting it far away from the mouse cursor and wouldn't exactly follow the way my pen moved. I tried messing with them again and it won't work at all now, even when I set it back to the
settings that at least got it to detect something.

Grismar (grismar) wrote :

For me, this problem can be resolved by using the Wacom Table Preference File Utility (on Windows 7 Home Premium 64-bit) by removing prior settings for the Wacom Tablet. The problem only occurs whenever I make custom settings (like binding a key to a button on my tablet), although it doesn't occur immediately after changing settings.

The problem does not affect all pen-controlled applications, but Inkscape -is- always among the affected applications. This seems to suggest that Inkscape can deal with the tablet just fine when it's set to default settings, but something goes wrong when non-default settings are applied.

The behaviour is exactly as described: menu's and controls work just fine, but the canvas no longer picks up any input from the pen, even though the mouse and even the mouse for use on the Wacom tablet still work fine.

kartal (gecicigec) wrote :

I can confirm that this bug exist in developement versions as of inkscapeR9404-1005100249.7z . My wacom Intuos3 is not working under Winndows 7 in that dev version. Enabling tablet seems to work reverse like pen enables eraser, eraser enables pen in the gui. But in any case enabling any of those does not make wacom pen work at all. Wacom pen works only for clicking menu items.

V0.47 release seems to handle my wacom and wacom pressure fine

I have a HyperPen Graphics Tablet, and I'm experiencing the same problem. I can click on things, but I cannot draw with any of the tools...

I used to have an XP system, but the computer died, so I'm not forced to use Windows 7 (against all my better judgement). When I had XP, I didn't have a problem at all. It all worked fine and all was well. But now I'm 7ed, I can't use the tablet at all.

I tried to do as people suggested here, and look in the input device settings, but the only thing that shows up in there I can't read, because it's in Chinese... And changing the settings on the Chinese one, whatever it is, has no effect on the tablet at all.

Any ideas or suggestion or help will be greatly appreciated!! I rely on both InkScape and the Tablet so please someone fix this bug soon!!

I've had the same problem with Inkscape 0.47 on UBUNTU Linux! But I found it only occurs when the pen mode is set to "Relative" - when I change it to "Absolute", it works, including pressure sensitivity...

Cheri (cherimm) wrote :

Martin, which Wacom are you using? Mine is Bamboo Fun (and my computer is a PC) and there is *NO* option to set the pen preference to "relative" or "absolute" -- there simply just isn't such a choice. I'm glad you found a solution for your problem, though.

I'm using the Bamboo Pen & Touch (CTH-460) on Ubuntu Linux 9.10. I only have it for a day now. On Linux, you have to play a bit with the settings and drivers to get it working, and one setting you have if whether the tracking should work in relative mode (like the touchpad on a Laptop), or in absolute (the whole area of the tablet mapped to the whole screen). See the tool xsetwacom from linuxwacom.sourceforge.net

Sorry, I can't help for Windows driver settings. If it's any relief to you: I haven't got the actual touch function to work at all (yet?). But I don't care so much...

To add to some other comments before: yes, the eraser just works like a normal pen, I guess Inkscape does not automatically change the tool for different input devices? Or am I missing something?

A more technical addition (this is a bug report, after all):

When looking at the raw input values from the tablet with xidump, in absolute mode, I get the pen pressure and x and y coordinates over the whole range of 0,0 to ~14000,9000 (forgot the exact values).
When in relative mode, the coordinates only ever show the increments between reads, so positive and negative(!) numbers in the range up to ~+/-40 or so. More importantly, in relative mode, I don't get any pressure information, even in the raw data. I do get a "button 1 up/down" event, though, so I don't understand why I can't draw at all in Inkscape (even with pressure sensitivity switched off).

I hope, this might help someone who understands more about it, to fix the bug.

Sorry, my last post for today (unless requested), I promise: I answered my own question, which was off topic for this thread anyway: I found the setting to change the tool with the used tablet input device (under "Mouse" preferences, though).

Fairly happy now (using the work around of having switch to absolute mapping mentioned above). ;-)

cyrano1 (cyrano) wrote :

Wacom tablet CTE 430 worked fine with XP with no adjustments.

On Windows 7 the tools didn't work until I was directed to this thread. I applied the screen mode to the Puck (mouse), pressure stylus, and eraser.The tools now work with the pen, the mouse still doesn't work under any setting but who cares?, and the new settings hold when opening and closing Inkscape. Thanks!

Ville Takanen (ville-takanen) wrote :

By applying the fix on comments of https://bugs.launchpad.net/inkscape/+bug/405326 and Cyrano1's comment above I managed to fix this semi permanently.

Using Win7 ultimate 64 vit and inkscape 47-pre from the inkscape official site.

cyrano1 (cyrano) wrote :

Wacom bamboo tablet CTL-460 - windows 7 home edition

Same problem until I left the pressure stylus on screen mode and changed the eraser from "disabled" to screen mode (even though there is no eraser on this model pen). The settings hold when opening and closing inkscape.

Phlegmbot (heylookmail) wrote :

Sooo, what's the proposed solution for a Bamboo tablet in a Win7 eviron?

The pen options mentioned above do not exist (including eraser, relative, etc.).

I've the most-recent Wacom Bamboo driver...if that means anything.

Thanks!

Phlegmbot (heylookmail) wrote :

"environ" -- sigh.

cyrano1 (cyrano) wrote :

Phlegmbot: I think maybe you're trying to change your tablet settings rather than change Inkscape settings. I'd start by re-setting your tablet settings to default. Then open Inkscape, go to "file", select "input device" - ("WACOM tablet pressure stylus", and "WACOM tablet eraser" show up for me even though my bamboo doesn't have an eraser) . Change all modes to "screen". Hope this helps.

Phlegmbot (heylookmail) wrote :

Shows, what you know, Cyrano!

Um...yeah, that was exactly it.

Thank you!

Robert Thompson (baughbe) wrote :

Hi, Just recently tried to use the program and found this also affects my Genius MousePen 8 x 6 Tablet. I can select tools, but cannot write/draw on the canvas. I tried the suggested setting the input to "screen" but that doesn't work with the Genius tablet. Using the tablet mouse works however. But of course have no sensitivity and a lot less drawing control that way. This would be a great fix when you can figure it out. And yes, Windows XP (Media Edition) Service Pack 3. Does anyone know if this will work in Windows 7 with the Genius MousePen?

cyrano1 (cyrano) wrote :

Robert: I just downloaded and installed Inkscape .48 so may not be seeing the same input information. One thing I do notice is that the input doesn't recognize my tablet pen until I'm actually USING it to make changes. If you're using your tablet mouse to make changes, perhaps the tablet pressure stylus isn't showing up in your input in order to switch it to 'screen'? (You need more than one input for all features of your tablet stylus and mouse (puck) to work) On version .48 I also have a box to check which enables the pressure sensitive tablet (requires program restart). I'm not familiar with the Genius mouse/pen, so don't know if this will help or not.

FreeFog (freefog) wrote :

Inkscape 0.48
Gimp 2.6
Windows 7 Ultimate
Wacom Bamboo Fun

Hey there =):

Bug General Description:
Unintuitive / undesired Tablet compability issues using this programs on Windows.

GIMP:
  Fix:
    Open Gimp then open Tablet preferences, I didn't need to reset any custom cfg.
    Pen tip pressure is recognized.

  Undesired Behavior:
    Eraser works just like the pen tip.

INKSCAPE:
  Fix:
    File > Preferences > Mouse:
      Uncheck: "Use pressure-sensitive tablet..."
      I close the dialog NOT using the Windows window Close (X) button but Inkscape button.
      Restart (close and open) Inkscape.

      I can use Pen, tablet and mouse.

  Undesired Behavior:
    Eraser works just like the pen tip.
    No pressure recognized (at least not noticeable while using Calligraphy tool).
    File > Preferences > Mouse > Checkbox: "Switch tool based on tablet devise..." option did not produce any noticeable difference.

Comment:
I hope you improve this, Inkscape seems really promising.

FreeFog (freefog) wrote :

I wanted to rectify a mistake.

In GIMP more than an undesirable behavior there is a side effect, eraser works just as another tip, if you select a tool using the eraser end of the pen to choose that tool will be "saved" to that end just like the normal pen tip and you can set different pressure levels for each end.

W. Bourgeois (roundsoftstudio) wrote :

Same bug here, with Windows 7 Professionnal 32-bit, Inkscape 0.48 and a Trust Flex Design Tablet (A Waltop thing).
Since when is the priority of this bug set to high?

Tavmjong Bah (tavmjong-free) wrote :

I am having trouble with 0.48.1 with Fedora 12 (self-compiled). I have a choice:

1. Set Wacom Intuos3 4x5 cursor to Screen. This allows me to draw, for example, rectangles with the mouse, but not if I start the rectangle over the intersection of two grid lines. In this case, the Eraser tool in "Cut out" mode only removes narrow swaths (I think it is expecting a pressure reading but obviously the mouse doesn't provide pressure).

2. Set Wacom Intuos3 4x5 cursor to Disable. Then the mouse does not work at all over the canvas.

Michal (michal-wojczulis) wrote :

Hello
i expierience a little bit of a problem on my machine as well.

inkscape 0.48.0 r9654
windows xp sp3

initially i couldn't get tablet working, or it worked randomly, with pressure sensitivity or without.

after reading the whole thread here,i couldn't manage to get this working repeatably (there were some good tips however) so played with settings for a while. at the moment i i can repeatably control the behaviour of inkscape and my wacom bamboo pen tablet. it's got no eraser feature. here are my findings:

1. tablet must be plugged in prior launching inkscape*
2. using 'input devices...' from 'file' menu, under 'configuration' tab choose the following settings (if not already set):
a) 'tablet core pointer' as 'screen'
b) 'wacom tablet pressure stylus' as 'screen'
c) 'wacom tablet eraser' as 'screen'
d) check 'use pressure-sensitive tablet (requires restart)'

Now there is the tricky bit, at least for me. I mean tricky in the way inkscape (or gtk, i am not sure here) accepts the change of settings.

So to change settings 2a, 2b, and 2c you need to select 'screen' from dropdown menu (dropdown menu is now in white and the selected line is in lighter gray) and click on the 'wacom tablet eraser' (in case of 2c) line (or any other line, that is 2a or 2b) so the highlighted line colour changes to darker gray. in this way you make changes. if you want thes changes (as i am sure you do) to be remembered by inkscape on restart, additionally you need to click on 'save'. note that if you leave the line in lighter gray and click 'save' nothing happens. this made me confused for a while.
The only difference is 2d, which requires restart for the change to take effect. you don't need to click on 'save' here.

Hope this helps
Regards

* as suggested here --> http://inkscape.org/doc/calligraphy/tutorial-calligraphy.html

Magnes (magnesus2) wrote :

I have the same problem in 0.48 on Ubuntu. Pressure works in 'input devices...' menu (as third axis) but doesn't work with the caligraphy tool.

Labrusca X (octopus103) wrote :

Okay, I only just downloaded v. 0.48.1, and I am having difficulties. I am using a PC with Windows 7 and a Wacom Bamboo tablet. Under the default settings, the program refuses to recognize the mouse as a valid drawing tool. Even if I select "Switch tool based on tablet device", any mouse clicks on the canvas are not recognized. I am able to use the mouse if I turn "Use pressure-sensitive tablet" off, but I would like to be able to just use either the pen or the mouse without having to go in and change any settings each time I change the one I'm using.

n30 (neobadandy) wrote :

OKAY! So... I think I have a lead.
If you monitor the activity of the axis. They are only ever active when you have both eraser and pressure stylus enabled. You need to expand the the box below the test area (in hardware tab) to see the levels of activity of the axis. But when they are both enabled it doesn't work at all. When only one of either is enabled, you can draw, but with no pressure.
One thing I'm curious about though.. Is the "link" option, because there seems to be an important connection to the functioning of the pressure and having one or both of the features turned on.
The problem I've noticed is that you can "link" them together, whatever that does. Under the "hardware" tab, but it never saves this linked setting. Seeing as you need to restart the program for the other settings to come into effect, I'm assuming the same goes for the "link" setting, but the link setting cannot be saved.
Perhaps the two parts of the pen need to be linked to work, but cannot be linked?
Also, I have also noticed that when I cannot draw, the x and y coordinates go to extremely high values, although they seem to be normal values while I am moving the pen. This can be demonstrated by drawing a 3D box, moving the mouse about one can see that the box has normal dimentions, but while the mouse is still, the box stretches to an extreme size in some dimensions. So it appears that when the pen is idle the x and y readings go crazy.
But I first advise investigation into the "link" settings. Thank you.
Best of luck. Looking forward to a solution.

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.47 and 0.48.1.
Fixed with trunk revision 10957 and 0.48.x branch.

Changed in inkscape:
milestone: none → 0.48.3
status: Confirmed → Fix Committed
Changed in inkscape-devlibs:
importance: Undecided → Medium
status: New → Fix Released
jazzynico (jazzynico) on 2012-02-11
tags: added: ui win32
removed: ui-dialogs-toolbars
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers