Render>Grid doesn't render the horizontal lines properly

Bug #401567 reported by chobo on 2009-07-20
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

The render grid filter does not work properly in windows xp. When I use the control it renders the vertical lines in one area and the horizontal in another. The end result is that the lines to not intersect, so no grid is actually formed.

Alvin Penner (apenner) wrote :

do you mean the menu item Extensions->Render->Grid?
I just tried that and got the following result, which looks normal.

Yes, that's the one. This is the result I am getting. see attached picture.

On Mon, Jul 20, 2009 at 2:48 AM, Alvin Penner <email address hidden> wrote:

> do you mean the menu item Extensions->Render->Grid?
> I just tried that and got the following result, which looks normal.
>
>
> ** Attachment added: "grid.svg"
> http://launchpadlibrarian.net/29273692/grid.svg
>
> --
> Render Grid not wokring properly in Win XP
> https://bugs.launchpad.net/bugs/401567
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> The render grid filter does not work properly in windows xp. When I use the
> control it renders the vertical lines in one area and the horizontal in
> another. The end result is that the lines to not intersect, so no grid is
> actually formed.
>

chobo (stevenhubele) wrote :

Just wanted to add I am using the following build,

Inkscape 0.46+devel r21627, built Jun 19 2009

This is in v0.47pre1

On Mon, Jul 20, 2009 at 8:59 AM, steven hubele <email address hidden>wrote:

> Yes, that's the one. This is the result I am getting. see attached picture.
>
>
>
>
>
>
> On Mon, Jul 20, 2009 at 2:48 AM, Alvin Penner <email address hidden> wrote:
>
>> do you mean the menu item Extensions->Render->Grid?
>> I just tried that and got the following result, which looks normal.
>>
>>
>> ** Attachment added: "grid.svg"
>> http://launchpadlibrarian.net/29273692/grid.svg
>>
>> --
>> Render Grid not wokring properly in Win XP
>> https://bugs.launchpad.net/bugs/401567
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Inkscape: A Vector Drawing Tool: New
>>
>> Bug description:
>> The render grid filter does not work properly in windows xp. When I use
>> the control it renders the vertical lines in one area and the horizontal in
>> another. The end result is that the lines to not intersect, so no grid is
>> actually formed.
>>
>
>

- could you attach the corresponding .svg file?
- when you render the grid, have you selected an object ?

Strange... When I select it now it does render it right. I could have sworn
it didn't work yesterday when I did that. Sorry if this was a false alarm. I
have provided the file that messed up.

On Mon, Jul 20, 2009 at 11:15 AM, Alvin Penner <email address hidden> wrote:

> - could you attach the corresponding .svg file?
> - when you render the grid, have you selected an object ?
>
> --
> Render Grid not wokring properly in Win XP
> https://bugs.launchpad.net/bugs/401567
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> The render grid filter does not work properly in windows xp. When I use the
> control it renders the vertical lines in one area and the horizontal in
> another. The end result is that the lines to not intersect, so no grid is
> actually formed.
>

Confirmed with Inkscape 0.47pre1 r21720, built Jul 20 2009, on OS X 10.5.7.

Extensions > Render > Grid…
- works when no object is selected (uses page as boundaries)
- fails when applied to a selected rectangle (as shown in "render grid.png" attached in comment 2)

Alvin Penner (apenner) wrote :

confirmed on Windows XP, Inkscape 0.47pre0 as well.

this is a weird one. In Inkscape preferences there is a setting for SVG output-> allow relative coordinates. The default is checked yes (I think). With this checked I can reproduce the problem.

A few days ago I had unchecked unchecked this option, and therefore could not reproduce this problem.

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

also, this does not appear to be a Python extension, as far as I can tell.

jazzynico (jazzynico) wrote :

Works well with 0.46.

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.47
tags: added: regression
summary: - Render Grid not wokring properly in Win XP
+ Render Grid not working properly in Win XP
tags: added: extensions-plugins
tags: added: grids
removed: grid

I think hit this bug based on the steps in an InscapeForum tutorial. I'm on WinXP. Seems that the priority should be higher.

su_v (suv-lp) wrote :

related: Bug #442642 “Inkscape crashes on Effects: render: grid without default”
<https://bugs.launchpad.net/inkscape/+bug/442642>

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 9.10, Inkscape 0.47pre4.

Changed in inkscape (Ubuntu):
status: New → Confirmed
jazzynico (jazzynico) wrote :

Too late for 0.47. Targeting 0.47.1 (or 0.48).

Changed in inkscape:
milestone: 0.47 → 0.47.1
jazzynico (jazzynico) on 2009-11-20
summary: - Render Grid not working properly in Win XP
+ Render>Grid doesn't render the horizontal lines properly
jazzynico (jazzynico) wrote :

Fix committed in bzr revision 9361.
Please test!

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: 0.47.1 → 0.48
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

fix in parts confirmed with Inkscape 0.47+devel r9361 (OS X 10.5.8)

Quick test: the bug as originally filed is fixed. However - as many other items - the extension doesn't deal with a resized/format-changed page: the calculated grid is inserted offset from the bounding box of the selected object - or from the current page margins (if no object is selected).

more generally: the extension misplaces the grid if the selected object/inserted grid is inside a transformed group.

jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
Alex Valavanis (valavanisalex) wrote :

This bug will be fixed in Ubuntu with the release of inkscape_0.48.0-1ubuntu1, which will appear in Maverick shortly. Please see bug #628048 for details.

Changed in inkscape (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.0-1ubuntu1

---------------
inkscape (0.48.0-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
    LP: #463602, LP: #591986)
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
    - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  * debian/dirs:
    - Add usr/share/pixmaps. Allow inkscape.xpm installation
  * drop 50-poppler-API.dpatch (now upstream)
  * drop 51-paste-in-unwritable-directory.dpatch (now upstream)

inkscape (0.48.0-1) experimental; urgency=low

  * [cae07a3] New Upstream version 0.48.0
  * [309c498] add patch to fix crash in node tool
  * The highlights of this release are:
      - multipath editing
      - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
      - new Airbrush tool
      - LaTeX export with PDF/PS/EPS
      - JessyInk extension to create presentations
      - numerous bugfixes
  * [56702cf] don't build-depend on libssl-dev (closes: #573338)
  * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
    many thanks to him (closes: #576357)
  * [747d3d1] add README.source adopted from nagios to make lintian a
    bit happier
  * [4df0df7] Remove all patches since they are applied upstream
 -- Alex Valavanis <email address hidden> Sun, 12 Sep 2010 19:44:58 +0100

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers