inkscape crashes with bad alloc on conversion from svg to png

Bug #394228 reported by richardhauer on 2009-07-01
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

Hi!

like some guys before i want to render data from openstreetmap.org

i've got several svg files and attached the biggest one, because inkscape crashes while converting this svg to png!

I'm working with Windows XP Professonal and therefore i use this little Python script from http://kaioa.com/node/42 to work with the commandline.

My command: InkCL -e C:\bilder_test\output_0013.png C:\bilder_test\output_0013.svg -w=1590

and the error msg i get:

Message: Error: Inkscape ist auf einen internen Fehler gesto\xdfen und wird nun geschlossen.
terminate called after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc'
Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

The output is an uncompleted png file, half of it is succesfully converted and looks great, the rest is blank (white)!

If i use a width of 800 in the command, it works, but i ned the specific resolution with a width of 1590!

richardhauer (richardhauer) wrote :
tags: added: crash svg
Alvin Penner (apenner) wrote :

confirmed on Windows XP, Inkscape 0.47pre2. This may be related to how much memory you have, my crash occurred when I ran out of memory at 1.04 GB.

Exit message is:

D:\Program Files\Inkscape>inkscapec -e C:\windows\temp\output_0013.png C:\windows\temp\output_0013.svg -w 1590
Background RRGGBBAA: ffffff00
Area 0:0:500:749.968 exported to 1590 x 2385 pixels (286.2 dpi)
Bitmap saved as: C:\windows\temp\output_0013.png
** Message: Error: Inkscape encountered an internal error and will close now.

terminate called after throwing an instance of 'std::bad_alloc'
  what(): std::bad_alloc

Emergency save activated!

Changed in inkscape:
status: New → Confirmed
Pablo Trabajos (pajarico) wrote :

I tried to export a bitmap and it crashed: "Too many heap sections!"

Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) on 2009-10-03
tags: added: performance
su_v (suv-lp) wrote :

Inkscape 0.46+devel r22346 on OS X 10.5.8 (2GB RAM, 2.4 GHz Intel C2D):

export using command line with -w=1590 works without crash but is demanding all system resources. In fact the laptop is almost unusable during 4-5 minutes while inkscape is exporting the bitmap.

The crash is a win32 issue only - possible duplicate of bug #168914.

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.1 (crash after 15 minutes and almost 2 Gio of memory eaten).
Not reproduced with trunk revision 10466. PNG exported successfully (in 2 minutes, only 300 Mio used).

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
su_v (suv-lp) on 2011-10-09
tags: added: bitmap exporting
removed: svg
su_v (suv-lp) on 2011-10-09
tags: added: win32
removed: performance
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers