inkscape unbelievably slow

Bug #388424 reported by Tobias on 2009-06-17
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Steps:
1. Download & install XQuartz 2.3.3.2 (why is inkscape using this prehistoric technology in any case?)
2. Download & install the latest inkscape (Inkscape-21525-10.5-i386.dmg)
3. Start Inkscape.
4. Resize the window or do anything else.

Results:
Inkscape feels as if using it on vnc over an analog modem connection. I have never ever seen an application which needs _several seconds_ to paint its about screen. And don't tell me it's my hardware (MacPro 2009, 8 x Xeon, 16 GB RAM, OS X 10.5.7).

su_v (suv-lp) on 2009-06-17
tags: added: osx
removed: slooooooooooooooooooooooooooooooooooooooow slooow sloow slow
Tobias (tobias-hahn) wrote :

Maybe http://developer.apple.com/technotes/tn2005/tn2133.html is partly responsible. Applying the workaround described in the subsection "A last resort" improved things, even though it still does not feel too snappy.

Tobias (tobias-hahn) wrote :

More precisely: adding CGDisableCoalescedUpdates true to X11.app's Info.plist improved things, since Inkscape uses X11 for drawing.

su_v (suv-lp) wrote :

Thank you for trying to figure out possible solutions for your performance issues with Inkscape on OS X. Since this seems more X11/XQuartz related - have you considered asking on the related mailing lists? Here are the links to their achives:
- X11-user <http://lists.apple.com/archives/X11-users/2009>
- Xquartz-dev <http://lists.macosforge.org/pipermail/xquartz-dev/>

There are efforts ongoing to build Inkscape with the native OS X GTK+ version, the thread <http://www.nabble.com/Inkscape-0.47pre0-to23993114.html> on the inkscape-devel mailinglist might help you to find ways to contribute to get a mac-native Inkscape ASAP? ;-)

hth, ~suv

Jon A. Cruz (jon-joncruz) wrote :

There was a recent problem on Jaunty (Ubuntu 9.04) where any remote X11 or VNC launch would slow down apps significantly. To reproduce it on a single system, just doing ssh -XYC 127.0.0.1 was enough to show it. Also the problem was not in the app binary, but the libs (X11 and/or GTK) on the system.

Jon A. Cruz (jon-joncruz) wrote :

BTW, X11 is not really so "prehistoric", most Hollywood effect studios currently use it, etc. It's actually staying cutting edge in many areas.

Pablo Trabajos (pajarico) wrote :

So, is this solved or not?

Changed in inkscape:
status: New → Incomplete
Tobias (tobias-hahn) wrote :

Quoting myself:

"Maybe http://developer.apple.com/technotes/tn2005/tn2133.html is partly responsible. Applying the workaround described in the subsection "A last resort" improved things, even though it still does not feel too snappy.

More precisely: adding CGDisableCoalescedUpdates true to X11.app's Info.plist improved things, since Inkscape uses X11 for drawing."

So no, this is far from solved.

tags: added: performance
coCoKNIght (cocoknight) wrote :

Inkscape worked fine on my netbook in Intrepid and Jaunty, but now in Karmic it takes ~40s to start, ~6s to resize the inkscape window, and all other interface actions like changing the color palette, showing the layers window etc also take way too long.
Doing the actual work like drawing etc. however is not slower than with Janty afaict
Is there any log stuff that I could provide?

RyuTesla (ryutesla) wrote :

I, too, have seen a severe (several seconds) slowdown of Inkscape while in Karmic. I've tried both Ubuntu and Kubuntu. It is extremely frustrating.

su_v (suv-lp) wrote :

>> So, is this solved or not?
> So no, this is far from solved.

Reverting 'Incomplete' status change.

Changed in inkscape:
status: Incomplete → New
PeterPall (peterpall) wrote :

Inkscape is slow on my computer, too, if many fonts are installed (PC withUbuntu). Mainly startup time, but the overall experience is affected, too. => Mark this bug as a duplicate of Bug #488247? Or is this a different issue, as improvement by the tweaking of other system components supposes this?

su_v (suv-lp) wrote :

@Peter Pall - this is a different issue about the osx port of Inkscape, please do not mark it as duplicate of a more generic issue.

PeterPall (peterpall) wrote :

Another question: I have noticed that on Ubuntu was that that setting "Preferences/Misc/Pre-render named icons" would increase speed a lot. If I understand things right the real issue for this bug lies on a completely different place. But maybe this setting will increase speed for you, too at least a little bit.

su_v (suv-lp) wrote :

> "Preferences/Misc/Pre-render named icons" would increase speed a lot.
> (…) But maybe this setting will increase speed for you, too at least a little bit.

The time needed to scale and render SVG icons affects opening of new windows (with toolbars) and dialogs (usually only once per session, after that the icons are cached), but not an issue as originally reported (with a dialog window that doesn't have any icons):
«I have never ever seen an application which needs _several seconds_ to paint its about screen»

I have seen extreme issues with the speed of updating the canvas in Inkscape under X11/Xquartz on a few occasions as well: Suddenly, when dragging a single rectangle on the otherwise empty canvas, the selection bounding box got detached from the object, stayed behind and only followed the mouse drag with a noticeable delay, no filters or path effects involved. At the time I was under the impression that a native osx application (iirc iTunes) seemed to have triggered the performance loss of screen-updating in X11 applications. Only a reboot restored normal performance, just restarting X11 or logging out and back in didn't help.

The about screen from 0.47 paints almost instantly, the one from 0.48 is somewhat slower due to SVG filter effects but still renders in less then a second. This is on a MacBookPro (late 2008) 2.4 GHz Intel C2D, 2GB RAM, OS X 10.5.8, Xquartz 2.4.0.

Beluga (buovjaga) wrote :

Tobias: what is the current situation with 0.91 or 0.92?

Mug Shepherd (mugshepherd) wrote :

Am experiencing the same. Slow enough I would move to another app if available.

Qantas94Heavy (qantas94heavy) wrote :

Inkscape 1.0 no longer requires XQuartz, closing.

Closed by: https://gitlab.com/Qantas94Heavy

Changed in inkscape:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers