display a ghost path

Bug #380726 reported by qbit on 2009-05-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Krzysztof Kosinski
Nominated for 0.48.x by Krzysztof Kosinski

Bug Description

When move a node of a path, it is helpful to show a "ghost path" displaying both starting position of the path and the current position of the path being moved. (See the attached image where the red path is the current position of the path and the gray line is the initial position).

Related branches

qbit (paulix) wrote :
Changed in inkscape:
importance: Undecided → Wishlist
Krzysztof Kosinski (tweenk) wrote :

I'll do this in the new node tool by exposing a setting that only moves the outline while dragging and leaves the original alone until the handle is ungrabbed.

Changed in inkscape:
assignee: nobody → Krzysztof Kosiński (tweenk)
status: New → Confirmed
status: Confirmed → In Progress
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

three LPE editing regressions related to revision 9038 observed in Inkscape 0.47+devel r9045 (compared to r9029) due to un-checking the new preference
[ ] update path when dragging nodes

* Interpolate Sub-Paths
  - doesn't save trajectory path (parameter)
    works in 0.47, 0.47+devel r9029

* Spiro spline
  - cusp nodes (between straight segments) set to 'smooth' are
    not longer recognized as smooth nodes for Spiro splines
    works in 0.47, 0.47+devel r9029

    steps to reproduce:
    1) node tool preferences: uncheck '[ ] update path when dragging nodes'
    2) pen tool: draw closed triangle with straight lines
    3) node tool: select all -> make selected nodes smooth
    4) apply Spiro spline path effect (fails in r9045)

    expected result: circle through 3 points
    actual result: triangle

    workaround:
    - change cusp nodes to symmetric nodes (not smooth nodes)
    or:
    - node tool preferences: check '[x] update path when dragging nodes'

* Stitch Sub-Paths
  - stitch path is diagonally mirrored when editing
    works in 0.47 (not related to revision 9038)
  - doesn't save stitch path (parameter)
    works in 0.47, 0.47+devel r9029

Changed in inkscape:
status: Fix Committed → In Progress
Krzysztof Kosinski (tweenk) wrote :

Fixed in r9066.

Changed in inkscape:
status: In Progress → Fix Committed
Changed in inkscape:
milestone: none → 0.48
jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers