strings that need to be fixed for translation

Bug #380522 reported by helix84 on 2009-05-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
Nominated for 0.47.x by helix84

Bug Description

There are some problems with translation of a few highly visible strings in the UI:

#: ../src/ui/widget/selected-style.cpp:161
#: ../src/ui/widget/style-swatch.cpp:296
msgid "<i>None</i>"
msgstr ""

This refers to both "No fill" and "No stroke". These two can be (and are e.g. in Slovak, Czech) different genders therefore cannot be translated equally. Please separate this to 2 strings.

#: ../src/filter-enums.cpp:95
#: ../src/flood-context.cpp:264
#: ../src/ui/dialog/document-properties.cpp:325
#: ../src/ui/dialog/filter-effects-dialog.cpp:468
#: ../src/ui/dialog/inkscape-preferences.cpp:255
#: ../src/ui/dialog/inkscape-preferences.cpp:418
#: ../src/ui/dialog/inkscape-preferences.cpp:550
#: ../src/ui/dialog/inkscape-preferences.cpp:1140
#: ../src/ui/dialog/inkscape-preferences.cpp:1205
#: ../src/verbs.cpp:2239
#: ../src/widgets/stroke-style.cpp:765
#: ../src/widgets/toolbox.cpp:3885
#: ../share/extensions/grid_polar.inx.h:16
#: ../share/extensions/guides_creator.inx.h:15
msgid "None"
msgstr ""

Same thing here. This needs to be separated according to which thing it refers to (shape, markers, stroke, ...). It cannot be translated equally and needs msgctxt.

helix84 (helix84) wrote :

src/widgets/select-toolbar.cpp:536

Please add tooltip describing "Affect:"

helix84 (helix84) wrote :

share/patterns/patterns.svg should be i18n-ed (probably the same way as filters.svg). It contains fill patterns listed in Object - Fill and Stroke - Pattern - Pattern fill.

jazzynico (jazzynico) wrote :

Calligraphy presets (Bug #327533) and colons in filters parameters (Bug #358921)?

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed

"share/patterns/patterns.svg should be i18n-ed"

Added to PO files - yes. Appear transalted in UI - no.

helix84 (helix84) wrote :

sp_pattern_menu_build @ src/widgets/paint-selector.cpp:771
needs to be fixed to use the localized pattern names

@helix84

That like talking in Chinese to me, sorry :)

jazzynico (jazzynico) wrote :

> src/widgets/select-toolbar.cpp:536
> Please add tooltip describing "Affect:"

Suggestion:
"Control whether or not to scale stroke widths, scale rectangle corners, transform gradient fills, and transform pattern fills with the object"
(extracted from Inkscape FLOSS manual: http://en.flossmanuals.net/bin/view/Inkscape/SelectorTool).

Changed in inkscape:
status: Confirmed → In Progress
helix84 (helix84) wrote :

> "share/patterns/patterns.svg should be i18n-ed"
> Added to PO files - yes. Appear transalted in UI - no.

This is because they're stored in a variable, they're not a literal. This might help if it works for C++, too:

http://docs.python.org/library/gettext.html#deferred-translations

jazzynico (jazzynico) wrote :

Thanks for the idea!
Seems to work well for calligraphy presets (Bug #327533).

helix84 (helix84) wrote :

> Seems to work well for calligraphy presets (Bug #327533).

Oh, wrong bug :) Thanks, I didn't have the time to test it.

jazzynico (jazzynico) wrote :

Should now work with patterns too.
(src/widgets/paint-selector.cpp:793 and 795)
Committed rev. 21755.

helix84 (helix84) wrote :

> Please add tooltip describing "Affect:"

I added the tooltip in r21765.

Currently all problems mentioned in comments of this bug have been fixed except for those in description ("None").

jazzynico (jazzynico) wrote :

Colons in filters parameters (Bug #358921) is fixed in rev. 21769.

tags: added: translation
jazzynico (jazzynico) wrote :

I'll try to investigate the "None" strings for 0.49.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
jazzynico (jazzynico) wrote :

Should be fixed revision 13576.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers