Node tool behaviour different and wrong in 0.47 compared to 0.46

Bug #379817 reported by worms_x on 2009-05-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Draw a zigzag path (I am attaching such a path drawn in 0.47 rev 21271 (Windows XP)

2. Open this file with the 0.46 official release
2.a. Select the path
2.b Switch to the node tool
2.c Do Edit / Select All (this selects all nodes of the path and marks them with a blue diamond)
2.d Click on "Smooth nodes" in the node toolbar
Result:
2.e You get a nicely curved path as in the file zizzag046.svg attached

3. Open the zizzag file with a recent 0.47 build (I used rev 21271)
3.a. Select the path
3.b Switch to the node tool
3.c Do Edit / Select All (this selects all nodes of the path and marks them with a blue diamond)
3.d Click on "Smooth nodes" in the node toolbar
Result:
3.e You get a totally, and wrong, curved path as in the file zizzag047rev21271.svg attached

In other words, as such, the node tool behaviour is unpredictable and unusable to do "simple" operations which could be done in 0.46

I think it is a critical loss of a functionality.The 0.46 behaviour is the right one.

N.B.: I'll file a separate bug, sometimes when I convert a perfect circle to a path, I am still getting 5 nodes instead of 4. In all cases of this conversion, though, the end node is a cusp node instead of a smooth node (same behaviour in 0.46 and 0.47 for that), and I don't see the reason why this cusp node.

worms_x (wormsxulla) wrote :
worms_x (wormsxulla) wrote :
worms_x (wormsxulla) on 2009-05-23
tags: added: node-editing
removed: node
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, rev. 21424.
But this is not that critical since auto-smooth gives the expected result. It may not be as straightforward as smooth, but it"s a good workaround.

Changed in inkscape:
status: New → Confirmed
Krzysztof Kosinski (tweenk) wrote :

The new node tool which will be in 0.48 gives the expected behavior.

worms_x (wormsxulla) wrote :

One cannot expect users to dramatically change the way they do simple operations, such as the one described above. Furthermore, you cannot expect them to change twice (once from 0.46 to 0.47, and then back again from 0.47 to 0.48).

Autosmooth might be a workaround in some cases, but certainly not in all... I personally rarely use autosmooth, because it doesn't do what I want - it must be the way I "design" things.

In my understanding, a "tool" should keep consistent behaviour across versions. Because most users (including me), don't even "think" when they draw... they've been used to a behaviour since 0.45 or maybe before...

Regards.

bbyak (buliabyak) wrote :

fixed in 22139, please test

> In my understanding, a "tool" should keep consistent behaviour across versions.

except when new functionality is added - and this was just a case of useful new functionality (half-smooth nodes) being applied in a wrong situation

Krzysztof: please make sure to reproduce the exact behavior of the old node tool, including my fix, in your new tool (see the pseudocode algorithm in sp_nodepath_convert_node_type)

~suv (suv-lp) wrote :

Fix in rev. 22139 by bbyak confirmed with Inkscape 0.46+devel r22240 on OS X 10.5.8

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers