crash when run non-interactively and .gnome2 directory unable to be created

Bug #376866 reported by Mark Edgington on 2009-05-15
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

I have encountered the following bug, when running inkscape for non-interactive conversion from svg to pdf with a python script (using Python 2.5.2). The command being run is "/usr/bin/inkscape -z -A /tmp/outfile.pdf /tmp/infile.svg". (infile exists, outfile does not)

The inkscape output captured by the script is:
-----------------------------
** (inkscape:9424): WARNING **: Cannot create directory /var/www/.inkscape.
Although Inkscape will run, it will use default settings,
and any changes made in preferences will not be saved.

(inkscape:9424): libgnomevfs-WARNING **: Unable to create ~/.gnome2 directory: Permission denied

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
** Message: Error: Inkscape encountered an internal error and will close now.
-----------------------------

The script runs as the www-data user, and therefore cannot create new directories in /var/www (whose permissions are: root/root 0755). I have checked it with all cases of ~/.gnome2 and ~/.inkscape existing/not-existing. The only cases which cause inkscape to crash are those in which ~/.gnome2 does not exist (and cannot be created).

When I run the python script (or inkscape directly from the shell) in an interactive session, no crash occurs, therefore I can only assume that there is some connection between the bug and inkscape being run non-interactively. (haven't investigated further, however)

Mark Edgington (edgimar) wrote :

Forgot to mention:

using Inkscape 0.46 (Apr 7 2008)

And, when I did my interactive tests, I did so as the www-data user.

tags: added: crash
John Peterson (john-peterson) wrote :

The same thing happens when you try to run it from PHP in MediaWiki. Still with Inkscape 0.46 (Apr 8 2009). I have not tried 0.47.

John Peterson (john-peterson) wrote :

Same thing occurs with Inkscape 0.47pre4 r22446 (Oct 14 2009) in Ubuntu 9.10.

su_v (suv-lp) on 2010-02-16
tags: added: cli

some with Inkscape 0.47 r22583 on Ubuntu 10.04

su_v (suv-lp) wrote :

Changing status to 'Confirmed' based on duplicate report (bug #420636).

Changed in inkscape:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers