Inkscape: A Vector Drawing Tool

Print files go to Inkscape directory not to current

Reported by LucaDC on 2009-05-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

I often print to file (using a dummy printer) to create a postscript file of my drawings.
All programs I use to do this (not only Inkscape), create the file on their current working directory, that is: if I open a file double-clicking on it, then select File -> Print and select my dummy printer, the system asks for the file name to print in; if I give only the name (e.g. "fileprinted.ps", without any path) it's created in the same directory where the original document is (because it's the current directory taken by the program that opened the file).
With Inkscape, the same procedure always generates the file under "C:\Program Files\Inkscape\" or whatever it is (mine is different...).
This means that Inkscape is not setting correctly it's _real_ working directory: does it need to keep it under it's root?

Also if this could be not considered a bug, it is very annoying, indeed, because I always have to print on "C:\fileprint.ps" and then open Explorer to move the file under the directory I need it in.

Windows XP SP3, SVN 21298

Thanks.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP sp3, build 21303.
The bug only appears when I open the SVG file by double-clicking on it. Works well when I use File>Open and then print to a file.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
LucaDC (dicappello) wrote :

Ok, so the workaround is: open with double click (because it's easier, and places Inkscape in the right directory so I don't have to browse to it), go to File -> Open, reopen the file (a new window appears, so the first has to be closed) and now print to file works in the right directory.

Hope this will be fixed soon; I see you marked as "low importance"...
I'm not sure that print to file is the only operation affected by this bug.

Thanks

jazzynico (jazzynico) wrote :

I've decided to mark it "low" (IMHO it is better than "undecided") because the bug seems to be quite old (also affects 0.46) and I can't find any other related report. But we can change it if you really thing it should have a higher importance.

LucaDC (dicappello) wrote :

I agree with the 'low' marking: it's not critical for normal use and does not affect any functionality. Also, there is a workaround.
I didn't know how old this bug could be because printing has been fixed only recently so I usually went through saving as pdf and then printing.
I had to use the postscript creation because with a drawing I can't create a readable pdf (I don't know why but it's from an imported file so maybe there is something wrong with the original).
I only hope that this issue will be worked before 0.47.
I remember seeing other fiels created under Inkscape's directory (some pngs from copy/paste, other tmps or something else) but I can't say under which circumstances. Having them created under the current directory would help cleaning them.

Thanks.

ScislaC (scislac) wrote :

Here's a related Q... forgetting the that PS printer method. How can we get our .ps output up to snuff that you'd just directly opt to use that?

LucaDC (dicappello) wrote :

I use the print-to-ps method because it's application-independent so I can use it with any program. I simply got used to this way.
Also, as it's alway Cairo that creates both pdf and ps, problems with pdf are usually present also with ps.

~suv (suv-lp) wrote :

Bug #389262 describes similar issues on OS X where Inkscape saves files inside the application bundle, which is usually hidden from the user. Those examples are not related to printing but seem to share a common flaw in setting the current working directory for Inkscape once the app has started and knows the path to its resource files and libraries.

LucaDC (dicappello) wrote :

I tried again for bug #296778: now the PNGs are created on my Desktop, also if I run gdb (and inkscape) from a command prompt under Inkscape's program directory (having copied my boh.svg file there).
This is the batch file I run under "C:\Programmi\Inkscape-dbg\inkscape" directory passing "boh.svg" (without path) as first and only

   @gdb -silent -ex "symbol-file inkscape.dbg" -ex "run %~s1" inkscape.exe

And I don't even need to open "boh.svg": just run inkgdb, draw a square, ctrl-c, ctrl-alt-v: the PNG is created on my desktop.

On 22/6/09 11:36, LucaDC wrote:
> And I don't even need to open "boh.svg": just run inkgdb, draw a
> square, ctrl-c, ctrl-alt-v: the PNG is created on my desktop.

I had a similiar 'case to reproduce' for bug #381301 (comment 7) which
could crash inkscape because it tried to write those pngs into '/' -
where no user has permission to write (this connected the cut/paste with
the path issue, by chance).

~suv (suv-lp) on 2009-10-18
tags: added: exporting printing
LucaDC (dicappello) wrote :

I just tested with rev. 10300 and this problem no longer occours, probably due to last fixes about starting and working directory (related to other bug reports).
And, by the way, I stopped producing .PS files, as saving directly in .PDF is now working perfectly.
Thanks.

~suv (suv-lp) wrote :

Thank you for reporting back (much appreciated!) - changing status to 'Fix Released' without setting milestone (probably 0.48, but I'm not certain about that).

Please reopen of the error still occurs with latest stable release or current development snapshots.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers