FreeArt license replaced by CC-by-sa in metadata

Bug #372427 reported by jazzynico on 2009-05-05
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Peter Liljenberg

Bug Description

When I reopen a file saved with a FreeArt license in the metadata, the license is replaced by CC by-sa (the URI remains correctly set to FreeArt ).
Same problem with Other, replaced by proprietary.
All other licenses work well.

Tested on Windows Vista, Inkscape 0.46 and build 21287.

Same thing with debian and Inkscape 0.46 and Inkscape build 21164.

jazzynico (jazzynico) on 2009-05-06
Changed in inkscape:
status: New → Confirmed
Lorenz Aebi (inkscape-xca) wrote :

the problem is that both licence permits and requires the same:

struct rdf_double_t rdf_license_freeart [] = {
    { "cc:permits", "http://creativecommons.org/ns#Reproduction", },
    { "cc:permits", "http://creativecommons.org/ns#Distribution", },
    { "cc:permits", "http://creativecommons.org/ns#DerivativeWorks", },
    { "cc:requires", "http://creativecommons.org/ns#ShareAlike", },
    { "cc:requires", "http://creativecommons.org/ns#Notice", },
    { "cc:requires", "http://creativecommons.org/ns#Attribution", },
    { NULL, NULL }
};

and

struct rdf_double_t rdf_license_cc_a_sa [] = {
    { "cc:permits", "http://creativecommons.org/ns#Reproduction", },
    { "cc:permits", "http://creativecommons.org/ns#Distribution", },
    { "cc:requires", "http://creativecommons.org/ns#Notice", },
    { "cc:requires", "http://creativecommons.org/ns#Attribution", },
    { "cc:permits", "http://creativecommons.org/ns#DerivativeWorks", },
    { "cc:requires", "http://creativecommons.org/ns#ShareAlike", },
    { NULL, NULL }
};

the match between these 2 licences is done by compare the upper mentiones values. The 'rdf_match_license' function can be extended by checking also the URL but I don't know if this is a good idea, because the URL can be changed by the user.

FYI: Here is a related discussion about this issue/bug/dilemma (which is bigger than this bug) http://lists.ibiblio.org/pipermail/cc-devel/2013-June/001828.html . In the end it seems to come down to that a proper comparison would be to only compare URI.

Though only comparing URI would mean that it would still be hard to tell the difference between "proprietary" and "other" so not sure what to do about that just yet. Perhaps remove "proprietary" and only have "other" or group them together.

Changed in inkscape:
assignee: nobody → Peter Liljenberg (peter-liljenberg)

Commit http://bazaar.launchpad.net/~commonsmachinery/inkscape/cm-metadata/revision/12392 contains a fix for this. (That branch contains some other changes too, though, but the commit itself is clean.)

This came out of a discusson on cc-devel, where it was defined that tools should only check licenses for equality based on the URI, not the properties: http://lists.ibiblio.org/pipermail/cc-devel/2013-June/001849.html

Best practice is probably not to include the <cc:License> section at all, but the code keeps backward compatible support for it and reconciles any differences with a preference for the cc:license property.

Changed in inkscape:
status: Confirmed → In Progress

https://code.launchpad.net/~commonsmachinery/inkscape/lp372427

Ok, I've grabbed Peters patch and put it in a separate branch. Listed above. It works fine for me and fixes the issue with Free Art License and CC-BY-SA. Though it does not fix the issue with Proprietary and other.

### Solutions for the other part of this bug. (Move to future/new bug).
If this compiles fine for others I will merge it into trunk and open a new bug for the "Proprietary" and "Other" issue. I've tried to solve it but didn't want to refactor too much of the code as new features will be implemented soon regarding the handling of metadata. An easy fix could be to just remove "Proprietary" and only use "Other" though feedback from IRC suggested that "Other" doesn't make sense.

Instead a different solution was suggested. (1) Rename "Proprietary" to "Unspecified". (2) If "URI License" Entry is empty the "Unspecified" should be selected. (3) If "URI License" has any text in it and it doesn't match any listed license "Other" should be selected.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2013-07-24
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers