Remove deprecated Glib symbols

Bug #367606 reported by Andre Klapper on 2009-04-26
Affects Status Importance Assigned to Milestone
Krzysztof Kosinski

Bug Description

According to , Inkscape uses the following deprecated Glib symbols:

GMemChunk, G_ALLOC_AND_FREE, G_HAVE_GINT64, g_basename, g_dirname, g_mem_chunk_alloc, g_mem_chunk_create, g_mem_chunk_free, g_strcasecmp, g_value_set_string_take_ownership

These symbols will be removed for Glib 3 which will be released in March 2010.
Also see and .

Related branches

nightrow (jb-benoit) on 2009-05-10
Changed in inkscape:
importance: Undecided → Wishlist
Javier Jardón (jjardon) wrote :


I think that the status of this bug should be changed to high or normal

All these symbols will be removed for GTK 3 which will be released in March 2010.

See for more info

jazzynico (jazzynico) on 2009-07-21
Changed in inkscape:
importance: Wishlist → Medium
milestone: none → 0.47.1
status: New → Confirmed
Travis Athougies (iammisc) wrote :


I replaced some of the deprecated symbols except those in helper/units.cpp. This patch is taken from the inkscape 0.46 release. This is my first patch so if I made any mistakes don't hesitate to correct me.

~suv (suv-lp) on 2010-04-15
Changed in inkscape:
milestone: 0.47.1 → 0.48
jazzynico (jazzynico) on 2010-07-13
tags: added: build
Changed in inkscape:
milestone: 0.48 → 0.49
Krzysztof Kosinski (tweenk) wrote :

Fixed in 10480. Now compiles with G_DISABLE_DEPRECATED.

I didn't permanently add the define to, because we can't know what functions will be deprecated in the future, and would lose forward compatibility with newer libraries.

summary: - Remove deprecated Glib+ symbols
+ Remove deprecated Glib symbols
Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Krzysztof Kosinski (tweenk)
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints