import from open clip art crashes Inkscape (OS X)

Bug #365567 reported by stu on 2009-04-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

0.46 dev 20809 OS X 10.5.6

When I hit the 'search' button on the 'Import From Open Clip Art Library' screen it returns 'Inkscape encountered an internal error and will close now' a copy of the Apple crash report is attached.

stu (sedwards2) wrote :
nightrow (jb-benoit) on 2009-05-10
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

Mac OS X 10.5.6
XQuartz 2.3.2 (xorg-server 1.4.2-apple31)
Inkscape 0.46+devel r21262, built Apr 30 2009

no crash when using 'search' button in 'Import From Open Clip Art Library' dialog.

random crash when opening/inserting selected clipart. Can't reproduce it though :-(

theAdib (theadib) wrote :

I wonder how can I enable OCAL dialogs on my ubuntu dev builds ... ? Adib.

tags: added: crash importing
su_v (suv-lp) wrote :

more error messages related to OCAL from logging inkscape output:

--------------------------------------------------------------------------------
script: starting inkscape... [cl arguments: ]
--------------------------------------------------------------------------------

(process:7234): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
Xlib: extension "RANDR" missing on display "/tmp/launch-4H9XAl/:0".

(inkscape-bin:7234): Gtk-WARNING **: Could not find the icon 'object-visible'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
 http://icon-theme.freedesktop.org/releases
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
terminate called recursively

Emergency save activated!

Emergency save document locations:
  New document 1.2009_05_10_18_34_01.0.svg
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

don't know if that's relevant... this crash happened again when inserting the same clipart (apple > apple - Fruit series. A apple picture in cartoon style) for a second time into the drawing.

steps to reproduce:
1) open new drawing
2) 'Import From Open Clip Art Library' > "apple" > search
3) select last item in search result and import it by clicking 'open'
4) repeat steps 2 and 3
5) inkscape crashes
6) Emergency save document contains both instances on top of each other

Michael Wybrow (mjwybrow) wrote :

Can someone (who does not use macport's dbus package) please confirm that this occurs with the Inkscape-0.47-pre1-1.LEOPARD.dmg package I have just put up on SourceForge.

If so, then I will investigate the correct way to go about installing the LaunchAgents for dbus.

su_v (suv-lp) wrote :

confirmed with:

  Mac OS X 10.5.7 (9J61)
  XQuartz 2.3.3.2 (xorg-server 1.4.2-apple42)
  Inkscape 0.47pre1 r21720, built Jul 6 2009
  no macports installs

reproduced with steps outlined in comment 4
console messages attached.

do you need the crash report as well?

Alexander (aralni) wrote :

I get full similar crash on Linux, Inkscape 0.47

After this, I see on site OCL:

"Open Clip Art Library
We are upgrading the current website and will be back momentarily as we upgrade this website"

While site not response this error ocсurred.

shelleyfrank (michael-pienaar) wrote :

same thing happens on:
OS X 10.4.11
Inkscape 0.47 r22583, built Dec 7 2009

For interest's sake I manage to open one clip art image, and when I try again Inkscape crashes when I click to select an item in the list.

tags: added: osx
Changed in inkscape:
status: New → Confirmed
Corinna Maass (corinna-maass) wrote :

I can reproduce this bug on Kubuntu 11.04, Inkscape 0.48.1 r9760.

Shell output before segfault, test searching 'fish':

http://openclipart.org/media/feed/rss/fish:8: parser error : EntityRef: expecting ';'
 type="text/css" href="http://www.openclipart.org/style.php?site=default&widgets

Emergency save activated!
Emergency save completed. Inkscape will close now.

This coincided with the OpenClipart library being down for maintenance.

BobSongs (bobspcrepair) wrote :

-= PLEASE NOTE =-

From the OpenClipArt Website:

"The site has been experiencing some backend performance issues and is currently down for maintenance. We will bring the site back online soon when we can resolve those issues.

OSUOSL Staff"

Taken from www.openclipart.org

BE ADVISED that Inkscape will crash when connecting to the OpenClipArt site.

su_v (suv-lp) wrote :

@all - this report is about a specific issue with the bundled Inkscape.app for Mac OS X.

The crashes due to the recent outage of openclipart.org are tracked in

 Bug #889421 “Segfault in openclipart dialog when openclipart.org is down”
 <https://bugs.launchpad.net/inkscape/+bug/889421>

su_v (suv-lp) on 2012-01-13
tags: added: openclipart
removed: importing
su_v (suv-lp) wrote :

Crash still reproducible in Inkscape 0.48.2 and 0.48+devel r10877 on Mac OS X 10.5.8 and OS X 10.7.2
(even with dbus session loaded and running):
For steps to reproduce see comment #4.

su_v (suv-lp) wrote :

Backtrace Inkscape 0.48+devel r10877 on Mac OS X 10.5.8 Leopard (32bit)

su_v (suv-lp) wrote :

Crash report Inkscape 0.48+devel r10877 on OS X 10.7.2 Lion (64bit, llvm-gcc-4.2).

ScislaC (scislac) wrote :

~suv: Is it still reproducible with current trunk? If so I'm thinking it should be a blocker.

su_v (suv-lp) wrote :

@ScislaC - the new ocal import in trunk doesn't work on OS X at all, tracked in bug #943148.

su_v (suv-lp) wrote :

Crash no longer reproduced with official Inkscape 0.48.5 package and with local X11-based builds of the stable 0.48.x release branch which use up-to-date versions of all dependencies.

The crash still reproduces though with same Inkscape revisions compiled using older versions of the dependencies (separate 'frozen' MacPorts tree on the local system). This indicates to me that the underlying issue is likely related to older upstream bugs in OS X ports of dependent libraries.

All tests done on OS X 10.7.5.

Closing - no longer reproduced with the current stable package (0.48.5) for OS X.

Changed in inkscape:
milestone: none → 0.48.5
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers