Control points not drawn at (0,0)

Bug #360158 reported by Diederik van Lierop on 2009-04-12
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Diederik van Lierop

Bug Description

Using latest revision (#21132) on Fedora 10, one of the selection arrows is not being drawn under some specific conditions. See the attached screenshot.

Conditions to reproduce
1) The boundingbox corner is exactly at 0,0 (e.g. when using a rectangle with _no_ stroke, with the lower left corner snapped to the grid with origin at (0,0) )
2) The arrow is initially drawn, but disappears when switching from scaling/translating mode to rotating mode of the selector tool, or back again.

jazzynico (jazzynico) wrote :

Not reproduced with Windows VIsta, Inkscape build 21115.

jazzynico (jazzynico) wrote :

Confirmed with Ubuntu 8.10, build 21132.
But the steps are different. It works well if Stroke Paint is set to "no paint", and fails if set to "Flat", with "Width" set to 0.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) wrote :

With 21139, it fails with "no paint" too.
Worked well in 0.46. Tagged as regression.

tags: added: regression
jazzynico (jazzynico) wrote :

I can't reproduce it on Ubuntu 9.04, Inkscape r21932.
Could you test and confirm the bug is gone?
Thanks.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.46+devel r21924, built Jul 29 2009 on OS X 10.5.7:
fails with stroke paint set to 'no paint'

I cannot reproduce this any longer with the fix applied in rev. #10463, so I guess this has been fixed!

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2011-07-17
Changed in inkscape:
milestone: none → 0.49
Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
summary: - Selection arrow missing
+ Control points not drawn at (0,0)
su_v (suv-lp) on 2011-10-31
tags: added: selection ui
su_v (suv-lp) wrote :

The changes from r10463 merge cleanly into <lp:inkscape/0.48.x>, and fix the display of control points at (0,0) for filled, unstroked paths. Patch tested successfully with 0.48.x r9960 on OS X 10.7.5).

Proposing to include the fix in 0.48.5 (same patch fixes also bug #1095288).

tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Backport patch tested successfully on Windows XP, 0.48.x branch revision 9663.

su_v (suv-lp) wrote :

Backport committed to lp:inkscape/0.48.x in revision 9966

Changed in inkscape:
milestone: 0.49 → 0.48.5
Kris (kris-degussem) on 2013-12-11
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers