License conflict in inkscape (apache 2.0 vs GPLv2)

Bug #357043 reported by Vincent Untz on 2009-04-07
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Martin Owens

Bug Description

The siox code is under the Apache 2.0 license according to the headers. However, this license is incompatible with GPLv2, see http://www.fsf.org/licensing/licenses/#apache2

Note that the GIMP code for siox is GPL. I guess asking the siox people to relicense would be the right thing to do.

Related branches

Ted Gould (ted) on 2009-04-07
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
jazzynico (jazzynico) on 2010-05-22
tags: added: license
Vincent Untz (vuntz) wrote :

Ping? Has someone asked the siox people?

On Sun, 2010-09-12 at 17:08 +0000, Vincent Untz wrote:
> Ping? Has someone asked the siox people?

I haven't sorry. I asked the folks in Inkscape that added the code, but
they never responded and I didn't follow up.

Martin Owens (doctormo) wrote :

Gerald Friedland, Kristian Jantz and Lars Knipping and Bob Jamison have all been contacted with a link to this bug and asked to re-license their work as GPL for Inkscape.

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Confirmed → In Progress
Martin Owens (doctormo) wrote :

All fixed, see message from Gerald Friedland on Inkscape-devel "Re: Regarding Bug 357043" at 2013-06-11 23:39:15 -0400

Headers updated, marking as fixed.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Martin Owens updated bug status:
> status: Confirmed → Fix Committed

r12370

Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers