inkscape crashed with signal 5 in _XError()

Bug #336435 reported by Anders Kaseorg on 2009-03-01
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: inkscape

This happens when passing a .svg file to Inkscape on the command line: inkscape image.svg.

ProblemType: Crash
Architecture: amd64
DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module is deprecated import sets Ubuntu 9.04
ExecutablePath: /usr/bin/inkscape
NonfreeKernelModules: nvidia openafs
Package: inkscape 0.46-5ubuntu1
ProcCmdline: inkscape ksplice-k-only.svg
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_TIME=en_DK.UTF-8
Signal: 5
SourcePackage: inkscape
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 _XError (dpy=0x1a1b4e0, rep=0x4c6dd60)
 process_responses (dpy=0x1a1b4e0,
 _XReply (dpy=0x1a1b4e0, rep=0x7fff2796f540,
 _XGetWindowAttributes (dpy=0x1a1b4e0,
Title: inkscape crashed with signal 5 in _XError()
Uname: Linux 2.6.28-8-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse kvm lpadmin netdev plugdev powerdev pulse pulse-access pulse-rt scanner tape video

#2 0x00007f141d140652 in gdk_x_error (display=<value optimized out>,
    error=<value optimized out>)
    at /build/buildd/gtk+2.0-2.15.4/gdk/x11/gdkmain-x11.c:641
 buf = "BadWindow (invalid Window parameter)", '\0' <repeats 27 times>

Anders Kaseorg (andersk) wrote :

StacktraceTop:gdk_x_error (display=<value optimized out>,
_XError (dpy=0x1a1b4e0, rep=0x4c6dd60)
process_responses (dpy=0x1a1b4e0,
_XReply (dpy=0x1a1b4e0, rep=0x7fff2796f540,
_XGetWindowAttributes (dpy=0x1a1b4e0,

Changed in inkscape:
importance: Undecided → Medium
Bryce Harrington (bryce) on 2009-04-08
description: updated
Spyros S. (spystath) wrote :

I confirm this with the latest developmental build of inkscape. Exact same error.

Bryce Harrington (bryce) wrote :

A pre-release of the upcoming Inkscape 0.47 is now available in Ubuntu
Karmic for testing. Because *so* much stuff has changed compared with
the version you reported your bug against, would you mind re-testing
this new version and see if this bug is now resolved?

Karmic Alpha CD ISO images are available at:

  http://cdimage.ubuntu.com/releases/karmic/

If you're not testing Karmic yet, there are .debs of this new Inkscape
for Jaunty, Hardy, and Intrepid here:

  https://launchpad.net/~inkscape.testers/+archive/ppa

You might find further bugs when testing this alpha release. If that is
the case, please file a NEW bug report here:

   https://edge.launchpad.net/inkscape/+filebug

Thanks ahead of time for your testing efforts, and enjoy the new Inkscape!

Changed in inkscape (Ubuntu):
status: New → Incomplete
Anders Kaseorg (andersk) wrote :

$ dpkg-query -W inkscape
inkscape 0.47~pre1-0ubuntu1
$ inkscape help-about.svg

Gdk-ERROR **: The program 'inkscape' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 15378 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap

Changed in inkscape (Ubuntu):
status: Incomplete → New
Spyros S. (spystath) wrote :

Exact same problem as Anders above. This bug occurs *only* if either "Remember and use last window''s geometry" or "Save and restore window geometry for each document" are selected (Inkscape Preferences->Windows->Saving window geometry). If "Don't save window geometry" is selected everything loads fine.

Bryce Harrington (bryce) on 2009-07-06
Changed in inkscape (Ubuntu):
status: New → Triaged
jazzynico (jazzynico) wrote :

Not reproduced on Ubuntu 9.04, Inkscape rev. 22025 compiled from SVN.

Changed in inkscape:
importance: Undecided → High
tags: added: crash

Reproduced with "Inkscape 0.47pre3 r22311 (Sep 29 2009)" using GTK+ 2.16.6. However, everything workds with GTK+ 2.14.7:

### GTK+ 2.16.6:

$ ~/software/inkscape/bin/inkscape /tmp/sinplot.svg
The program 'inkscape' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 4566 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

### GTK+ 2.14.7

$ LD_LIBRARY_PATH=~/software/gtk/lib/ ~/software/inkscape/bin/inkscape /tmp/sinplot.svg

(Opens the file, which was generated by gnuplot.)

###

Setting Inkscape Preferences → Windows → "Don't save window geometry" makes it work with GTK+ 2.16.6.
Setting Inkscape Preferences → Windows → "Remember and use last window's geometry" makes it CRASH with GTK+ 2.16.6.
Setting Inkscape Preferences → Windows → "Save and restore window geometry for each document" makes it CRASH with GTK+ 2.16.6.

I'm adding a backtrace, using GTK+ 2.16.6 and "Save and restore window geometry".

I wonder - since it breaks on GTK+ 2.16.6 and works with the other version - could this bug be related to bug #430853?

I've found a workaround: SSH. I can't imagine why that should make it work, but it does. Using "su - user" also makes it work.

Normally it crashes like this:

christian@omicron ~ $ ~/software/inkscape/bin/inkscape /tmp/sinplot.svg
The program 'inkscape' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 4566 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
christian@omicron ~ $ ssh -Y christian@localhost ~/software/inkscape/bin/inkscape /tmp/sinplot.svg
Password:

After authentication, inkscape opens a window with the sinplot.svg. Everything seems to work.

You can also work around the crash with "su - username", but just "su username" does not work.
christian@omicron ~ $ su christian
Password:
christian@omicron ~ $ ~/software/inkscape/bin/inkscape /tmp/sinplot.svg
The program 'inkscape' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 4566 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
christian@omicron ~ $ exit
christian@omicron ~ $ su - christian
Password:
christian@omicron ~ $ ~/software/inkscape/bin/inkscape /tmp/sinplot.svg

Now inkscape opens a window with the sinplot.svg.

I have tried to reproduce this bug with all the GTK+ versions from
2.12.0 to 2.18.2. The first version to make inkscape crash is GTK+
2.15.2, but it crashes with a segmentation fault regardless of whether
we pass it a file on the command line.

GTK+ versions 2.15.3 through 2.17.2 all make inkscape crash if and
only if we pass it a file on the command line. It seems they all
reproduce this bug. Importantly, this includes the entire stable 2.16
series.

I have tested:

gtk-2.12.0: inkscape works
gtk-2.12.1: inkscape works
gtk-2.12.2: inkscape works
gtk-2.12.3: inkscape works
gtk-2.12.4: inkscape works
gtk-2.12.5: inkscape works
gtk-2.12.6: inkscape works
gtk-2.12.7: inkscape works
gtk-2.12.8: inkscape works
gtk-2.12.9: inkscape works
gtk-2.12.10: inkscape works
gtk-2.12.11: inkscape works
gtk-2.12.12: inkscape works
gtk-2.13.0: inkscape works
gtk-2.13.1: inkscape works (with unrelated Gtk warning)
gtk-2.13.2: inkscape works
gtk-2.13.3: inkscape works
gtk-2.13.4: inkscape works
gtk-2.13.5: inkscape works
gtk-2.13.6: inkscape works
gtk-2.13.7: inkscape works
gtk-2.14.0: inkscape works
gtk-2.14.1: inkscape works
gtk-2.14.2: inkscape works
gtk-2.14.3: inkscape works
gtk-2.14.4: inkscape works
gtk-2.14.5: inkscape works
gtk-2.14.6: inkscape works
gtk-2.14.7: inkscape works
gtk-2.15.0: inkscape works
gtk-2.15.1: inkscape works
gtk-2.15.2: inkscape crashes (Segmentation fault)
gtk-2.15.3: inkscape crashes (gdk_x_error)
gtk-2.15.4: inkscape crashes (gdk_x_error)
gtk-2.15.5: inkscape crashes (gdk_x_error)
gtk-2.16.0: inkscape crashes (gdk_x_error)
gtk-2.16.1: inkscape crashes (gdk_x_error)
gtk-2.16.2: inkscape crashes (gdk_x_error)
gtk-2.16.3: inkscape crashes (gdk_x_error)
gtk-2.16.4: inkscape crashes (gdk_x_error)
gtk-2.16.5: inkscape crashes (gdk_x_error)
gtk-2.16.6: inkscape crashes (gdk_x_error)
gtk-2.17.0: inkscape crashes (gdk_x_error)
gtk-2.17.1: inkscape crashes (gdk_x_error)
gtk-2.17.2: inkscape crashes (gdk_x_error)
gtk-2.17.3: inkscape works
gtk-2.17.4: inkscape works
gtk-2.17.5: inkscape works
gtk-2.17.6: inkscape works
gtk-2.17.7: inkscape works
gtk-2.17.8: inkscape works
gtk-2.17.9: inkscape works
gtk-2.17.10: inkscape works
gtk-2.17.11: inkscape works
gtk-2.18.0: inkscape works
gtk-2.18.1: inkscape works
gtk-2.18.2: inkscape works

I have not recompiled inkscape between switching GTK+ versions here. I
don't _think_ that should affect the result.

Alex Valavanis (valavanisalex) wrote :

I'm marking this as fixed in Ubuntu, as the bug no longer affects the latest stable version (karmic), which uses gtk 2.18.3.

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
jazzynico (jazzynico) wrote :

Closing this report "fix released" (gtk 2.17.3+).

Changed in inkscape:
status: New → Fix Released
Changed in inkscape (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.