PDF import template or default

Bug #333953 reported by LucaDC on 2009-02-24
2
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Sorry if what I'm asking is already implemented, but I couldn't find a way to get this.
I often start my designs from PDFs, importing them in Inkscape and saving to SVG.

I've set up my default.svg with all the options I always need, but it's not used when importing a PDF.

Is there a file where I can set up the environment to get after a PDF import? If not, is it possible to add this feature, so the PDF import is done over a template? (default.svg or the locale equivalent would be good for me, but maybe a default.pdf.svg is more flexible).

Thanks in advance.

tags: added: pdf
Pablo Trabajos (pajarico) wrote :

I'm setting this as invalid. Here is the rationale: this is basically already implemented but you're using it wrong. If you import a PDF (or any other file) into an already created document, it won't change any attribute of it like page size, etc. Instead, if you open it, it will take the page size from the PDF file.
So if what you want is to get the dimensions of the PDF page, open it instead of importing it.
If what you want is to import a PDF into an already created document, create a template and import the PDF. This way you'll have some basic settings coming from your template and the drawing of your PDF.

Feel free to revert the status if you disagree.

Changed in inkscape:
status: New → Invalid
LucaDC (dicappello) wrote :

I've just seen the reply: sorry, I missed it last summer.

Well, importing could work, indeed, but it's not like opening a PDF.
I mean, I really want to open a PDF so all objects are in their original position, and having the correct page size is also important.
What I miss is having all other Inkscape's specific options already set as I did in my template.
This is not really an issue related with PDFs, but rather a problem due to the fact that so many options are stored per document (which is not bad, by itself) and there's no way to have Inkscape get them from a different source when you open a document that does not specify them. In other words: a normal PDF will not have a unit setting, a grid definition, a current stroke width, color, caps and so on to use with tools.

I feel the problem is still open.

Thanks.

Changed in inkscape:
status: Invalid → New
su_v (suv-lp) on 2010-12-29
tags: added: importing
su_v (suv-lp) on 2010-12-29
Changed in inkscape:
importance: Undecided → Wishlist
LucaDC (dicappello) wrote :

I'm still interested in seeing this problem fixed.
To make it short, when opening a document Inkscape is applying its hard-wired configuration which is totally arbitrary and the user cannot change it in any way.
My suggestion is to make a merge between the document (not SVGs, of course) and the current default.svg (or the localized one) and import all settings not already defined in the original source (I think almost all except page size).
If this is too strict, an alternative could be to define a special template (e.g. defaultPDF.svg for PDFs and so on) to apply at each filetype Inkscape can natively open. If one wants the same settings as in default.svg, he only needs to copy default.svg to defaultPDF.svg.
A third solution could be a "merge import settings" that one could apply after opening the document, so the operation would not be automatic but, at least, all settings could be applied all at once and not manually one by one as is now necessary.
Maybe latest progresses in templates could help?

su_v (suv-lp) on 2013-10-16
tags: added: templates
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers