"Remove filters" isn't synced with SVG Filters dialog

Bug #326560 reported by Alexandre Prokoudine on 2009-02-07
4
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

When you choose "Remove filters" in the Object menu, the checkbox in SVG Filters dialog is still on.

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 9.04, Inkscape rev. 21460.
Not too serious. You can deselect and select again the object to update the checkbox status.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) on 2012-08-01
tags: added: ui
jazzynico (jazzynico) wrote :

Some connections between the object (and the filter's XML tree) and the filter editor seem to be missing.
Related: Bug #1006816 "Newly applied filter doesn't show in Filters Editor".

Changed in inkscape:
status: Confirmed → Triaged
John Smith (john-smithi) wrote :

Cant reproduce with Ubuntu 12.04 r11843.
Filter->Remove Filters causes Filter Editor checkboxes to update correctly.

su_v (suv-lp) wrote :

John Smith wrote:
> Cant reproduce with Ubuntu 12.04 r11843.

On OS X 10.7, reproduced with <= r11593, not reproduced with >= r11598.

Likely fixed in r11596
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/11598>
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11596>

Changed in inkscape:
milestone: none → 0.49
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers