Calligraphy tool crashes app when guide path used

Bug #324673 reported by John Adams on 2009-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

I'm not sure if this is exactly the same problem reported earlier regarding the calligraphy trace tool.

inkscape 0.46 on win xp

usually immediately upon hitting the ctrl button to try and start a trace, inkscape crashes with the following reported in an error dialogbox:

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Program Files\Inkscape\Inkscape.exe

This application has requested the Runtime to terminate in an unusual way.
Please contact the application's support team for more information.

A screenshot is attached.

John Adams (geartooth) wrote :

please try a recent SVN build, there were many fixes in this area

John Adams (geartooth) wrote :

I just tried the precompiled dev build Inkscape20697-0902142327.7z Feb. 14 '09

There is no way to tell if this is fixed because this build trashes my wacom tablet.

The tablets pen can select menu items and tool buttons and can move the cursor around the drawing area, but it cannot draw anything at all.

bbyak (buliabyak) wrote :

please help us to find the source of this regression - if you can roll
back your SVN and recompile, to find out at which revision it appears,
that would be very helpful - thanks!

John Adams (geartooth) wrote :

just tried the precompiled dev build May 7 '08

I thought I was using gdb correctly and I was able to reproduce the crash but the gdb bt command just said no stack.

baktracefailish.txt is the details of the gdb session.

Is a SVN rollback part of gdb?

Alexander Smirnov (inkscaper) wrote :

My inkscape 0.46 on win xp is not crash.

Changed in inkscape:
milestone: none → 0.46
status: New → Incomplete

I can reproduce that crash using 0.47 pre2 in Ubuntu 9.04 64 bit with a tablet. All the time. Sometimes does the autosave, sometimes it just disappears.
The funny thing is that I can't reproduce it in another machine with the same system, very similar hardware and the same build (but without a tablet).

In the machine that crashes I tried to deactivate pressure, deactivate the tablet from the input devices dialog and it still crashes.

I'll try to get a backtrace.

Changed in inkscape:
status: Incomplete → Confirmed

inkscape from GDB didn't crash but froze my desktop, so I had to kill gdb and I couldn't get a bt. The only thing I got is this. Does it make any sense?

** (inkscape:26367): WARNING **: Failed to create path: invalid data in dc->cal1 or dc->cal2
terminate called after throwing an instance of 'Geom::ContinuityError'
  what(): lib2geom exception: Non-contiguous path (2geom/path.cpp:355)

su_v (suv-lp) wrote :

bug reports with the same error messages:

> WARNING **: Failed to create path: invalid data in dc->cal1 or dc->cal2

Bug #247166 “calligraphic pen stroke sometimes fails”
Bug #347987 “Strange random error message”: Comment #7, #16 (Ubuntu, Fedora)

> terminate called after throwing an instance of 'Geom::ContinuityError'
> what(): lib2geom exception: Non-contiguous path (2geom/path.cpp:355)

Bug #284546 “SVN, rev.19997: Crash on using calligraphy tracing tool with wacom tablet” (OpenSUSE, XP, Gentoo)
Bug #409043 “3D + rectangle quit after rotation” (XP)

jazzynico (jazzynico) on 2009-10-01
Changed in inkscape:
importance: Undecided → High
milestone: 0.46 → 0.47.1
tags: added: tablet
laborator (thomas-j-schrader) wrote :

Hi everybody,

it still fails on Mac OS X and Windows 7 and renders the whole tracing thing plainly speaking *unusable* ...

Posted my investigations on Bug #284546 ...

Cheers

laborator

su_v (suv-lp) wrote :

linking as duplicate to bug #284546. Please add a comment and revert the duplicate status if you don't agree and think these are separate issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers