UI improvement for link addition

Bug #321775 reported by pygmee on 2009-01-27
2
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Kris

Bug Description

Actually when one wants to add a link you have :
1, Create the object
2, right click>create link
3. right click>set link

I guess step 2 could be ignored. Link could be added only if link window is modified, and removed if all the fields are empty.
33% time saved.

Tags: ui Edit Tag help
Pablo Trabajos (pajarico) wrote :

That's not how it works, at least from 0.46 onwards. You only have to click on "create link" and on the next right click you'll get more link options. I don't understand your proposal because there is no "set link" option on that menu.

Changed in inkscape:
status: New → Incomplete
pygmee (pygmee) wrote :

well, i've been reported this some time ago, and it's gone out of my head now. But, i've just build and i don't see the changes since. In fact, i'm wondering if the "create link" menu would not open the link settings by default. Because, what does a link mean without any attribute ? I'm also wondering if it could not be a dockable window because link will certainly be most useful for web svg, which means here can be many link in the drawing and that it can be boaring to display the window link after link. In the same way, required attributes should more important than other in the window. In fact, my best solution woule be :
- no "create link" command
- a dockable link window
- when the window is changed, link is automatically created or updated

what do you think of this ?

Changed in inkscape:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
jazzynico (jazzynico) on 2009-08-06
tags: added: ui
Kris (kris-degussem) wrote :

Setting to Fix committed.
Code for the link properties dialog is rewritten in trunk revision 10910. Link properties is now dockable.
Link properties window also opens by default after clicking "Create link"

Changed in inkscape:
assignee: nobody → Kris (kris-degussem)
status: Confirmed → Fix Committed
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers