export via cairo -> shifted image

Bug #320646 reported by crusaderv83 on 2009-01-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
Inkscape Devlibs
Medium
Unassigned

Bug Description

if you export the svg as a pdf, the circle in the middle is shifted.

crusaderv83 (s-kegel) wrote :
theAdib (theadib) wrote :

First I confirm this issue.
I played a litte bit with your drawing. Your circles are geometrically not 100% identical, one is open, they have different skew values, the points are not on the same coordinates, etc.
All of this differences are in the 4th or so digit. So I guess there is an numerical issue in the path representation during the conversation to cairo that leads to this visible differences.
What is the numerical representation in the Lib2geom (inkscape-cairo.cpp) ?
Adib.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Stefan (stefan-roellin) wrote :

Seems to be a cairo bug. The attached program reproduces this behavior without inkscape.

The program just draws two circles: one solid and one transparent exactly over the first. As can be seen from the program, the use of cairo_push_group and cairo_pop_group_to_source leads to an unexpected shift of the second circle.

see https://bugs.freedesktop.org/show_bug.cgi?id=22441

Alex Valavanis (valavanisalex) wrote :

Similar bug forwarded from Debian..?

bug #705345 "Cairo rendering broken for "use" elements with scaling or a viewBox"

su_v (suv-lp) wrote :

Related:
Bug #562592 “misaligned transparent paths in pdf export”

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape 0.48.1 (cairo 1.10).
Not reproduced with 0.48.2, recent trunk revisions (cairo 1.11.2) and local tests with cairo 1.12.8.

Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Marking the bug fixed for win32.

Changed in inkscape-devlibs:
importance: Undecided → Medium
status: New → Fix Released
su_v (suv-lp) wrote :

Seems to have been fixed upstream in cairo 1.10.2.

Closing as 'Invalid' for project 'Inkscape' since this was an upstream bug in earlier cairo releases which got fixed in stable cairo release 1.10.2. All latest stable release packages of Inkscape for Windows and Mac OS X include newer versions of cairo which are no longer affected.

Please reopen if you think this report was closed in error.

Changed in inkscape:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.