Cannot trace large .TIF image

Bug #319644 reported by Rick on 2009-01-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Attempting to trace a large .TIF image causes application to terminate. To reproduce this bug, load an image of the following specification, then try to Trace Bitmap...

Width: 7398 pixels
Height: 3142 pixels
Horizontal Resolution: 1200 dpi
Vertical Resolution: 1200 dpi
Bit Depth: 24

Approximate File Size: 45 MB

Pablo Trabajos (pajarico) wrote :

You forgot to tell what OS and inkscape version you're using. This bug seems related to #400396.

Pablo Trabajos (pajarico) wrote :

By the way, please attach a compressed JPG of the file. I've found similar problems when tracing but these are usually more related to the complexity of the image rather than to the format.

Changed in inkscape:
status: New → Incomplete
Rick (rick-elwell) wrote :

I was doing this for an art project. Adobe Illustrator could handle parts of it, but not the whole thing. The difficulty with R2V conversion on intaglio prints is that the ink bleeds into the paper causing jagged edges that tracing programs cannot smooth out. Something else you may or may not be wondering about... yes, i've scanned in a banknote... however we are still in compliance with federal law... we are not printing or intending to defraud. For me it is a project to create something derived from banknote artwork.

Pablo Trabajos (pajarico) wrote :

What settings are you using with the bitmap tracer? And what version of Inkscape?

Rick (rick-elwell) wrote :

Initially when I posted the bug report I was using 0.46. Just now I tried it with the latest 0.47pre1. Attached please find a screenshot of an assert that I'm now getting.

jazzynico (jazzynico) on 2009-08-16
Changed in inkscape:
importance: Undecided → High
tags: added: crash
Pablo Trabajos (pajarico) wrote :

Rick: I tried with different settings and all seem to crash inkscape sooner or later. Trying with multiple scans:gray and other options gave me the false hope that it was working but after a couple of minutes it crashed. I'm not sure yet if the cause is the big dimensions of the file (sometimes it crashes immediately) or the complexity (sometimes it crashes after a while which could indicate it's trying to actually trace it).

Changed in inkscape:
status: Incomplete → Confirmed
tags: added: tracing
tags: added: bitmap
Marcin Floryan (mfloryan) wrote :

I was just playing with some tracing on R9102-1002211124 Windows Build. I had some large TIF b/w bitmap (8000x6000 pixels) - with a small file size (under 1MB). When I tried tracing that bitmap - Inkscape crashes if I bring up the Trace window and click OK (with default settings) however if I click Update first and the Ok - the bitmap is traced correctly and Ink works fine.

Kris (kris-degussem) wrote :

Original bitmap too big in size to import.
Playing with a 4928x3264 photo does not show any issues, including the preview issue reported in comment 7 (vista 64 bit, Inkscape 0.48.4).
Hence issue could not be reproduced. Quite probably it is related to the size. If not, also it should be considered that it is a scan, whose background is quite variable and that a lower quality scan (less pixels) would also have done the trick.

jazzynico (jazzynico) wrote :

Tested with trunk rev. 14037 on Crunchbang Waldorf.
Tracing the banknote from comment #3 takes a good 10 minutes with a 2 years old i5 processor and requests about 2 Gio of RAM, but it doesn't crash. Note that the generated object has tens of thousands nodes and is very slow to handle.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers