Duplicating text along path doesn't link both

Bug #312116 reported by Gatonegro on 2008-12-29
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc
inkscape (Debian)
Fix Released
Unknown

Bug Description

When you place a text along a path and duplicate (ctrl+D) them both, the result is a copy of the original path and a copy of the original text *linked to the original path*, not to the new copy. Hence, all changes to the original path will affect the copy text, and no changes in the copy path will affect the copy text.

This is (IMHO) a big problem when you create a text-along-path "object" and copy it for experimentation (something that is relatively frequent when typesetting flyers, logos, posters, etc).

The correct behavior would be to re-link the new text to the new path, keeping the transformations done to the text.

Related branches

Alvin Penner (apenner) wrote :

it looks like this may be related to the behaviour of the xlink:href attribute:
for example, in my drawing I have :
- an original path with id="path2694"
- an original text which is linked using : xlink:href="#path2694"

- a new pasted path with an id="path2727"
- a new pasted text which is linked using : xlink:href="#path2694-1

it appears that the link to 2694-1 is not working. Interestingly enough, the id 2694-1 actually does exist, but it is in the <defs> section, not the main body.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) on 2011-02-01
Changed in inkscape:
importance: Undecided → Low
tags: added: text
Changed in inkscape (Debian):
status: Unknown → Confirmed
Beluga (buovjaga) wrote :

Still repro.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.92pre1 15054 (GTK3)

Mc (mc...) wrote :

Fix committed in trunk to r15117

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
Mc (mc...) wrote :

... and minor problem fixed in r15118 (previously, original text was relinked to duplicated path, which was weird and could only be detected by moving the selection right after the duplicating)

Changed in inkscape (Debian):
status: Confirmed → Fix Released
su_v (suv-lp) wrote :

Please milestone to 0.93 (this change is not part of 0.92).

jazzynico (jazzynico) on 2017-01-05
Changed in inkscape:
milestone: none → 0.93
Eduard Braun (eduard-braun2) wrote :
Changed in inkscape:
milestone: 0.93 → 0.92.2
jazzynico (jazzynico) on 2017-08-31
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.