segfault when drawing closed path in sketch mode

Bug #310206 reported by naught101 on 2008-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

To reproduce:
- select pencil tool, default settings
- hold alt and draw closed loop
- let go of mouse button, let go of alt key
- click "ok" on error message
- note segfault in console.

$ inkscape --version
Inkscape 0.46+devel (Dec 21 2008)

Error output:

(inkscape:19513): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

** (inkscape:19513): WARNING **: Family name LondonTwo does not have an entry in the font lister.

Emergency save activated!

Emergency save document locations:
  New document 1.2008_12_21_23_14_43.0.svg
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Segmentation fault

Alvin Penner (apenner) wrote :

confirmed on Win32 build 20375, Dec. 15.

exit message is:
C:\Python25\APP>inkcl.py
return code: -1073741819
Emergency save activated!

Changed in inkscape:
status: New → Confirmed
Johan Engelen (johanengelen) wrote :

Ok, I've fixed the crash; but a problem remains.
I am not sure how to handle this. Should I close the path? But as it is a sketch, it might not be drawn closed the second time it is sketched...
So for now, it does not close the path.

Changed in inkscape:
assignee: nobody → johanengelen
status: Confirmed → Incomplete
naught101 (naught101) wrote :

I didn't really understand sketch mode when I filed this bug, but after reading "it might not be drawn closed the second time it is sketched", I tried it again. Interesting to note that if you draw the same path multiple times, all closed then it will crash, but if you draw even one of the paths open, it works fine, without a crash

I would say that if all the paths are drawn closed, then close the path, since it's obvious that if the user makes the effort to close each sketch then they want it closed.

Perhaps you could flesh out the explanation here for others who don't get it:
http://wiki.inkscape.org/wiki/index.php/ReleaseNotes047#Pencil_sketch_mode

Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) on 2012-10-01
Changed in inkscape:
importance: Undecided → High
tags: added: crash
Johan Engelen (johanengelen) wrote :

the crash should be fixed now (really) in rev 11723.

issue remains about what to do for closed path stuff... ideas are welcome

Changed in inkscape:
status: Confirmed → Incomplete
Johan Engelen (johanengelen) wrote :

marking as fix committed. the closed path issue could be opened separately if it is really an issue at all. :)

Changed in inkscape:
milestone: none → 0.49
status: Incomplete → Fix Committed
su_v (suv-lp) wrote :

The changes from r11723 merge cleanly into <lp:inkscape/0.48.x>, and fix the crash otherwise easily reproducible with current stable 0.48.4 (tested with 0.48.x r9960 on OS X 10.7.5).

@Johan - any reason not to backport your fix to the stable branch?

tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to lp:inkscape/0.48.x in revision 9993.

Changed in inkscape:
milestone: 0.49 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers