Inkscape: A Vector Drawing Tool

color management - link profile segfault

Reported by Simon Dahlbacka on 2008-12-12
4
Affects Status Importance Assigned to Milestone
Inkscape
High
Felipe "Juca" Sanches

Bug Description

Environment:
Vista x64
mingw 4.2.1
devlibs svn revision 14
inkscape trunk svn revision 20357

Steps to reproduce:
start inkscape
open document properties
go to Color management tab
(linked color profiles listbox is empty, available color profiles combo is empty. However, so far everything is probably as it should.)
Now, if I click the Link Profile button, Inkscape segfaults.

"Inkscape encountered an internal error and will close now."

there should be something listed in "available profiles".
I will add a special case check on the button handler to avoid the crash, but we should investigate why you have absolutely nothing listed there...

Changed in inkscape:
assignee: nobody → felipe-sanches

I have just committed a quick fix to this crash. Could you please svn update, compile it and test again?

On Thu, Jan 29, 2009 at 11:09 PM, Felipe Juca Sanches
<email address hidden> wrote:
> I have just committed a quick fix to this crash. Could you please svn
> update, compile it and test again?
>

just did that, and no crash anymore.

now, please, check whether there are files with the cms or icm extension in your system.
If you find such file types, plese tell me where they are located.

attached result of dir /s *.icm
From that list, I'm assuming that
C:\Windows\System32\spool\drivers\color is the "correct" location.
Hmm, might it be that the fact that I'm running a x64 system matters?

On Fri, Jan 30, 2009 at 12:21 AM, Felipe Juca Sanches
<email address hidden> wrote:
> now, please, check whether there are files with the cms or icm extension in your system.
> If you find such file types, plese tell me where they are located.
>
> --
> color management - link profile segfault
> https://bugs.launchpad.net/bugs/307567
> You received this bug notification because you are a direct subscriber
> of the bug.
>

we can eventually fix it by making inkscape look at these directories. I think that Vista could be more well organized and put these files in a default place instead of spread all over your system...

But be aware that color management in inkscape is still not ready for production use. This is a user interface bug that we are trying to fix. But then we still need to finish the actual color management support implementation...

So dont expect it to work right now because it wont.

On Fri, Jan 30, 2009 at 1:40 AM, Felipe Juca Sanches
<email address hidden> wrote:
> we can eventually fix it by making inkscape look at these directories. I
> think that Vista could be more well organized and put these files in a
> default place instead of spread all over your system...
>
I am pretty sure there is one default location, and the very location
of which is most likely saved somewhere in the registry. A quick
googling seemed to reveal that it indeed is
C:\Windows\System32\spool\drivers\color that is the "correct"
location. (as it seems to have been in xp too?)

> But be aware that color management in inkscape is still not ready for
> production use. This is a user interface bug that we are trying to fix.
> But then we still need to finish the actual color management support
> implementation...
>
> So dont expect it to work right now because it wont.

sure, this bug report is more or less the result of "monkey testing"
of my part, i.e. I was just clicking around more or less randomly when
I happened to notice this one.

Jon A. Cruz (jon-joncruz) wrote :

The crash seems to be fixed, so I'm closing this bug.
If Inkscape still is not finding the colors from the "correct" Windows directory, then that is a different issue and needs a new bug. BTW, the Win32 API has a function to retrieve that, so we shouldn't hard-code it.

Changed in inkscape:
importance: Undecided → High
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments