various things are displaced

Bug #299362 reported by Brynn
14
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Medium
Unassigned

Bug Description

This is to summarize another bug report, which because I've had no experience with reporting bugs, I've made rather a mess. I will make that report a duplicate of this, because it does contain all the details in each case, as well as attached files.

This is all happening with Inkscape v 0.46, the last stable release, under Windows XP Home SP 3, fully updated. I'm just an ordinary Inkscape user, and have no way of testing these problems in different versions under different OS's.

I have 4 unique instances of things being displaced. In all cases, I used one transformation or another, and the "Fit page to selection" feature. I suspect the Fit page feature is somehow causing transformation to be applied to other objects and/or layers than it was originally applied. It may be that transformations are not buggy on their own. I believe the bug is in the "Fit page to selection" feature, which causes transformation data to be applied to all layers in existance when the transformation is done.

The 1st case is a clipping path which is displaced when the clip is set. The attached file for this case is "clipping-bug.svg". Please see the duplicate bug for a full description and the file.

The 2nd case is radial tiled clones which are sprayed around the canvas, instead of all in one place, as the settings indicate they should be. The attached file for this case is "radtc.svg". Please see the duplicate bug for a full description and the file.

The 3rd case is single dots made with Control + click with either the pen tool or pencil tool. The attached file for this case is "p-c2a.svg". Please see the duplicate bug for a full description and the file.

The 4th case is a radial gradient which shows up some distance away from where it is applied. The attached file is "radgrsamp.svg". Please see the duplicate bug for a full description and the file. (This one may also contain another bug involving grouped ellipses.)

Please note that I 1st reported all these issues at Inkscapeforum.com, where members with much more experience than me, can't solve the problem, and suggested I report them as bugs. Links to those threads appear in the duplicate bug. And those threads contain links to sample files, which are somewhat different than those attached.

As I've stumbled upon each case, in working with different images, when I click to apply the various things (clipping path, tiled clones, single dots, radial gradient) they disappear. It was only when I posted messages and files, asking for help, that it was discovered the various things did not disappear, but in fact were applied in some distant area of the canvas.

I've tried to be as brief as possible here, but I see this report has grown long. I apologize, but I think it's all important info. Thanks for your time and attention to these issues. Please feel free to contact me if you have any questions.

All best,
Brynn

Revision history for this message
Brynn (brynn4inks-deactivatedaccount) wrote :
tags: removed: clipping-path displaced fit-page-to-selection radial-gradient-fill single-dots tiled-clones
Revision history for this message
Pablo Trabajos (pajarico) wrote :

The first case looks similar to #351281 "clips and masks should transform along the affected object."

Revision history for this message
Pablo Trabajos (pajarico) wrote :

Also I can't find the other bug so I don't have the descriptions of each file for 2nd, 3rd and 4th.

Revision history for this message
su_v (suv-lp) wrote :

@Pablo
> Also I can't find the other bug
It's the one Brynn had linked as duplicate, bug #284709.

2nd case: Bug #168651 “"Tiled Clones" inside transformed groups broken” (confirmed)
3rd case: Bug #427267 “single dots (Ctrl+click) inside transformed groups misplaced” (fixed)
4th case: possibly [1] Bug #317108 “The Gradient jumps around when editing it.” (new)

[1] that description is soo long (Brynn, you know ;) ), I guess it's the same issue what I analyzed in one of my early contributions in the forum <http://www.inkscapeforum.com/viewtopic.php?f=5&t=3686&p=17057> (file attached in my last comment there) - maybe I'll revisit this later.

Revision history for this message
Brynn (brynn4inks-deactivatedaccount) wrote :

Re: Pablo comment #2
I don't know if I agree that it is related to bug #351281. In this bug, everything just disappears. In the other, the clipping path is not transformed along with object. Right?

I just don't know enough about how Inkscape works, or investigating or examining the file to know why things happen. (That's why I made the message long enough to include everything that I thought might be relevant. Sorry *again* for the mess I made of it. I do try to avoid reporting bugs, because of this.)

Thanks again :-)
Brynn

Revision history for this message
su_v (suv-lp) wrote :

from 'clipping-bug.svg':

  <g
     inkscape:groupmode="layer"
     id="layer28"
     inkscape:label="1.5"
     transform="translate(-649.46271,-11.311015)" >

  <g
     inkscape:groupmode="layer"
     id="layer12"
     inkscape:label="1.9"
     transform="translate(-749.99996,-424.02675)">
  </g>

1nd case: Bug #569281 “layer translation attributes on canvas resize mess things up later on”
<https://bugs.launchpad.net/inkscape/+bug/569281>

Revision history for this message
su_v (suv-lp) wrote :

s/1nd case/1st case/

Revision history for this message
su_v (suv-lp) wrote :

Update 2015-10-06:
1) Displaced clipping path: duplicate of bug #284709. Fixed in current trunk (fix confirmed with Inkscape 0.91+devel r14397).
2) Displaced radial tiled clones: duplicate of bug #168651. Fixed in current trunk (fix confirmed Inkscape 0.91+devel with r14397).
3) Displaced single dots: duplicate of bug #427267. Fixed in 0.48 (fix confirmed Inkscape 0.91+devel with r14397).
4) Displaced gradient: duplicate of bug #317108 (or at least sharing the same underlying issue). Not fixed yet.

Revision history for this message
su_v (suv-lp) wrote :

Multiple issues cannot be tracked properly within a single report - I'll update the status of this one as time permits (the actual bug status, milestone and releases will be handled in individual specific reports, linked to commits and assigned to the developer committing the fix).

On 2015-10-06 23:16 (+0200), ~suv wrote:
> 1) Displaced clipping path: duplicate of bug #284709. Fixed in
> current trunk (fix confirmed with Inkscape 0.91+devel r14397).

This one was fixed recently by Mc in Revision 14130: "fixes various bugs with clipping and masking" (for bug #569281, bug #1319171, bug # 1177650). The fix will be available in the next major release 0.92.

Revision history for this message
Brynn (brynn4inks-deactivatedaccount) wrote :

Thanks ~suv and others, both for the fixes, and for patience with having several different issues in one report. I didn't know better at the time I posted.

Thank you very much!

Revision history for this message
su_v (suv-lp) wrote :

Setting bug status and importance based on status of the 4 separate issues:
- Issues 1-3 have fixes committed
- Issue 4 (bug #317108) still pending

Changed in inkscape:
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Hachmann (marenhachmann) wrote :

The fix for the tiled clones/layer transform bug is worth mentioning in the release notes, I think. It has been bothering lots of people.

@suv or Mc: was that fixed by the same commit that fixed the clips dislocation? Is there a separate bug report for it somewhere that could be linked from the release notes?

Revision history for this message
su_v (suv-lp) wrote :

@Hachmann - you can look for example at what was prepared for the (never realized) 0.91.1 release:
http://wiki.inkscape.org/wiki/index.php/Release_notes/0.91.1#Important_bugfixes
for older fixes (basically all fixes listed there will be part of 0.92 now because 0.91.1 was never released). The issue with tiled clones inside transformed (layer) groups is not tracked in this report (bug #299362) - it is as mentioned in earlier comments tracked in bug #168651.

Note that the (by now obsolete) 0.91.1 release notes prepared don't include later fixes - those can be best searched for on the milestone page for upcoming 0.92:
https://launchpad.net/inkscape/+milestone/0.92

Revision history for this message
Hachmann (marenhachmann) wrote :

Thank you very much, suv! This is good news :)

I didn't even remember that the 0.91.1 release notes draft existed... you had added quite a lot there already.
I'll update the new release notes with the most important ones (or at least with what I believe is most important). The notes are getting awfully long - shows how much work has been done, though :D

Revision history for this message
Hachmann (marenhachmann) wrote :

<offtopic, again, sorry!>How about re-targeting the 124 bugs milestoned for 0.91.1? Would be good to have them all in a single list, I think...</offtopic>

Revision history for this message
su_v (suv-lp) wrote :

<off-topic>
@Hachmann - Bryce can run (python) scripts for such mass changes. For the past releases, this was how reports with status 'Committed' and the specific milestone of the release were bulk-changed to bug status 'Fix Released'.
After the 0.92 release, there could be a second run of such a script which bumps committed reports targeted for milestone 0.91.1 to 0.92 and adjusts bug status accordingly.
</off-topic>

Revision history for this message
Hachmann (marenhachmann) wrote :

Thx! Will need to watch out for this, and remove the second link from the release notes, when it was done.

Revision history for this message
su_v (suv-lp) wrote :

<off-topic>
@Hachmann: I would recommend - once the final 0.92 release has been cut - to ping Bryce on irc (#inkscape-devel) directly about those (committed) reports which had been milestoned at the time for 0.91.1. The bug-fix release 0.91.1 was never officially "canceled" or otherwise closed on Launchpad, and the current state thus is still kind of 'pending' or unresolved.
</off-topic>

Revision history for this message
Hachmann (marenhachmann) wrote :

<offtopic>
Thanks for the hint, I hope I'll remember.
</offtopic>

Revision history for this message
Qantas94Heavy (qantas94heavy) wrote :

If the rest of the bugs are fixed and only bug 317108 remains, this should probably be marked as fixed and we'll leave the final issue to be tracked in that bug.

Closed by: https://gitlab.com/Qantas94Heavy

Changed in inkscape:
status: In Progress → Fix Released
tbnorth (terry-n-brown)
tags: added: bug-migration
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.