Inkscape: A Vector Drawing Tool

Semi-Bold font style not applied

Reported by Gatonegro on 2008-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I have just installed a font family which has regular, light, bold and semi-bold variants, and while in the text properties window all are listed (under "Style"), and I can select the "semi-bold" variant (and in the preview area it is displayed properly), when I click on "Apply", it defaults back to the bold variant.

I think this may be because Inkscape is not properly parsing the "semi-bold" name when inserting it into the XML (perhaps because of the hyphen (-)? ), but I'm not sure.

I cannot attach the font because it is not free, but I'd like confirmation to know if this is really an Inkscape issue, or if it is a font problem.

Terabyte (terabyte) wrote :

I can fully confirm this bug with a Semi-Bold version of a proprietary font (ITC Eras Semi-Bold) in the latest svn build. I do not believe however, that it is due to a hyphen (-), since other font variants, such as Ultra-bold do show correct behavior.

~suv (suv-lp) on 2010-02-21
tags: added: fonts
~suv (suv-lp) wrote :

confirmed per comment #1

possibly related to
Bug #165521 “font variants information ignored”
<https://bugs.launchpad.net/inkscape/+bug/165521>
Bug #167353 “Fonts weight variants selection”
<https://bugs.launchpad.net/inkscape/+bug/167353>

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
~suv (suv-lp) wrote :

Do you still have this issue in Inkscape 0.48 or later development builds?

There have been several font weights added to be handled properly in Inkscape, as part of the refactored text tool:
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.48#Text_Tool>

Changed in inkscape:
status: Confirmed → Incomplete
Kris (kris-degussem) wrote :

Closing report by lack of user feedback.

Changed in inkscape:
status: Incomplete → Fix Released
Andreas Sommer (andidog) wrote :

Fixed in the latest dev version (2012-10-08) on Windows (not yet in the stable version 0.48.3.1r9886).

jazzynico (jazzynico) on 2012-10-23
Changed in inkscape:
milestone: none → 0.49
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers