[Win32] Save As/Save a Copy not shown

Bug #285267 reported by Ravager on 2008-10-18
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Inkscape
Critical
Jon A. Cruz

Bug Description

Since the switch to native dialogs, when I click on 'Save as' or 'Save a copy', the only thing that happens is the whole view is redrawn (including applications OTHER than inkscape).
The 'Open' dialog shows as normal.

OS: Windows XP Service Pack 3

Alvin Penner (apenner) wrote :

which version of Inkscape ?

Ravager (ravager01) wrote :

Recent snapshots, starting from the 19900's.

Alvin Penner (apenner) wrote :

running Windows XP, Inkscape19989-081013.7z,
I cannot reproduce this problem.
So this happens when you click on the menu item that says File | Save As ... (or shift-ctrl-S) ?

Ravager (ravager01) wrote :

Correct.

Alvin Penner (apenner) wrote :

could you try this with a recent build ?

Changed in inkscape:
status: New → Incomplete
Ravager (ravager01) wrote :

Even in 21044, I still cannot bring up the Save As/Save dialog..

Alvin Penner (apenner) wrote :

- is this a blank document?
- do the Save and Save As buttons work differently, because I know that the Save button doesn't work on a blank document

Ravager (ravager01) wrote :

I always test with an already created SVG.

Alvin Penner (apenner) wrote :

so, are you not able to save any document in any way at all?

Changed in inkscape:
status: Incomplete → New

Ravager: Did you try removing the inkscape configuration folder in Documents and Settings?

Btw, it's probably a Windows only bug. I've never seen something like that in Linux.

Alvin Penner (apenner) wrote :

yes, you might want to take the file
C:\Documents and Settings\yourname\Application Data\Inkscape\preferences.xml
and rename it to be something else, to force Inkscape to start from a default configuration.

The folder 'Application Data' is sometimes hidden, so you may need to type in the name explicitly

Ravager (ravager01) wrote :

Just did. No change.

Alvin Penner (apenner) wrote :

just to clarify, are you able to save a document in any way at all, or do none of the save procedures work?

Ravager (ravager01) wrote :

None of them work.

Alvin Penner (apenner) wrote :

- well, I'm at a loss, the only thing I can think of is to try to trap any exit messages that may be generated using the method outlined in http://kaioa.com/node/63
- to use this method, you'll need to download the file inkscapec.exe from this website, put it in the directory C:\Program Files\Inkscape, or wherever your Inkscape is, and then use it to start up Inkscape. Unfortunately, this is best done from a DOS Window, but it will allow you to see any error messages that Inkscape generates.

Ravager (ravager01) wrote :

Oddly, I get no errors when i select any of the 'save' options.
Was there ever discussion about adding the option to select between GTKmm and Native dialogs?

Ravager (ravager01) wrote :

Here's a thought.
Would uxtheme.dll being modified have anything to do with this?

Alvin Penner (apenner) wrote :

- with respect to the switch from GTK to Native, I don't think it would be feasible to support both, or to be more exact, the amount of work involved in supporting both would probably be prohibitive.
- with respect to uxtheme.dll, mine is version 6.0.2900.5512 modified April 14, 2008. (I have to confess I've never heard of this dll before. I guess the question is, do your other Windows programs have "normal" Save As dialogs, since uxtheme is probably common to them all.)
- is there anything at all even remotely unusual about your machine? I'm running Windows XP Home edition SP3. For example, user name with unusual characters? I heard about strange unexpected behaviour caused by an '&' in a user name. Or maybe directories that are read-only? Or installation in a directory other than C:\Program Files\Inkscape\. Or any kind of security setting that might restrict your ability to write to a file.

Ravager (ravager01) wrote :

Normal username, no file restrictions, save dialogs are 'normal' for everything else, same UXTheme.dll version as you, Windows XP Pro SP3.

Alvin Penner (apenner) wrote :

well, I'm stumped...

sfranky (sfranky) wrote :

same here...problem only with developmental versions.. I have one thing to add.. the window DOES exist, but it's invisible..I tried moving it with alt+space, and i can see its upper edge moving..and then , if i start typing a name, i can see the drop down menu (auto complete) ...
windowsxp sp3

jazzynico (jazzynico) wrote :

Confirmed by duplicate Bug #408592.

I've had that kind of behavior with OpenOffice (the font selector was weird).
Removing UXTheme resolved the bug.

Changed in inkscape:
importance: Undecided → High
status: New → Triaged
tags: added: ui win32

yes but i dont have uxtheme installed (is that an xp theming application??)
and the problem was solved in later nightly builds of inkscape !!!!

On Fri, Aug 7, 2009 at 4:42 PM, JazzyNico <email address hidden> wrote:

> Confirmed by duplicate Bug #408592.
>
> I've had that kind of behavior with OpenOffice (the font selector was
> weird).
> Removing UXTheme resolved the bug.
>
> ** Changed in: inkscape
> Importance: Undecided => High
>
> ** Changed in: inkscape
> Status: New => Triaged
>
> ** Tags added: ui win32
>
> --
> [Win32] Save As/Save a Copy not shown
> https://bugs.launchpad.net/bugs/285267
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: Triaged
>
> Bug description:
> Since the switch to native dialogs, when I click on 'Save as' or 'Save a
> copy', the only thing that happens is the whole view is redrawn (including
> applications OTHER than inkscape).
> The 'Open' dialog shows as normal.
>
> OS: Windows XP Service Pack 3
>

--
Sotiris

----
I enjoy the massacre of ads. This sentence will slaughter ads without a
messy bloodbath.

jazzynico (jazzynico) wrote :

Nice to hear!
But Ravager and the other bug mentioned UXTheme.
Since I've had some UI issues with it too...

Martin Pajuste (martinpajuste) wrote :

I'm unable to use Save As dialog since the upgrade to 0.47 because it's invisible. Only way to see the dialog is to use Win classic theme. Dialog appears to be stretched out vertically. See the attachment.

OS: Win XP Prof SP3
Inkscape 0.47 r22583, built Nov 21 2009

sas (sas-sas) on 2009-12-17
tags: added: saving
sas (sas-sas) wrote :

I'm marking this as Confirmed, even though I can't reproduce it myself, since at least five people have reported this (three in this bug report, another in the duplicate report, and another on InkscapeForum.com).

Martin Pajuste's screenshot makes me wonder if this is somehow caused by the Title edit box.

Changed in inkscape:
status: Triaged → Confirmed
su_v (suv-lp) wrote :

There's another potentially duplicate report:
Bug #493588 “Save dialog boxes do not appear on save command.”:
<https://bugs.launchpad.net/inkscape/+bug/493588>

slurdge (slurdge) wrote :

I have also the bug with 0.47.
I tried to change the window properties (width is 0 in winspector spy) but it did not make the window appear.

Tested R9126, bug is also present.
Executing with windows theme disabled, IME disabled, and Windows2000 compatibility mode did not help :(.

erketre (spconv) wrote :

The same bug here. SAVE AS dialog does not appear
 - R9170
 - xp pro sp3
 - theme: classic

sad...

Krzysztof Kosinski (tweenk) wrote :

Increasing prio... not being able to save is really critical.
The cause is that a dialog with zero width is created as described in bug 493588.

Changed in inkscape:
importance: High → Critical
Al James (alex-c-jones) wrote :

Also have the bug - using Win 7 Home Prem. x64 and Inkscape 0.47 r22583, built Nov 21 2009. Only workaround to save is to make a copy of an existing .svg file, rename in Windows Explorer, and use that as a blank document (regular save, i.e. overwrite existing file without using a dialog, works ok)

Cataddict (phantom) wrote :

Chiming in as another user seeing the bug.

Inkscape versions tried: 0.47 release + several nightly builds (up to Inkscape 0.47+devel r9492)
Windows XP SP3 using classic desktop

Nirsoft's "winlister" program shows the missing "save as" dialog as 561 x 0 pixels, and if I use it to maximize the dialog, it does show up in the upper left hand corner of a full maximized screen. So on my system it seems the missing dialog is 0 height instead of 0 width as someone reported. But basically the same issue.

The "open" dialog, which brings up basically the same type dialog box works just fine and shows a size of 713 x 412 pixels.

EXTREMELY annoying bug. If I don't type the desired path in the hidden window just right, I have to track down my files by searching my whole disk.

Bram Wayman (bram-wayman) wrote :

Count me in—I just ran across the same thing. Good for Cataddict, whose use of Winlister corroborates my suspicion that the window was being called up but was for some reason not visible. (Good thinking. I didn't even know Winlister existed.) This is obviously a top-priority bug: if we can't easily save, why use a new version? :-P

Rafal Lach (mr-deimos) wrote :

I've been experiencing this bug on winXP, but it doesn't happen anymore after switching windows 7 even though the inkscape version didn't change (it didn't even get reinstalled).
So My guess is that win7 doesn't allow '0 as dimension of a window and uses default value instead.
Anyway in case some of you haven't noticed, there's a workaround in comment to Bug #493588:
https://bugs.launchpad.net/inkscape/+bug/493588/comments/11
It doesn't really fix the source of the problem but using it you won't have to change window dimensions manually and you will be able to work normally until a real fix is done in inkscape.

Krzysztof Kosinski (tweenk) wrote :

There is a call to MoveWindow in the dialog setup procedure. Either the preceding call to GetWindowRect sometimes fails, or MoveWindow misbehaves when the passed width is the same as the current width. I added some defensive code. Please test whether this patch fixes the issue.

Jon A. Cruz (jon-joncruz) wrote :

There are a few shortcomings that collapsing to a single sub-expression have in that patch. It also fails to address a *height* of zero, as mentioned in comment #32. A few other things also need to be approached differently.

Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
status: Confirmed → In Progress
Jon A. Cruz (jon-joncruz) wrote :

This patch attempts a safer and more comprehensive fix.
The height is addressed in addition to the width, magic literals are avoided in favor of legible constants, and excessive height addition is flagged.

Jon A. Cruz (jon-joncruz) wrote :
su_v (suv-lp) wrote :

@all - there is a patched build available for testing - please download 'inkscapeR9692+285267_patch.7z' from <http://inkscape.modevia.com/win32/?C=M;O=D> (it's a current development snapshot build, Inkscape 0.48+devel r9692, with the patch from comment #38 applied), unpack the archive, run inkscape and report back if the error still persists or if the save dialog now is visible and correctly sized.

Martin Pajuste (martinpajuste) wrote :

The save dialog is now visible and correctly sized.

Changed in inkscape:
milestone: none → 0.48
Bram Wayman (bram-wayman) wrote :

Just confirming that the patch posted by ~suv works. Thanks for your hard work, developers! We all appreciate it :-)

Jon A. Cruz (jon-joncruz) wrote :

Fix committed as of revision 9698 in trunk and 9650 in 0.48.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
fever2tel (fever2tel) wrote :

Hi, I am using inkscape 0.48.1 (downloaded it about 2 weeks ago) and I have this same problem.
I cant see the save and open dialogues coz they are zero height.

I type a name press enter nothing happens, then I keep pressing tab and typing a name and pressing enter hoping I reach the right box but have been unsuccessful in saving anything.

How do I apply the above mentioned patches? Its just a little bit of text code? Thanks you for any help.

su_v (suv-lp) wrote :

fever2tel wrote:
> How do I apply the above mentioned patches?

You can't and should not: the mentioned patch was already committed in time for the 0.48 release (i.e. it is included in Inkscape 0.48.0 and later releases). Please verify the Inkscape version that exposes this issue on your system with menu 'Help > About Inkscape'.

If you actually have 0.48.1 running, it seems that your issue is different -> please file a new report and provide details about your OS and Inkscape version as well as 'steps to reproduce'.

Fraser67 (fraser-cavanagh) wrote :

I am running Win XP SP3, and just installed with Inkscape version 0.48.2.r9819 to try.

When any of the save option are selected, nothing happens. No dialog boxes, nothing. So I can't save any work!

Fraser67 (fraser-cavanagh) wrote :

I have removed 0.48.2.r9819 and installed 0.48.1 and the save options now work.

su_v (suv-lp) wrote :

@Frazer67 - your issue is related to
Bug #805095 “no File->Save As... dialog box if previously opened a file from root directory of a drive”
<https://bugs.launchpad.net/inkscape/+bug/805095>
(a regression introduced with Inkscape 0.48.2)

For variants of how the issue exposes itself in 0.48.2, see e.g.
<https://bugs.launchpad.net/inkscape/+bug/872669>

(Note: this bug (#285267) had been fixed in 0.48.0)

o d (odarcan) wrote :

save and save as dialogs dont work for me either, so i have to export the image to png.

i have win 7 and latest inkscape,

this only happens OCCASIONALLY, NOT everytime. I dont know what the reason is.

the save dialog does not come up when i click it.

o d (odarcan) wrote :

a week ago there was no problem. Today i cant save ...

o d (odarcan) wrote :

when i close the program, it asks "close without saving" / "cancel" / "save", i click save nothing happens it goes back to the program. so to close you have to close without saving..

Same problem here, Windows XP SP3, Windows classic theme (but happens also with standard theme).

su_v (suv-lp) wrote :

@o d, @Patrick Ruoff - if you are using current Inkscape 0.48.2, any issues with saving not working are not related to this old bug (this one was fixed in 2010) - please my earlier comment #47:

Regressions with saving in Inkscape 0.48.2 on Windows are due to
Bug #805095 “no File->Save As... dialog box if previously opened a file from root directory of a drive”
<https://bugs.launchpad.net/inkscape/+bug/805095>

GurgiONE (elektronikbox) wrote :

I have the same problem with Windows 7 Professional.
I fix the problem when I install an older version of Inkscape 0.48.

The problem comes in time, when i open a file at the explorer with (open with). after some open's and closings of the programm (in time) the program will not do the "SAVE AS" dialog. "SAVE AS COPY" still works. But after some times even this isn't working anymore.

My theorie is that inscape somehow tries to open the last save folder and is failing.

GurgiONE (elektronikbox) wrote :

Adittion.
I'm using a GERMAN version of Inkscape. Some folders got special letters like ö ä ü. Just in case.

Alvin Penner (apenner) wrote :

- could you compare your symptoms to Bug 805095 (no File->Save As... dialog box if previously opened a file from root directory of a drive)
- for example, have you ever saved a file to the root directory of a device?
- have you ever saved a file to a network drive, that started with '\\' ?
- if neither of these are true, can you copy and paste here the complete names of the directories you have recently saved to?
- also, would you be willing to try upgrading to the most recent stable version of Inkscape, 0.48.3.1, available at:
  http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/
  (this version has a fix for Bug 805095)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions