inkscape text tool font selector is broken

Bug #273961 reported by Wahooney on 2008-09-24
20
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

When creating text with the Text Tool, selecting a font in the combo-box doesn't create the new text object with that font.
Once the text object is created you cannot use the combo-box in the Text Tool to change the font.

I posed this issue to the guys on IRC and I was told that this issue is know, albeit in a different form, some users have to select the font from the combo-box, click the font with the mouse then hit Enter before the font is applied.

This bug was tested on:
Windows XP
Inkscape 0.46 stable
Inkscape 0.46+ nightly.

Marcin Floryan (mfloryan) wrote :

I would say that this actually is a duplicate of #168320 but at least please have a look at that one as well. Indeed a known and long-outstanding issue anyway.

Marcin Floryan (mfloryan) wrote :

Confirmed.

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
valent (valent-turkovic) wrote :

I can confirm this bug on Fedora 10 with Inkscape 0.46

Can I provide some additional feedback in order to fix this issue?

prkos (prkos) wrote :

I'm on fedora 9 and I can't reproduce it on 0.46 or dev build. I thought this was a windows only issue.

I don't know...but now i don't have problems...is possible that someone
fixed it.

2008/12/3 valent <email address hidden>

> I can confirm this bug on Fedora 10 with Inkscape 0.46
>
> Can I provide some additional feedback in order to fix this issue?
>
> --
> inkscape text tool font selector is broken
> https://bugs.launchpad.net/bugs/273961
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Inkscape: A Vector Drawing Tool: Confirmed
>
> Bug description:
> When creating text with the Text Tool, selecting a font in the combo-box
> doesn't create the new text object with that font.
> Once the text object is created you cannot use the combo-box in the Text
> Tool to change the font.
>
> I posed this issue to the guys on IRC and I was told that this issue is
> know, albeit in a different form, some users have to select the font from
> the combo-box, click the font with the mouse then hit Enter before the font
> is applied.
>
> This bug was tested on:
> Windows XP
> Inkscape 0.46 stable
> Inkscape 0.46+ nightly.
>
>

--
Paolo
skype paolo_boz

valent (valent-turkovic) wrote :

On Wed, Dec 3, 2008 at 9:49 PM, prkos <email address hidden> wrote:
> I'm on fedora 9 and I can't reproduce it on 0.46 or dev build. I thought
> this was a windows only issue.
>
> --
> inkscape text tool font selector is broken
> https://bugs.launchpad.net/bugs/273961
> You received this bug notification because you are a direct subscriber
> of the bug.
>

This definitely is a bug on Fedora 10 running Inkscape 0.46.

Look at the video capture and see for yourself:
http://www.youtube.com/watch?v=i9aiLKXLGPo

--
http://kernelreloaded.blog385.com/
linux, blog, anime, spirituality, windsurf, wireless
registered as user #367004 with the Linux Counter, http://counter.li.org.
ICQ: 2125241, Skype: valent.turkovic

valent (valent-turkovic) wrote :

This definitely is a bug on Fedora 10 running Inkscape 0.46.

Look at the video capture and see for yourself:
http://www.youtube.com/watch?v=i9aiLKXLGPo

Ernie (ebell351) wrote :

It's also a problem with the Windows XP version.

Ernie

valent (valent-turkovic) wrote :

do you need any more feedback regarding this bug?

Keith Henn (keithahe) wrote :

I also had this problem on SUSE 11.0 with Inkscape 0.46. Looking at the console errors it couldn't find the font Bitstream Vera Sans in the font selector list. Installing the Bitstream Vera Sans font on my system appears to have solved the problem. Hopefully this helps.

Keith

MARINI (iorismekda) wrote :

And in my interpid also my windows version at inkscape 0.46

ccanepa (ccanepacc) wrote :

for what is whort, in win XP + sp3, installing from Inkscape-0.45-1.win32.exe ( found in the inestable builds for windows 32) the problem is not present.
The inestable dated 2009-04-24 manifest the problem.
I noted the problem begun around the 0.46 launch.

ccanepa (ccanepacc) wrote :

as a workaround to set the font name and size, you can
1. select text tool
2. click in the draw area
3. issue <ctrol>+<shift>+T [ the font select dialog popups ]
4. adjust at will, and then press the button 'set as default'

The font name, size and variant will be used for all subsequent text, BUT: if you click in the toolbar font name, or size, the font name will reset to the inkscape default ('Sans' in winXP). Sometimes the buttons for bold-italic also triggers the reset. The font reset dont show at the toolbar click, but at the first keypress after the click.

bbyak (buliabyak) wrote :

fixed in svn

Changed in inkscape:
status: Confirmed → Fix Released
valent (valent-turkovic) wrote :

FYI, I have posted this video a while ago:
http://www.youtube.com/watch?v=i9aiLKXLGPo

And this bug is still present in latest Fedora 11, the strange thing is that inscape works if you have bitstream-vera-sans-fonts package installed, but try
yum remove bitstream-vera-fonts (F10)
yum remove bitstream-vera-sans-fonts (F11)

Now try to type some text and change it's font in inkscape...

You can do this as a prank if somebody leaves his desktop unattended just remove bitstream-vera-fonts package and ask him to do something in inkscape with text ;)

I'll report this bug to fedora and ask that bitstream-vera-fonts gets installed as a dependency for inkscape.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers