Limit of 100 x 100 cells in "Rows and Columns" dialog is too small

Bug #268576 reported by Alexandre Prokoudine on 2008-09-10
4
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Johan Engelen

Bug Description

I use the awesome Inkscape to create bitmaps for pattern generation on nanofab tools.

I often need bitmaps with regularly spaced objects. Inkscape limits me to only 100 objects/columns in a row. And it's a pain to paste one object 100 times then do a 'row & column' command.

Do any fellow users know of a work around? Thanks!

Changed in inkscape:
importance: Undecided → Wishlist
jazzynico (jazzynico) on 2010-07-02
tags: added: objects ui
Andreas Becker (abecker) wrote :

In 0.48.2, the limit is 500 rows or columns, and that is already too high for my system.
The workaround is easy, just apply the tiled clones effect multiple times. It is necessary to group the row after each tiled clone.
I set to "fix released", because the limit has become higher (and high enough, because the workaround works).

Changed in inkscape:
status: New → Fix Released
su_v (suv-lp) wrote :

> In 0.48.2, the limit is 500 rows or columns, and that is already too high for my system.
> The workaround is easy, just apply the tiled clones effect multiple times.
>
> I set to "fix released", because the limit has become higher

Reopening - 'Rows and Columns' does not refer to 'Tiled clones', it is a dialog of its own in the menu 'Object' and the number of rows and columns is still limited to 100 in 0.48.2 and 0.48+devel r10520).

Changed in inkscape:
status: Fix Released → Confirmed
su_v (suv-lp) wrote :

Note that recommending 'Tiled clones' is not a general workaround to overcome the limitation: 'Object > Rows and Columns…' is used to arrange a number of existing objects in the current document, which not necessarily are clones of a single object.

Johan Engelen (johanengelen) wrote :

I set the max to 10000, hope that is enough. I also increased the significant digits for the offset params.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions