XAML export invalid because of empty transforms

Bug #266909 reported by Ken MUse on 2008-09-05
6
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
Nominated for 0.47.x by Rob Oakes

Bug Description

Performing an export of a complex design results in invalid XAML. Specifically, after moving and positioning objects (and in some cases performing undo to revert the change), the exported XAML contained a number of empty Transform tags. This creates an error when importing the file into other XAML tools because the tag is required to have a transform if present. See also #220711

Ken MUse (ken-muse) on 2008-09-05
description: updated
jazzynico (jazzynico) on 2009-08-06
tags: added: exporting xaml
tags: added: transformations
Simone Romano (mail-sromano) wrote :

It seems to be directly connected to Radial Gradients:

How to reproduce:
Create a simple rectangle with uniform color, save it in xaml format and it will work with IE.
Just modify the fill color of the rectangle to any radial gradient, export agait to xaml and it will produce the error.
Come back to uniform gradient or even linear gradient and il will work again.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape 0.47.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :

Probable the same cause as in Bug #573512.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

...and Bug #220711 is not related at all.

jazzynico (jazzynico) wrote :

Partially fixed by a patch detailed in Bug #573512.
The exported xaml is no longer invalid, but transformed shapes with gradients still have position problems.

jazzynico (jazzynico) wrote :

Closing this report as fixed in 0.48. The known remaining issues are listed in the wiki (http://wiki.inkscape.org/wiki/index.php/SpecXAMLExport).
Feel free to reopen this report if you run into the empty transforms bug again with a recent Inkscape version.

Changed in inkscape:
milestone: none → 0.48
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers