colored and labeled guides

Bug #263069 reported by jimmac on 2008-08-30
2
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Felipe "Juca" Sanches

Bug Description

Enhancement request -- alow individual guides to be colored and labeled. When using many guides it's tough to figure out which is which. In my case, I was drawing font glyphs and I wanted the most important guides, the baseline, ascender and descender to be prominently colored/identifiable while I needed a lot more.

prkos (prkos) wrote :

I also think it would be very useful. It looks like the work has started already http://wiki.inkscape.org/wiki/index.php/SpecGuidesImprovement

description: updated
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
su_v (suv-lp) wrote :

Reverting the duplicate link:

Recent work by Felipe "Juca" Saches to enhance Inkscape for font editing added labeled guides as well as a set of extensions to help setting up documents for designing glyphs.

Changing status to 'In Progress' and assigning to Felipe.

Changed in inkscape:
assignee: nobody → Felipe "Juca" Sanches (felipe-sanches)
status: Confirmed → In Progress
su_v (suv-lp) wrote :

An early documentation of the new features by prokoudine:
<http://libregraphicsworld.org/news.php?readmore=805>

It is done. :-)

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

@Felipe - what about colors? ;)

yeah, we still dont have a way of setting up the guide colors

Changed in inkscape:
status: Fix Committed → In Progress

implemented user interface for setting guideline colors in bzr revision 10315. We still need to save this info in the XML tree.

su_v (suv-lp) wrote :

Inkscape creates corrupted files (r10315 and later) if saving the file after changing the color of a guide in the 'Guides…' dialog:

/Volumes/blue/img/Inkscape/test/bug/263069-colored-guides-4.svg:70: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0xFF 0x2C 0x22 0x20
       inkscape:color="rgb(?," />
                           ^

The file can no longer be opened in Inkscape.
(tested with Inkscape 0.48+devel r10315, r10320 on Mac OS X 10.5.8 (i386))

su_v (suv-lp) wrote :

File corruption due to custom color has been filed as new report:
Bug #823739 “Guide color change corrupts SVG”

su_v (suv-lp) wrote :

Editing labels may produce corrupt SVG files as well: see
Bug #1029033 "Guide labels are not getting saved to SVG"

su_v (suv-lp) wrote :

Guide colors are not loaded from the file:
Bug #1374870 “Guide colour not rendered opening saved document”

su_v (suv-lp) on 2014-09-28
Changed in inkscape:
milestone: none → 0.91
su_v (suv-lp) wrote :

Closing this one as 'Fix committed' since known regressions / missing features have been reported separately.

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
Pedro de Carvalho (p.c) wrote :

Hi everyone! Great job on this latest release! the performance is incredible!

i've been enjoying inkscape to make a catalogue, but i found some problems:

1- Color guides don't stay in document after closing and opening it again.

2- If I name a guide, all the guides start to flicker under the mouse.

i can do a screencast if it helps to illustrate these problems.

ps: can't wait for multipages in 0.94!

su_v (suv-lp) wrote :

On 2015-09-22 12:41 (+0200), Pedro de Carvalho wrote:
> 1- Color guides don't stay in document after closing and opening it
> again.

Tracked in bug #1374870.

> 2- If I name a guide, all the guides start to flicker under the mouse.

Please file a new report and include details about OS/platform there, as well as steps to reproduce.

Pedro de Carvalho (p.c) wrote :

wow, i see there's a fix committed already! great!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers