configure should use boehmgc.pc pkgconfig file

Bug #261409 reported by hawkes on 2008-08-26
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Alex Valavanis

Bug Description

As boehmgc provides a pkg-config file since 7.0alpha, one should update the configure.ac of inkscape to use this file. see http://osdir.com/ml/programming.garbage-collection.boehmgc/2005-09/msg00001.html for more information

su_v (suv-lp) on 2010-02-18
tags: added: build
Alex Valavanis (valavanisalex) wrote :

Confirmed, but pkg-config name seems to be bdw-gc

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
Alex Valavanis (valavanisalex) wrote :

Patch added to replace our custom tests for libgc with a call to pkg-config. Running a test-build now

Alex Valavanis (valavanisalex) wrote :

Should be fixed in lp:inkscape r12155. We now use pkg-config for this.

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
status: Triaged → Fix Committed
su_v (suv-lp) on 2013-02-25
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers