Unweirdification of Preferences dialog's menu

Bug #259480 reported by Alexandre Prokoudine on 2008-08-19
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
jazzynico

Bug Description

Preferences dialog is getting pretty crowded these days.

Here is suggested outline for the part outside Tools group:

Behaviour
 Clippaths and masks
 Clones
 Filters
 Mouse
 Scrolling
 Steps
 Selecting
 Transforms
User interface
 Toolbars and menus
 Windows
Input/Output
 Autosave
 Bitmaps
 Open Clip Art Library
 SVG Output
Grids
Color management
Misc

Also:

1. Mouse should rather be renamed to Input Devices or even Pointer Devices or just Pointers as its settings apply to both mice and tablets.

2. "Prevent sharing of gradient definitions" from Misc should probably go to Gradient Fill tool page.

3. "Latency skew" and its hint sound too technical.

jazzynico (jazzynico) wrote :

And we could add Snapping in Behaviour, and Spellcheck just before Misc (not sure for this one...).

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: ui
jazzynico (jazzynico) on 2010-07-02
tags: added: preferences
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
jazzynico (jazzynico) on 2010-07-17
Changed in inkscape:
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Apparently, it's time for some clean-up...

Suggestion:

== Toolbar == (previously tools)
All the tools in the toolbar, sorted as in the UI.
"Prevent sharing of gradients" option in the Gradient tool (previously in Misc).

== Tools ==
* Clones
* Clippaths and masks
* Spell check

== Interface == (+"simplification" option from Misc)
* Windows
* Selection
* Transforms
* Grids
* Scrolling
* Snapping
* Steps
* Filters ("Show primitive info" from Rendering)

== Input-output == (previously Import/Export, +"Use current dir for Save As" from Save)
* Input devices (previously Mouse)
* SVG output
* Bitmap (+"Resolution" from Import/Export)
* Color management
* Autosave
* Openclipart

== System == (previously Misc)
* Performances (threads/cache)
* Rendering (here or in Filters, not sure).

Comments welcome!

What about giving the dialog a Gimpy look?

jazzynico (jazzynico) wrote :

Change committed in the trunk, revision 10861.

Changed in inkscape:
status: In Progress → Fix Committed
Edouard (edouardst) wrote :

JazzyNico, how complex would it be, in the "Toolbar" subsection, to put the icon of each tool next to its name ? New users should then be able to better "catch" the meaning of it. And the icons would be reused from the interface so not much weight gain for the program.

jazzynico (jazzynico) wrote :

@Edouard - I don't know how complex it would be. Since the icons already exist, I guess it wouldn't be too difficult for someone (not me) with Gtk knowledge.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers