"Object to Path" should work for Connectors

Bug #257223 reported by rubik-cube on 2008-08-12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Matthew Petroff

Bug Description

At the moment, "Object to Path" doesn't seem to do anything when applied to Connectors, it only says "No objects to convert to path in the selection."

This is annoying, the only way to convert them is to do it manually in the xml editor or a plain text editor.

What it should do: Simply remove the inkscape:connection-end, inkscape:connection-start and inkscape:connector-type attributes.

I think this could be a nice beginner's bug, probably easily fixed by anyone who wants to start with inkscape.

Related branches

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) on 2009-12-24
tags: added: connectors
~suv (suv-lp) on 2013-03-04
tags: added: easy-fix
jazzynico (jazzynico) wrote :

Still reproduced on Windows XP, Inkscape trunk revision 12228.

Changed in inkscape:
status: Confirmed → Triaged

The attached patch removes the connector attributes when a path is a connector and should fix the bug.

jazzynico (jazzynico) wrote :

Looks good on Windows XP, Inkscape trunk 12304. No regression found so far, but I'll test again later on Debian with more test cases before committing.
Thanks for the patch!

Changed in inkscape:
assignee: nobody → Matthew Petroff (matthewpetroff)
milestone: none → 0.49
status: Triaged → In Progress
~suv (suv-lp) wrote :

Patch tested successfully on OS X 10.7.5 with Inkscape 0.48+devel r12312.

jazzynico (jazzynico) wrote :

Tested successfully on Debian testing, Inkscape trunk revision 12312.
Patch committed revision 12313.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2013-05-01
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Removing the backport-proposed tag. Too difficult (risky?) to backport due to changes in SPItem.

tags: removed: backport-proposed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers